X3D import hangs with some files - is it in an infinite loop?

I’m having a few problems with the Blender x3d importer. My x3d files are just spheres, but as the number increases the importer seems to hang. The files are not very big, only 191KB and 286KB, 641KB (attached). The smaller one has 2304 spheres and takes a minute or two to load, the middle one has 3456 spheres and sometimes hangs and sometimes loads, and the large one has 7776 spheres and seems to hang forever.

When it hangs Blender seems to continually fire-up for a few seconds (CPU and memory are being allocated to Blender) and then it disappears from the active processes, only to appear again a few seconds later.

I’ve tried it on Windows 10 with Blender 2.75 and Ubuntu 14.04 with Blender 2.77 and get the same behaviour. I don’t think it is a memory or CPU problem as I tried it on an AWS c4.8xlarge EC2 ubuntu 14.04 instance (36 vCPUs & 60 GB RAM) and that hung too, the file wasn’t imported when left overnight!

I found that someone else seems to have seen similar behaviour (https://www.blender.org/forum/viewtopic.php?t=25641) but there doesn’t seem to have been a solution.

It seems as if the importer is getting stuck in some sort of infinite loop.

Any help in solving this would be much appreciated.



x3dfiles.zip (135 KB)

Ok I’ve got it working with a fresh install of Blender 2.77 on AWS EC2 ubuntu 14.04 and running apt-get update and apt-get upgrade before installing Blender. I’m still not sure what the problem was.