YABLE error!!

I am recieving an error that will not let me execute the YABLE script.

Here is what I get when I hit “ALT-P”:




I was just using the script today and now I cannot ge it to work all of a sudden. I DID assign some new UV textures to him but I tried to open a scene that I had NOT messed with and the script still fails. Let me know. Thanks ahead of time.

Oh…before I forget I tried it in 2.27 as well as 2.28 so that isnt it either.


Looks like it does not want to overwrite. I had this problem, I quick fixed it by moving my files from the Yable folder temporarily.
From what I have figured out, if I save a file ( named “theremin” for example) , and I close Blender…when I open Blender up again and start Yable, it will try to save it as "theremin"still.

Dude…sweeeet…so…your saying that all I have to do is move all of myfiels out of that directory…run YABLE again…and then place them back in again? The weird thing is that it wont even let me execute the script…strange huh?

Thanks for the help man. I really appreciate it!


If you have Problems using Yable with Blender 2.28, you should use Blender 2.26. Don’t forget to convert Text in curve if you use TTF fonts :))


First I would like to thank everyone for their help. Thanks to JA-forreal-forreal my problem has been solved. Refer to this thread over at the YAFRAY site for his answer:



And here I am…with my foot in my mouth…mumbling about how I should have actually tried to export a file before claiming my problem had been solved…AHHHHHHHHHHHH!

Ok…I can now execute the script…tweak settings and such…but as soon as I go to export it starts looking as though it is trying and gets hung up on the following message:


well…ok…its official…I am back in the saddle again boys! I have a fully functioning YABLE…and I am back in business with the YAFRAY version of the Airman once again…just one day before I have to go back to work…thats right…I spent my entire vacation trying to get this damn thing to work only to have gotten rid of my problem by uninstalling python…putting 2.2.3 back in, and using the original YABLE (not YABLE X)…who knows…I dont care…as long as it works!!!

Take care everyone. Also, if anyone else out there has come along this message in search of answers to a problem of thier own…feel free to contact me and I will do as much as I can to assist…I dont know much but I will share what I do know and have learned in this little adventure of mine.