Yaf(a)ray Installation issue: libopenexr2ldbl

  1. Yaf(a)ray 0.1.0 wont install on my M/c.
    Error: Dependency is not satisfiable: libopenexr2ldbl

I have Ubuntu 8.10 64bit + Python 2.5 (from Ubuntu rep) + Blender 2.48a (from getdeb) installed.

I have 2 installation files (from http://www.yafray.org/index.php?s=2) :
yaf_blender_282_amd64.zip - Blender Integration scripts

  1. What is the purpose of the 2nd file?

i could have written this actually as i have exactly the same problem. i hope someone can help.

i tried this, it seems to be installed i don’t have time to test it right now sorry. but you can try:

$ sudo dpkg -i --force- yafaray_0.1.0.282_amd64.deb
(Reading database … 142212 files and directories currently installed.)
Preparing to replace yafaray (using yafaray_0.1.0.282_amd64.deb) …
Unpacking replacement yafaray …
dpkg: yafaray: dependency problems, but configuring anyway as you request:
yafaray depends on libopenexr2ldbl (>= 1.2.2); however:
Package libopenexr2ldbl is not installed.
Setting up yafaray ( …

please, let us know if it works for you.

Everybody (Linux users only) please share your hw/sw configuration in the format below:

CPU: Intel Quad Core Q6600 @ 2.4GHz
Operating System: Ubuntu Intrepid Ibex 8.10 64bit.

Blender version: 2.48a
Source Link: http://www.getdeb.net/download/3468/0

Yaf(a)ray version: 0.1.0 (cannot install)
Source Link:http://www.yafray.org/index.php?s=2

Any other renderer version:
Source link:

I would like to understand working combinations.

Got this error message.

dpkg: error processing yafaray_0.1.0.282_amd64.deb (–install):
cannot access archive: No such file or directory
Errors were encountered while processing:

The .zip file contains the python export scripts. They should be extracted and placed in your .blender/scripts folder.
I had a similar problem with libopenexr when upgrading from 7.10 to 8.04. I solved it by building from source. (If this appeals there is a guide here)

(I assume you noticed the version of Yaf(a)ray you have is for Ubuntu 8.04 ?)

Well, there was no link for downloading for Ubuntu 8.10. so does that mean Yaf(a)ray is not supported for Ubuntu 8.10.

I will certainly try the ‘building from source’ option. though I am not so comfortable with the same.

I am sure there must be some user who must be using Ubuntu 8.10 64bit and Blender 2.48a and still managing to get the latest version of yaf(a)ray to work with blender.

I couldn’t honestly say.

There is a script that simplifies the build process, but since the scons upgrade thing it has been slightly problematic - though only the building Blender part. I don’t know whether the dependencies are all available for 8.10, I’m still using Hardy.

i have now a working blender 2.48a with yafaray!
the only thing i had to do is installing the package libopenexr2ldbl (hardy version) from packages.ubuntu.com.
here’s the link:

hope it also helps to you :smiley:
by the way, i use the same spec. exept that i have 2.1 GHz core2dual cpu.