yafaray renders of face borders wierd looking

Hi Folks,

I’m trying to model a loudspeaker (a B&W 704, if you care). The render with YafaRay looks as though the thin pie-slice faces are somehow influencing the result. I am using the “painted wood” (cloud) texture as recommended here: http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Every_Material_Known_to_Man/Woods.

Using the Blender render I don’t get the wierdness. See bottom for YafaRay and Blender renders, and for a Blender screenshot showing the faces and normals.

My blender settings:
Map Input: ORCO, Cube
Map To: Col

YafaRay material is shinydiffusemat.

Is there a Better Way? Have I don’t something horribly wrong? Any ideas?



As you can see from the blender screenshot below, the the normals all point outwards, and the faces are all parallel:

in YafaRay it looks like this:

and with Blender:

if I set any face of the object smooth, then I get this effect. It does not matter if the face is in a mesh connected to the speaker-box mesh – it can be in the grill or the tweeter mesh. What’s going on?


The topology is bad. You might get away with subdividing those long edges once or twice, though a better approach would be to get rid of the triangles entirely.

Thanks (again) organic :slight_smile: Can you describe in this case how you would “get rid of the triangles”? Is there somewhere some documentation about good and bad topology?



Alt-J makes triangles quads (edit mode).

Everyone has their own preferences, but most people agree that quads are easier to work with if you intend using a subsurf modifier or smooth shading.

Using loops to control edges is fairly efficient and quite versatile:- http://pedroalpiarcadossantos.webuda.com/Elbows.html

Or look at some hard surface modelling tutorials.

thanks again for your help. I played around a lot with using a subsurf mod and creasing the sharp edges and/or using the edgesplit mod on the edges adjoining the faces I wanted to smooth.

In this case the edgesplit mod turned out to be a quick-n-dirty fix. I was able to apply it to my nasty topology, and now the speaker sides appear flat (render attached). I really appreciate your taking the time to help.