Yafaray Textures not visible with Blender 2.62

Hi guys,

It’s been a while since I last used Yafaray, thought I’d give it a whirl. I’m having issues with UV texture maps, they aren’t appearing, both in the UI and also in the render.

Blender 2.62 (Emended)
Yafaray 0.1.2 Beta 3 + Blender 2.62 Exporter (9th March)

It works fine in BI, and I also unticked Cycles in the preferences in case there was an issue there.

All my paths as far as I’m aware are directed to the correct location.

Any ideas?

Cheers, Jay :wink:

I think the latest yafaray don´t work with 2.61.
No problems here with 2.62 and YafaRay 0.1.2 Beta 3
You get it here:

Cheers, mib.

Darn, sorry mib2berlin,

My bad, I am with 2.62 - forgot I’d installed it! I’ve emended the above post. I’m also using the latest YafaRay 0.1.2 Beta 3, with blender 2.62 exporter.

Guess it’s a bug then :wink:

Hm, this combo should work then, this file work for me.


Cheers, mib.

Possibly you are already aware of it, but the beta 3 doesn’t work with builds more recent than the official 2.62 release from blender.org. Graphicall.org and other svn builds are not currently supported.

Yeah organic, I’m using the stock svn version of 2.62, I’ll check out you file tomorrow mib2berlin - curious what it is -don’t have yaf installed on my laptop yet. :wink:

Well mib2berlin, as I never stop working it seems - (damn 3D - look at the bags under my eyes!), curiosity got the better of me :wink:

I downloaded your file, the texture showed up in the 3d camera viewport, but when I hit render, nothing - just a blank screen as before, plus there was not texture displayed in the properties panel.

What’s going on?

I’ve installed 2.62 blender, installed yafaray (above mentioned version) as directed through the vid clip, Yafaray is ticked in preferences and running - no problems rendering, but soon as I add a image texture, just a black screen which doesn’t even attempt to render :frowning:

Makes me really sad, I thought I’d give it a crack as Yafaray seems to be moving on again, but with these kind of bugs it’s not lookin good.

Additionally I posted this on the yafaray.org forum this afternoon, and still my post isn’t displayed there, 7+ hrs later - sucks!

I tried to install the 32 bit version on my laptop, and that complained about missing opencl.dll drivers too - so couldn’t install at all.

Darn, I know it’s a beta, but I can’t be the only one - my machine isn’t that odd.


Does the error message still state Blender 2.61? Maybe something is using the wrong directory?

I take it the textures are not packed into the .blend? (Yafaray needs them to be unpacked first).

Can you upload a file for testing?

I had a similar problem on Ubuntu 11.04. It turns out the libpng used to build Yafaray was more recent than the one I had installed. It has since been fixed (within a few hours in fact)

Hi, here’s a test file - just a plane with a uv mapped texture. No texture included, just substitute for one of your own.


Here’s a screen grab of the console too:

Thanks in advance if anyone knows what’s going on :wink:

Well, looks like it was pretty simple - guess it’s my error in the end.

I was using this version:

But after trying:

It worked fine.

Thanks for the help :wink:


Cheers, mib.

The experimental build must not support textures. I was having the same problem and found this thread looking for an answer. Fixed it for me as well.