Yafray Animation - Different Background every frame

Hi, i hope this is the right subforum to ask this question, if not, mods, please move this thread where it belongs.

I’ve got a serious problem. I’m doing a little spot for a magazine, where I hav an animated camera movement. As for quality issues I decided to use yafray as the renderer for this purpose (I’m new to yafray, maybe this is my only problem).

Now everything works fine, when it comes to every single frame, but when I render the whole animation, there is something “funny” happening with the background. somehow the shading of the background differs slightly between the frames, what makes the bg look “moving” when it comes to the animation.

Can this be an issue of me using spots an area lights (Samples are set to 1 in the Lamb options … maybe this is the problem).

Would Photon lights instead of the current ones improve my Picture, and if, how would I have to set them up?

Here are two pictures out of the spot where you see the differences, when you look above of the cover (those are upcoming frames, and the lights are not changing, only the cam position)



I don’t know YafRay, so I can’t help you there, but I have a suggestion. You don’t seem to be using any of the features that are unique to YafRay (like global illumination), so why use YafRay at all? You could easily get those results using the internal renderer.

The spotlights may be the culprit. Are the spotlights animated as well, or just the camera?

Well, at first i used GI (it is turned on too, but the light setup is the reason for no shadows) but then the guys didn’t want any shadows (where i thought the only want less shadows).

Only the camera is animated, everything else is still.
Would you think that returning to the blender internal renderer won’t cause such bad effects?

Since the spotlights aren’t animated, I doubt they are causing the problem. I do think the problem would go away with the blender internal renderer. I now suspect that the GI is causing the background to change between frames. If you decide to stick with YafRay, maybe try increasing some of the quality settings for the GI.

this shimmering effect occurs because the GI is calculated using a semi-random process that changes seeds every frame.

You will need to increase the precision of the GI solution by increasing the GI quality and the shadow quality. This will increase render times but make the background appear more consistent.

The process is imperfect so it will likely never be possible to completely eliminate the shimmering, but it can be made imperceptible.

Irradiance cache is only for stills. What it does is picks some pixels and calculates GI and then interpolates it with the surround samples. This results in some noise which will appear as flickering in an animation. It is a shortcut b/c it avoids calculating GI at every pixel.

If you want no flickering at all, you must turn off cache. But be advised, this will increase your rendertimes dramatically (in one of my cases, 20min with caching as opposed to 41hours without caching!)

You could refine the caching parameters so the flickering is less noticeable, but it won’t entirely disappear.

You should read this. It talks about caching, lighting and different rendering settings in Yafray.(approx 5.3MB)

thx for your thoughts about my problem, but it was more simple, than you thought.

I turned on the “tune photons” button, but didn’t know exactly what it does: it draws the photon map into the picture, what makes this noise in there :smiley: