Yafray Does nothing!!!

When I use Yafray to render anything, I get nothing. Im using G-4 MAC and am running OS10.4 and have latest Blender and yafray. Am I missing something because All I get is a Black screen in the render box. Please help.


Did you download the latest yafray?

If not do so.

Hello zigzaviour,try to toggle this button (XML) off,and render the scene,you should see a progressive render …


hope it’s helpful.

Yeah, I did that one. :expressionless:

It is hard to see the problem. Can you upload the BLEND file? In the meantime, turn your lamps up very high.

Use Skydome and LOW quality, Cache on, change the World Color to White (from the default dark blue) and turn XML off

I tried your idea of delecting the XML tab and still blank pic. Not sure what im doing wrong or not doing. Thanks very much though. Any other suggestions please let me know.

Can you tell us what message you get in the console?

I get no error message, I just get a blank viewing area. Its all black with no imagery. When I open the exported file its all white with no imagery. Is there any good tutorials or pages that explaine Yafray in detail. And yes I do have the very latest version of Yafray.



I had the same problem after intalling de 2.41.
It was solved by reinstalling the yafray too.

Blender’s lights can get pretty dark when rendered in YafRay. Try turning up the light energy. If you’re doing GI, increase the GI power.

hey how did u get tht skin to look like that? my blender is just gray and boring!

[hey how did u get tht skin to look like that? my blender is just gray and boring!]

I think there is a theme option where you can customise it. I like it to. Al Could you give us your theme file? thx %| [/quote]

Hello everybody,
zigzaviour, you open a console window and execute blender in it, when you render your scene and get the black image,take a look at the console and reporte the message you see there.

OneToBeamScotty and jumpy-monkey here is a blend file containig the theme script.

Execute the script (ALT+P)


Thanks Al, I will try your suggestion and see if I see anything. LOL If not then I will be going through the forum to dig up some more clues as to why Im having the problems with Yafray. Thanks for the advise.