Yafray Light Problem

Hi,
Here is my WIP I’m working on.
This is an interior scene representing my apartment.
I used area lights from windows. Now I try to add a lamp (Buf. Shadow) on the ceiling upstairs and here is what I get … It’s strange, isn’t it ?
Can someone explain me what happened ?
Thx in advance

http://www.image-dream.com/image.php?image=a681ae812b20647d854dc2c3ee85a1ae.jpg&pseudo=anonym

I’d like to help You, but can’t see the picture…
broken link?

Yes, broken link but it will work soon again…

When I saw the original it looked like caustics. Do you have a photom map and glass in the upstairs area? Also your GI may be too low to loook right for the large area.

I meant photon lamp.

No, I have no photon lamp or glass, just a lamp on the ceiling !
The result is surprising
Any idea ?

lack of data :expressionless:

  1. what kind of light is this?
  2. it’s settings?
  3. is there any glass object between Your lamp and camera?
  4. GI settings?
    You should post *.blend /(best option) or screenshots at last, other way we can just guessin’.

Once I had similar problem, but for other reasons had to reorganise scene and problem dissapeared…

Here are the different settings:

http://www.image-dream.com/image.php?image=8e25a1dd4a1b2aa375285920ba0b85b9.jpg&pseudo=anonym

http://www.image-dream.com/image.php?image=f43d6e94a03c48592a16a6b2b443ba12.jpg&pseudo=anonym

There is no glass between lamp and camera
I hope that it will help you !
I will post the .blend file later because at the moment I found no website for hosting my files

http://download.blender.org/documentation/bc2004/Alejandro_Conty/

What are your settings?

Auto AA =
Clamp RGB =
AA Passes =
AA Samples =
Psz =
Thr =
Raydepth =
Bi =
Gamma =
Exp =

Method =
Quality =
Cache =
No Bump =
Shadow Qu. =
Prec =
Refinement =
EmitPwr =
GI Pwr =
Depth =
C Depth =
Photons =
Count =
Radius =
Mix Count =
Tune Photons =
Render Time =

I think it will be better with these screenshots:

http://www.hiboox.com/vignettes/106/bomtr0z.jpg

http://www.hiboox.com/vignettes/106/g4gkpwq.jpg

http://www.hiboox.com/vignettes/106/9gttala.jpg

And th render time is 2 hours with Best in GI option

Seems to be simple to solve.
I see You use just three arealights - two downstairs and one upstairs. You make them to emit 600 000 photons, 200000 per each arealight. In the render You can see directly two of them (400 000 photons), but third produces light that bounces allaround upstairs and only a few of its photons falls down staircase. You can count them - each of those patches is one photon. So You lose most of them.
You made basic gaffe trying to reconstruc reality - you have to immitate it.
Try remove third arealight and simulate it’s bouncelight with slightly coloured spot with soft shadows.
but if I were You, I would separate part of model You work on to decrease number of vertices, to get only room on the first plane, staircase and corridor upstairs with door to the room where You have window. I’d place there arealight that matches this door, decrease it’s power and change it’s colour.

BTW decrease arealights power and double GI Pwr.

try those tuts:
http://cgarchitect.com/resources/tutorials/default.asp

Thank you very much for your advice !!
But in my scene, I use three arealights downstairs (2 on the main room and another one in the bedroom) and a lamp light upstairs (and this lamp is the source of the problem)
So what should I do ?
I know it will be simplier if I could post the blend file but I found no free website.
Another question: why do I have to decrease arealights power and double GI pwr?

Right
It seems to me, that Your lamp is on the meshes edge…

about GI
read this:
http://www.blender3d.org/cms/Alejandro_Conty.450.0.html

send blend to me:
jendrzych(at)o2.pl

Thanks for the tuto
(I’ve just sent the blend file)

That’s why it’d be better to decrease arealights power and increase GI pwr
this scene settings: two arealights power=1, GI power=7
http://img465.imageshack.us/img465/5555/1daygi78zj.th.jpg

this scene settings: two arealights power=7, GI power=1
http://img465.imageshack.us/img465/2905/2daygi12dy.th.jpg

Playing with your *.blend I found, that the problem is somehow related with distance between lamp and mesh. I did some tests (red poin shows position of a lamp).
Its something similar to your case:
http://img466.imageshack.us/img466/2505/1wrong0ng.th.jpg

And possible solution:
http://img466.imageshack.us/img466/4009/2corrected4oh.th.jpg

In some cases moving lamp away from celling may cause unreal shadowcasting, because of wrong lamp position, so I recommand to use wide angle spots with soft shadows.

Very interesting what you have discovered.
Thank you again for your help !