Yet another “Why Doesn't My Shader Displacement Node Work?!?!?” post

Of course I’m missing something basic, but googling around hasn’t found it, sorry:

3.0, reasonably high-density mesh, even higher thanks to sub-d. Displacement Node’s scale should be high enough (probably too high). Rendering gets me this:

Isn’t this setup supposed to get Suzanne a displaced outline? If I wanted this I’d use a Bump Node into the Principled BSDF – isn’t a displaced outline the point of using Displacement instead of Bump? (And I realize that I could use a Displacement Modifier instead, but that won’t coordinate with Shader Editor same-map effects, which is why I’m trying to do this.)

Anyway, how do I get the Displacement Node > Displacement socket of the Material Output Node to actually, y’know, displace?

SuzDispTest003.blend (4.9 MB)

Is this what you are looking for?

1 Like

Yes! What did I miss?

This is an Utmost Ordeal every newb must complete and memorize.

Jokes aside. This is stupid and I was as perplexed as you when I encounter this issue for the first time.


And I am ever and always a perpetual Blender Noob – I knew I’d forgotten something simple, thanks oodles!

Aren’t we all…

Glad I could help. And good luck!


same, this option shouldn’t even exist it should be something automatic in the displacement node (as a optional thing then there should be a “bump” checkbox as well of course)

1 Like

This setting should be moved from properties panel to displace node, so it’s always visible.

Even now after almost 3,5 years of using blender I’m forgetting where this little fuc**ng checkbox dropdown live. Glad we have properties search, but it’s PITA anyway.


same though…

1 Like