Zoom stops at a point

As in the title, in the attached model, zooming stops at the view position I saved the model. I cannot zoom in any further. Changing navigation properties, view type or clipping distances doesn’t change a thing.

I know the topic is covered extensively on forums, e.g. there:

The best I can do is to use dolly zoom (CTRL+SHIFT+MMB) or border zoom, or scale up my model by 100x, but those solutions don’t satisfy me. I just want to ZOOM, and I’m frustrated that I can’t.

So far this is my first and only model with this issue, so I bet there must be a clever way out.

If I copy my object to a new Blender file, then I can zoom indefinitely, and through the chair beams that I made, which is what I want. It can be the solution in this case, but I’m afraid that I’ll encounter this bug again with a complex model that I’d prefer not to move to a new file. Instead, I’d like to know how to fix zooming issue in this particular model:

zoom issue.blend (877.1 KB)

Try edit mode select any vertex Numpad Point (or Del) for zoom to selected (?) If this isn’t enough… then i don’t know.

Yeah, this helps 50%, I mean: it will indeed zoom to that vertex, closer than I can zoom with my scroll. But then I zoom out and still can’t zoom back in. It’s still uncomfortable, but better than nothing.

But maybe it can be fixed with some view settings that I don’t know.

Oh then there is the addon Stored Views. (I believe its’ build in but not enabled?)

Sure, but still it requires messing around, taking time to save a view. Even clunkier than using dolly zoom and numpad. I just want to fix the heckin zoom.

I’m questing myself: What do you don’t see by zooming this way… I had never any place in any model which i couldn’t reach (so to speak)? I mean given Suzanne for example: someone can select any vertex and zoom in so that almost no other vertex is visible. Just at to outmost border of the view. But as i said… then i don’t know.

I can’t get inside the mesh with my view, for instance: for inspecting against internal faces or other mesh errors. Close-ups are sometimes crucial for making such inspections.

Oh i can see you have overlapping faces while in edit mode vertices because the beam shows no vertex at the end. maybe use x-ray toggle?

I can use many workarounds, but I just want to know if I can fix this zooming issue. It’s not normal, it’s a bug or some mis-setting related to this particular model only.

I opened your file thinking it’s “simply” be the old focal point problem, but this is different. The zoom level stops abruptly, I’ve never seen it happen. It’s enough for me to report it as a bug because as far as I know there should be no hard limit on zoom level as it happens in your file.

1 Like

Thank you, Hadriscus.
Finally, someone decided to treat this issue seriously.
I knew it’s not that old focal point problem. I’m not using Blender since yesterday :slight_smile:
If you make a bug report, please paste a link here.

I’ll let you handle the bug report. There’s definitely something off here.

Hmm i just loaded it as original (load UI and trusted source, top left in image) and without (my setting mostly standard, top right in image, manually navigated to) :


Why is the wireframe visible but not enabled in Viewport Display ?? Lower left just zooming and inside the chair … lower right more zooming and wireframe enabled to see more where it is…

It is strange, no idea how to fix it. You can mitigate it though by turning a different editor (say, the outliner) into a 3D viewport. This new view will zoom correctly, and you can close the broken one (right click header → close area).

As to the cause of the problem, best I could do is find the property that controls the view zoom distance:

pathoutliner → data api display mode → screens → layout → areas → 3rd area in list (has editor type:3d viewport) → spaces → 3d view space → 3d region → 3d view region → distance

For no discernable reason it refuses to go below 0.1 by zooming. If you manually set it, it’ll stay there until you start zooming again, at which point it snaps back to 0.1 :confused:

1 Like

I don’t understand. Wireframe is visible because the wireframe setting under viewport overlays is On.

Oh yes overlays… it seems that i’m more accustomed to the “old” wireframe behaviour/options and a i didn’t think of overlays… thanks, i (re-)learned something about blender :wink:

Hadriscus, they don’t find it a bug. This behaviour is described in Blenders docs, yet I think it’s still a bug (though a known one), and I don’t know why they decided to ignore it.

https://developer.blender.org/T93273

I don’t know what to say… even refocusing the view (alt+MMB) to a point on your model doesn’t allow zooming any further, when it stands to reason that it should. I mean the single fact that you can orbit around it means the camera has not reached the defined focal point.

1 Like

My thought was exactly the same!
I’ll let myself paste this statement into the developer thread, to make them believe.

The Blender doc says: “Use Auto Depth and Zoom to Mouse Position.”
I have these settings ON in my Preferences, but it doesn’t help at all.
What happens if you use both options? Does it solve the issue for you?

I’ll chime in on the bug report, see if it helps clarify the thing.

1 Like