Zooming in Blender 2.54 on MacBook Pro

How can I restore the zoom behaviour of 2.49b for 2.54 on a unibody MacBook Pro (two-finger scrolling)? I have tried using various combinations of the “mouse/trackpad ______” options, but none of them have worked. Is this a known bug, or is there an easy fix that passed me by :confused: ?

Thank you