zooming through orthographic cameras not working (need everyone's help to fix this)

hi, sorry to bother you with a long introduction but i feel it’s necessary

im a Maya user and im trying Blender after i read a curious and taunting post saying that Blender destroys Maya (may have used a less appropriate verb…)
so i’ve been using it for one day and witnessed great improvement over the last decades and also over other 3D software, so much that im inclined to agree with the guy in certain areas

problem is, i’ve already found fundamental problems and it’s only been one day
for example on Orthographic cameras (cameras not views) you can’t zoom on the content while Lock Camera To View is On (which of course should be on if you plan on working, through that view)
in other words you can’t work with Orthographic cameras, i can’t see how could you
although it doesn’t get any more basic than that (it’s like if you couldn’t rotate in a 3D program), the real problem is not that actually
the problem is that what i just described has actually been reported many years ago and been …dismissed by a developer as invalid/working as intended (…)
im a new member and i can’t post links so bare with me
developer . blender . org / T36746

please tell me that im mistaken and there is another way to do that

if you need a detailed description of the problem, then you can follow this long list of SUPER EASY steps:

Perspective Camera

  • open the startup file and press 0
  • now you should be looking through the Camera (and not the viewport perspective)
  • you should also be able to see an Orange bordered rectangle, the Camera’s Resolution Gate (renderable area)
  • now use your mouse wheel, it should zoom in and out everything (Resolution Gate included)
  • this way you can set the (visual) size of the Resolution Gate on your viewport
    now, try this
  • open the Properties Panel Display (N)
  • go to View and tick the settings called Lock Camera To View
  • now use your mouse wheel, it should zoom in and out the scene (not the Resolution Gate)
  • this way you can set the content of the Resolution Gate
    in other words, with a Perspective camera, in two steps you can set your camera view size and also zoom in/out of the scene

Orthographic Camera

  • now select the camera
  • go to the Properties Editor (middle right), select Data > Lens > Orthographic (instead of Perspective)
  • repeat the same steps as before
  • you can see that your mouse wheel will still zoom in/out the Resolution Gate even when Lock Camera To View is ticked
  • in other words you can set your Resolution Gate but you can’t zoom in the scene itself
  • or in other words you can’t work with Orthographic at all

thank you for your time, could the community help to resurface this problem and get it fix? i mean i will probably keep using Maya myself but if im right then no offence but this is a ridiculous problem that needs to get fixed asap

ps: bare with me, im new and my replies probably need to be green flagged by the admins so it may take some time until you see them
thank you

Because nothing happens. Shift+ctrl+drag middle mouse button. You can change the orthographic scale though which is kinda the same thing.

You can post links, images and a .blend. The post just goes to moderation and appears within N days.

Zooming a perspective camera with lock camera to view moves the camera closer, like walking closer to the target so it fills the frame. With orthographic camera there’s no depth, so moving the camera closer in that view doesn’t fill the frame. Orthographic camera has orthographic scale setting to fill the frame, which is equivalent to zooming by changing the focal length with perspective camera.

The whole lock camera to view option is pretty useless when there are so many ways to set up the camera.

and that doesn’t even show all of it.

thank you for your answers

correct, that’s how it’s supposed to work

plz don’t argue just to argue, i read the same thing in stackexchange and i don’t understand where this is coming from and how to reply politely

the orthographic camera has no depth so moving the camera closer in that view wouldn’t bring things closer/bigger?
how come i’ve been using Blender for just one day and i’ve already seen it do exactly that in 3 different occasions?

  1. select your camera
  • press 0 (look through selected camera)
  • Properties Editor (middle right) Data Type: Data > Lens > Orthographic
  • Properties Editor (middle right) > Data Type: Object > Transform > Location
  • change the location manually instead of using the mouse wheel
    do things come closer/further, get bigger/smaller? yes, they do
    so what you are saying shouldn’t happen, does happen
    your point is that with orthographic cameras you can’t use the mouse wheel to zoom because orthographic cameras have no depth right?
    but at the same time you can still use the location values to do that, right?
    let me ask you something
    what exactly do you think the mouse wheel changes with perspective cameras?
    hint: it’s the location of the camera, you can see the values changing while you are using your mouse wheel
    what are we arguing about?
  1. instead of viewing through an orthographic camera, go through the viewport orthographic view
  • press num7 (top view)
  • then num5 (to convert it to ortho)
  • use your mouse wheel
    do things come closer/further, get bigger/smaller? yes, they do
    so again what you are saying shouldn’t happen with orthgraphic, does happen when the viewport camera is orthographic

and again

  1. select your camera
  • press 0 (look through selected camera)
  • Properties Editor (middle right) Data Type: Data > Lens > Orthographic
  • Properties Display Panel >
  • go to View and tick the setting called Lock Camera To View
    use your mouse wheel
    do things come closer/further, get bigger/smaller? yes, they do, even now they do
    the problem is that they don’t do that inside the Resolution Gate (which is what they should do when Lock Camera To View is on) as they do with a perspective camera
    instead, the Resolution Gate also gets bigger/smaller while it should remain the same

about other ways to use instead of Lock Camera To View like you said
4) then why does Lock Camera To View exist if it’s not supposed to work correctly with zoom?
every single 3D and CAD program i know of, works the way im talking about, do they have it wrong?
even Blender itself works like that in multiple occasions and this problem with Lock Camera To View only exists because a developer refused to correct it
anyway, you don’t want it to work as it should, np with me

thank you for the answer, but you lost me, i didn’t understand what you are saying and also shift+ctrl middle mouse drag doesn’t do what im talking about, are you sure you are talking about orthographic cameras?

I’m having a hard time recreating this case, objects in the view do not get bigger and smaller:

The ortho zoom value is set in the camera properties, much like the focal length of the camera.

the shift+ctrl+middle mouse is a shortcut for moving the camera along the front/back axis (z). in ortho view, you won’t notice this motion for the same reason you can’t see a change in the views posted above. you will see objects clipping in and out of the viewplane if you move the camera too far.

If you want to change the ortho zoom level in camera, you could set up a simple python operator to do that, but I don’t believe it is a built in function.

I don’t argue. I explained how it works, as SterlingRoth shows. If it doesn’t work like that for you, we don’t use walls of text to troubleshoot but images and .blend files. If it doesn’t work like you want, http://i.imgur.com/N2bJVV4.gif

If I understand correctly, you want to scale the orthographic view while viewing through the camera in the viewport, because using the mouse wheel only scales the viewport within the camera, so the camera border just stays the same.

So, why’d you want the view scale on the mouse wheel in the first place? It can’t be for animating, since the mouse wheel increments will make the zooming stuttery. It can’t be for modeling, because you don’t even need a camera for that. It can’t be for setting up a camera, because then you would have to remap the default perspective dolly zoom.

You’re not presenting a situation where this configuration even would be practical.