About the Last UI Changes by Ton in os X SVN

About the last changes by Ton in svn, I would say him that CTRL+wheel mouse will never work in mac OS X because it’s reserved by the system for zooming of the whole screen.
Apart from that, I’d prefer the old way, with the mouse wheel zooming, it’s the fastest way to navigate IMHO.

I take the chance to sincerely thank Him for all his efforts in improving the usability of blender, in OS X particularly.

EDIT: in rev.53402 the T and N keys for panels in the viewport doesn’t work well anymore, since, after you hit the key, you have to move the mouse where the panels should appear to get them.


ctrl+zoom work here, but i probably disabled osx keys for it…

T and N Panel works here too…

@bashi, I’m on 10.7.5, in the system preferences (keyboard shortcuts) I can’t find the place to disable the CTRL+wheel zoom.
I have the default configuration here.

I tried few revs before and the panels switching was working fine.

What I added is CTRL + swipes on trackpads or magic mouse. That now zooms in Blender (as in other apps)
CTRL + Mouse wheel is not a common shortcut in Blender, nothing changed for wheel using either.

@Ton, first off, Thank You!

I don’t understand ‘swipes’, with the Magic mouse I tried CTRL+ left and right scrolling, one or two fingers, and nothing happens, up and down I get the system full screen zoom.

P.S. I have put selections on left mouse button and Emulate Numpad in preferences, maybe this matters?

“Swipe” is just to distinguish it from scrollwheel. On a trackpad it’s 2-finger swipe, on magic mouse 1 finger.

If you have your own keymap configuration, it might need changes and new options… just try “factory default” (file menu) to compare.

On all my macs, magic mouse ctrl+swipe zooms in contents of windows, not the screen. Note that this is not working for the “mighty mouse” :slight_smile: I also mix these names up once a while…

That’s strange, I actually have the default system configuration, for Magic, no Trackpad.

Also the ALT+swipe for panning seems to me worst than previous ALT+SHIFT+dragging (with magic mouse, I don’t know for the trackpad), but it’s only a personal preference.

EDIT: at first I misunderstood the ‘factory default’, anyway I tried and nothing changed, thus it doesn’t depends on blender preferences.


From your link to apple:

regards, paolo

I did not add an ALT swipe… no idea. You sure have a good build there?
You need revision r53402 or later. You also need os x 10.7 or later.

Anyway, there’s developers with macs working every day with us online, we will test all possible hardware, OS combos.

I have indeed r53402, and 10.7.5.
I built it myself, but I have had no problem until now.

If I hold ALT and Swipe Up the viewport content scrolls DOWN and viceversa, if I swipe Left it scrolls RIGHT and so on.

Waiting for other mac users response.

EDIT: Just for completeness, my shortcuts for rotate and pan view don’t work anymore.

LAST EDIT (I hope :)): I realized that I have UI problems also in. rev 53177.
I will try to retrieve when they starting and why, anyway that CRTL+swipe issue seems quite logic to me, given the reserved system preferences for that shortcut in mac os x.


Hrm, I don’t have this screen zoom - and don’t remember i disabled it. Where in the preferences is that?
For me (like in mozilla) it just zooms the displayed content in window. Both macs, 10.7 and 10.8

Building yourself: our os x maintainer found an issue in our build system.
I have “OSX deployment target” set on 10.7

I reset preferences to default and restored my personal settings and all works fine now and the ALT+swipe has gone, though the CTRL+swipe zooming issue remains.


I have a very few knowledge of programming or building, sorry, I guess here it compiles for 10.6 even if it has and use the 10.7 sdk. EDIT: Wrong:

Detected Xcode version: -- 4.5 --
Available OS X SDKs:
    Mac OS X 10.7                     -sdk macosx10.7
    OS X 10.8                         -sdk macosx10.8

    iOS 6.0                           -sdk iphoneos6.0

iOS Simulator SDKs:
    Simulator - iOS 6.0               -sdk iphonesimulator6.0

Auto-setting available MacOSX SDK -> MacOSX10.7.sdk

About the CTRL zoom, as you can see in the apple page, that is a feature of 10.7 and AFAIK is not exposed, and I didn’t find the option in the system preferences, as expected; it should work by default on every mac.


I tried r53454 and all seems to work fine regarding UI,
but I get this strange behavior: when I double-click to open it, it suddenly opens without the splash screen and shows the last scene opened (foo.blend(Recovered)).

Anyway I’ll mark this thread as solved. EDIT: not yet
EDIT: In the texture editor the issue remains, in user prefs there are a lot of repeated settings for zoom, scroll, pan, but I can’t deal with them.

Another thing, the mac doesn’t have the middle mouse button.

Thank you


EDIT 2: now the strange behavior at start has gone away, before it did repeatedly.

Help! How do I disable the swipe orbiting? I prefer having the scroll be all about zooming. I can’t seem to find a setting for it in the User Preferences (I thought it had something to do with the emulate 3-button mouse)…

I managed to regain the 3d view zoom by these settings in Input User prefs:

EDIT: WRONG INFO! Deleted. See my next post for correct ones.

For the 2D View in UV/Texture Editor, after a week I have not yet succeded to get the zoom working.

I hope it’s clear enough


Thanks Paolo for the info… I had to do a few different changes as my mouse wheel setting where already as above…
I think there might have been some weirdness going on with the Mouse/Trackpad rotate view…
Fixed it by putting that on ctrl instead.
I found a view zoom setting under the Image/Global that fixed the zoom for me… (It had a ctrl-mouse/trackpad zoom attached to it) It was just above the View Zoom Ratio…

I’m very sorry, above I made a stupid mistake, grr… I opened an old rev for copying settings.

So, the correct changes are (in 3D View (Global)):



Thank you very much EvilTesla, with your suggestion you solved my problem in 2D view.

Thank you Paolo for helping me out in the first place… Now all I need to figure out is why it won’t zoom in the Node editor.
I’m guessing I have to create a custom hotkey for it, but that would require some code for the function, which I don’t know…

(On a side note about the Node editor… Is it just me or would it be helpful to have the cursor active there as well? Everytime I add a node it’s always outside of the viewport and I have to scroll and relocate)…

I didnt thought to the node editor until now, I see I have the same problem; I will investigate.

About the adding nodes in the editor, I think it tries to put it under the mouse, but it do it badly.


I found that disabling Pan View (Mouse/Trackpad Pan) in 2D View, I can get zoom in Node editor swiping Left-Right, while swiping Up-Down it still move Up-Down, very weird.

Those preferences are a total mess.