[Add-on] Instant Meshes Remesh

(Peetie) #61

I checked around a bit, but don’t see it. But let you know when I come across one.

1 Like

(rombout) #62

I also did some checking but havent found anything yet. I also made “issue” for it asking if it will be released :slight_smile:

0 Likes

(cgvirus) #63

hi @knekke I have updated the code for some more efficiency after getting some feedback from my artist panel. If you think this can be merged let me know. I will pull a request.

Feedback from my artists panel and DONE Changes:

  1. Start the operation loop only when “start remesh” is on. Otherwise heavyweight object takes a very long time for remeshing while changing params.
  2. Disabled the multi object feature as it makes high dense mesh without tweaking params and importing is somewhat a problem.
  3. Some transformation code is updated to remesh it without jumping to center as Blender 2.8 transform got some updates.

Download:

Demo:

2 Likes

(knekke) #64

@cgvirus Great! The update-only-when-checked is a good thing. I have it in my C4D version of the plugin, no idea why I didn’t add it to Blender. Please file a pull request, so I will merge it. Thanks!

1 Like

(cgvirus) #65

Alright @knekke. It’s done. To make sure there are no conflicts I have uploaded a whole new file without merging the old one. May be some user may find the previous one more useful. Thanks.

0 Likes

(Peetie) #66

@knekke
With the latest two builds I receive this error:

I hope you still maintain the addon because the results of the addon are excellent.

1 Like

(knekke) #67

I’ll take a look…

2 Likes

(knekke) #68

@Peetie fixed. Check it on github: https://github.com/knekke/blender_addons

2 Likes

(2tancommon) #69

Hey knekke, this addon looks amazing!!

I have the exact error that Peetie has (or had) what did you do to fix it?

I’m running blender 2.8 beta on WIndows 10.

0 Likes

(knekke) #70

Did you try the latest version from github? I disabled the use_mesh_modifiers_render parameter in line 99, so there is no way you would get the exact same error.

0 Likes

(bassig) #71

I always get this error when I hit Start Remeshing:

image

Windows 10 with today’s 2.8 beta Build and the current .py file from github.

0 Likes

(knekke) #72

Did you set the path to your Instant Meshes.exe? Open the console, what does it say right before the crash (it should print the command it tries to execute)? I’m not sure if I handle spaces correctly, so that might or might not be an issue. I don’t have time to check atm.

0 Likes

(bassig) #73

The path to Instant Meshes.exe is set, also tried another location.

0 Likes

(knekke) #74

Please look at the console: Top menu -> Window -> toggle console

0 Likes

(bassig) #75

Sorry, wrong window.^^

It seems that the path to Instant Meshes.exe was messed up for some reason. I set it again and this time it seems to work just fine. My mistake! Works like a charm.

1 Like