[Addon] UvSquares v1.9 (updated - 2.80 and multi island support)

Thank you! Working fine again :smiley:

Add me to the list of folks asking for the update for 2.8 if you’re still working on this.

Lovely addon- can’t believe this feature isn’t native yet!

1 Like

Not sure if this is still working. It install without any issues, but I can’t get it to work. Is there a step I’m missing?! Can anyone help me out, please? Thank you!

hey guys,

is it somehow possible to align uvs squarish that are not quad only?

cheers chris

Works fine with the latest build…
Thanks for the awesome addon!!

  1. select quad fragment
  2. square grid by shape
  3. pin
  4. select rest of uv island
  5. regular unwrap

Hello everyone,

I have been trying to install this addon into 2.8 but it doesnt seem to work. if I use the 1.5 master version on the github I can install but, it says in the addons ‘needs upgrade to 2.8x’. I have come across this forum and tried the uvsquares_v1.8.2 and if I install that one, I dont see the addon in the options to activate. Am I doing this wrong? I have also tried to install the 1.5 github one then the 1.8.2 but same thing happens I just dont see the addon in the list to activate. Any help would be greatly appreciated


Having the same issue. I hope it can get fixed for 2.8!

Hi, any chance of an update for the latest 2.80 version? The add-on will not install correctly. It says “update to 2.8x required”.

UV Squares Blender 2.8 code fix/workaround

Download the latest release from github for UV Squares

Then update the


file in Visual Studio Code or Notepad

To remove the blender 2.8 Upgrade warning change the bl_info section from:

bl_info = {
“name”: “UV Squares”,
“description”: “UV Editor tool for reshaping selection to grid.”,
“author”: “Reslav Hollos”,
“version”: (1, 5, 0),
“blender”: (2, 71, 0),
“category”: “Mesh”,
#“location”: “UV Image Editor > UVs > UVs to grid of squares”,
#“warning”: “”,
“wiki_url”: “http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/UV/Uv_Squares


bl_info = {
“name”: “UV Squares”,
“description”: “UV Editor tool for reshaping selection to grid.”,
“author”: “Reslav Hollos”,
“version”: (1, 5, 0),
“blender”: (2, 80, 0),
“category”: “Mesh”,
#“location”: “UV Image Editor > UVs > UVs to grid of squares”,
#“warning”: “”,
“wiki_url”: “http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/UV/Uv_Squares

Note that only the property of BLENDER has changed in the file to “blender”: (2, 80, 0),

I also had to comment out line 52 of the code to get this working in Blender 2.8, just add a # symbol in from of this line as follows:


Reinstall the addon and it should work for what most people need.

I’m hoping this addon gets some official love when Blender comes out of Beta soon.

Check again, you’re not using the latest one, but old “master” :wink:
switch branch from “master” to “upgrade7-80_2” or simply click link below for v1.8.2

here’s under Add-ons

and in UV Editor

Thanks for this, I completely missed that branch. I’ll clone it and give it a go. :grin:

Thank you so much dude!!! You saved me. The 1.8.2 branch does not work for me with Blender 2.8, so I had to edit the master branch with your instructions to work. You are a life saver!

Glad it helped someone until the official release :slight_smile:

For those who want a proper Blender 2.8 version, I’ve notice from this pull request that @poor made some code cleaning in his fork, here: https://github.com/p2or/UvSquares/tree/blender-28 (thanks about that :wink: )

1 Like

I’ve updated the master branch with 2.80 version now when it’s officially released.
It seems that the most frequent problem was with the installation when the file was unzipped.
I’ve added instructions for that, do not unzip the addon.
Current master branch also has “multi island” support, so you can do multiple UV chunks at once.
In case of issues, please email me and attach the installation file that is not working or .blend file.


Added support for installing from both zip and unzipped file, let’s end that confusion :slight_smile:

Nice, thanks!

So to help out I tested UV Squares v 1.12.0 in the latest 2.81 Alpha and both To Grid By Shape and To Square Grid worked fine. To be thorough, I then tested it in the 2.80 final, and they didn’t work – nothing happened. Anybody else having this problem?

I downloaded the beta and your correct. It does function but I guess I need more of a walk through. The way the video for the add on seemed to work is that it straightened up an entire island without too much work. From what I was able to get done it was a row at a time, which can be quite time consuming but I guess it’s better than nothing. Happy with the results regardless.

Thank you