Angle Tool

Hi BD3D. I was able to install it on todays 2.8 build.

Did you start getting the error after updating blender? Is it happening when you try to enable the add-on? Any more details would be helpful.

If anyone else is getting this error, feedback would be appreciated? Thanks.

hi

i just get this message when i try to install this addon, i both 10 april and 13 april version, and i tried on a portable build it doesnt work

its the first time im trying the add-on

edit: it is resolved, i cannot explain why… thanks for the fast support by the way !

tried the add-on, its cool ! is it possible to directly use the mouse and moving the cursor left to right like other regular tools instead of clicking adjusting the slider each time ? we can gain a lot of time that way :grinning:

2 Likes

Yep. That functionality is coming very soon. :wink:

4 Likes

Hi everybody! I have finished the first version of my Corner Extrude redesign, and I have given the tool a new name: Angle Tool!

This new tool is only compatible with Blender 2.8.

Angle Tool is now a modal operator like most of the built-in modeling tools in Blender, which means instead of the pop-up dialog, it’s now possible to create corners just by moving the mouse left and right.

While the tool is active, there are also some extra features such as Snapping, Extend Mode and Curve Mode. I hope you will find this update useful and don’t hesitate to leave any feedback.

9 Likes

HI
i found a bug that sometimes this one randomly disappear / not searchable anymore ( " Angle " )

and the tool cant be used anymore and i need to reactivate the addon and rebind it again
not sure how it triggers but it happens randomly

Hey MatsuikoHiroka! Thanks for posting. Just wanted to confirm that I understand correctly. Does the hotkey disappear and you aren’t able to use the hotkey anymore, at random? Could it be happening after you change something else in your settings?

Could you also send me a screenshot of the expanded view of the Hotkey (the same as you attached already but expand the Angle Tool row please, so that I can see more information.

You mentioned you have to reactivate the add-on and rebind the hotkey. Have you tried just rebinding the hotkey?

How did you bind the hotkey? Did you use the button in the Toolshelf on the left? Did you use the Face drop-down menu in Edit mode? Or did you enter the hotkey manually in the User Preferences? Thanks!

HI

if I restart my blender the “ANGLE” dissapears or not searchable anymore and i needed to reactivate the addon so it will appear again with default setting

so i cannot show it anymore the image you are asking

yes i rebinded my hotkey … i can activate this tool but cant make it function

image

as i mentioned the tool doesnt work because this one magically dissapears

the only fix for me in the end is that
i need to reactivate again the addon everytime i restart my blender.

I am guessing here, but please make sure that your hotkey looks like this (of course you can assign a different key, though):


The best way to Assign the Shortcut is to right-click on this button:

Please DO NOT assign a hotkey to this button:
image
The same goes for all the other big buttons in the Toolshelf on the left of the 3D Viewport. If you assign shortcuts to the big buttons on the left, then the shorcut will just activate that Tool Mode, but won’t actually trigger the tool.

Please let me know if this helps!

1 Like

thank you for your help its working now

1 Like

hi :slight_smile: really cool tool! Are you planning to have it extend uvs if they are setup.
Would be really awesome to work with trim sheets then :slight_smile:

Hey _vis thanks! This has crossed my mind, yes. I’ll mark it down as a feature request and I’ll try to implement it in the future.

Beautiful demo vid! It’s tools like this that draw me further away from my long love/hate affair with Max.

Going to purchase this right now. Even if I never use it, I’m always happy to support such fantastic innovation :+1:

EDIT: just purchased. However, first time running the tool - select face>switch to edge>make edge active>run the tool>error (note: I’m running the 7th May build)

1 Like

For me same, your version from BlenderMarket or Gumroad?

1 Like

I got it on Gumroad. I’ve tried it in 4 different builds goning back as far as Feb. Same error in each.

1 Like

This is the first time I’ve heard of this error and I’m unable to reproduce it with the newest version of blender. It is somehow related to the Active Edge. Thank you Musashidan for rigorous testing. I don’t know yet what this could be caused by, even though I’ve tried breaking the add-on on my end. Still working on finding the issue.

I’m downloading the latest build right now. Will test and report back. :+1:

Nah mate, just tested in latest build. Exact same error. Just out of curiosity, is the Gumroad version the latest? I just downloaded it today.

1 Like

Can someone teach me how to install it on 2.8? Just downloaded from the gumroad link. After I install the zip file nothing like “angle_tool” shows up in the add-ons :frowning:

Just mentioning that the issues from the last couple of posts have been solved. If anyone has any other technical problems, feel free to post it here or message me.

I will try to publish the next version of Angle Tool around the official release of Blender or shortly after. Also feel free to post any ideas or feature requests. :slight_smile:

1 Like