AO Maps look crumpled

I am trying to do AO maps on a new model I purchased. My AO maps look horrbile. The parts are smooth and UV mapped, but in their AO renders, appear damaged, crumpled, non-smoothed. The model was created in Max by another artist. I imported it from OBJ format to Blender. The model looks fine in Blender and in the game I am exporting it to. But AO maps are failures. My theory is the mesh has an artifact smoothing issue from Max that OBJ format may have distorted and its showing up in renderings. Theory only.

I tried a few tricks to get it to smooth last night, like resmoothing the seats after making them flat again, then smooth again. Mesh auto-smooth is set to 180, maximum. I am using Blender 3.0, Sep 30 build, renderings on another model last week were perfect, so I do not think its Blender or my settings. I think (theory) its the mesh.

Any idea how to fix mesh that will not render right, but appear perfect?

Many thanks in advance…


Nothing than the usuall suggestion: doubled vertices, disconnected faces, additional normal data, faces set to flat/smooth ?

Hey Okidoki,

I just tried Cleanup. The seats then rendered pure black, as well as a couple of other parts. Anything I tried to AO render was black. Googled this, and it says a scene can become corrupt. So I migrated/copy-pasted the entire scene to a new scene, reorganized it back to containers structures, exported, and this time they were not black, but were a mess. Worse then before. Its so odd as the part is beautiful in Blender and in Flight Simulator, but the AO looks like aluminum foil. :frowning:

I wonder if I had accidentally created a secondary set of parts by mistake, like a Shift-D mishap, and duplicated the parts, and that caused the black renderings… I did find a copy with a different name, re-routed that to a backup folder which should have been where this was. But that would explain the black parts.

But… That said, the seat renderings are even worse.

With Culling active, there are no backsides visible.
I ran Delete Loose and Merge by Distance. Same result.

What do your bake settings look like? Your UVs? Your topology? Looking at the shot, it’s probably pretty clean, but it’d be nice to see what’s what.

Also, for a lark, select all the faces in your model, then hit Shift-N to recalculate your normals. See what that does.

Hey Renzatic,

I am exporting to a 4096 square image. That will later be 2048, but for now, just trying to get good AO maps.

I edited my post above. The one thing I’m most leaning towards is recalculating your normals.

Also, make sure you apply all your transforms while in object mode. That’s Ctrl-A for reference.

Oh, and what’s your modifier stack look like?

Here are the normals. I ran Shift-N, rendered, same result. I also have been using Reset Vectors which usually always corrects smoothing issues and tried Smooth Vectors, all with no result.

It appears like there is another mesh in the mesh… but I rewelded by distance, and ran delete loose.

Uhh… not sure if it was mentioned (sorry), but remember that AO bake includes EVERYTHING that is enabled for render. So if you have an overlapping invisible (but enabled for rendering) mesh, it might influence the result too.


Your topology looks fine. Whatever it is you’re experiencing, it’s some little thing that’s throwing you off in a big way.

Under your Object Data Properties tab, go down to Geometry Data, and if it’s there, hit the Clear Custom Split Normals Data button, then try the render again.

Tried that just now. Same result.

Many thanks. I did have camera icons visible, though they were outside of the Containers, but I turned off the camera icons and unchecked them. Thanks for the heads up on that.

This might be one of those things we have to see for ourselves to know how to fix. If you don’t have a problem uploading parts of your model for us to tinker with, I’d suggest doing that.

Seeing this mosaic image of yours i’m remembereing something about/like double used UV’s mismatch baking… but it seams to bw you have two seats on the UV’s …

It does…
I just realized ‘camera’ icon on the Outliner is ‘visibility’ and computer screen icons are renderings which werent visible on the filter. I turned those off on unwanted sections, and also had the checks unchecked on unwated parts sections, and now the renderings are solid black, nothing visible. Light is in the rendering, but nothing. :S Goodness… It just gets worse.

Here is the seats part cluster. (517.4 KB)

Note, this is Blender 3.0, Oct 29th build.

Okay and you set the Bake Type to Occlusion ( in your file it’s eevee instead of cycles)?? Because i got this in 2.93.4 (was just open on my comupter :wink: ):

1 Like


I am using Cycles… Off to try this.