AwesomeBump: A free alternative to CrazyBump


(Terrance8D) #1

EDIT: Due to high traffic, the AB website is down. Before asking for a download link, visit https://github.com/kmkolasinski/AwesomeBump to download for Windows and Linux. To get it on OSX, go here: https://github.com/kmkolasinski/AwesomeBump and then here: https://www.youtube.com/watch?v=R-WgHserrS0

EDIT 2: The AwesomeBump website isn’t down anymore, but in case it goes down again, visit the links listed above.

Hey! A new tool called AwesomeBump is out now! Version 1.0 was released on January 30th, and since then there have been 3 subsequent releases. AwesomeBump is a lot like CrazyBump. Some BIG differences are that it’s free, open-source, AND cross-platform. Windows, Mac, and Linux. You load up an image, and it creates Normal, Specular, Height, and Occlusion maps for you. You can remove stretching from an image, remove shading from it, and there are SO many options for tweaking the maps! That’s not all - if you don’t like any of the models included with AB, you can load in your own! You can seriously test the texture maps ON YOUR OWN MODEL. It seems to good to be true, and it sort of is. “WHAT?! SORT OF?! WHAT DOES THAT MEAN?!”, you scream in a fit of rage. You need OpenGL 4.0 or greater to run the tool. The reason for this is because 99% of the computing is done on the GPU. If you can utilize this tool, it runs BLAZING fast. But don’t take my word for it! DOWNLOAD IT HERE: http://awesomebump.besaba.com Get it, and make some AWESOME renders!:smiley:


(michalis) #2

Can’t download this link, it takes forever…
Sorry.


(Terrance8D) #3

The page seems to load fine for me, it might be a problem with your connection.


(Stan Pancakes) #4

Nope, takes forever here too. ping shows 56% packet loss.


(Terrance8D) #5

Once again, normal load speed/download speed for me…Don’t know what might be happening.:stuck_out_tongue:


(Old_Demon) #6

May be only for Antarctic population this is great news :slight_smile:

Win users have…

MapZone
NeoTextureEdit
FxGen
SSbump Generator
… more?..

…at last - Blender + some brainstorm

… many years…:slight_smile:
…but still not have free analog tool as PixPlant…:frowning:


(m9105826) #7

No problems here


(blurymind) #8

download works fine for me too. Its hosted on github


(English is not my native language) #9

Thank You! Running on Kubuntu 14.04 64bits


(blurymind) #10

cant compile it. It errors at a missing capsule.obj file. Filed a bug report


(NinthJake) #11

Cool. It is good to finally have an alternative option for texturing on Linux.

I am a bit bummed out about the OGL 4.0 requirement though. My Linux machine only supports up to ~3.8 so I still can’t use it.


(Stan Pancakes) #12

There’s no OpenGL 3.8. 3.3 -> 4.0.


(NinthJake) #13

It is 3.x - something. I still tried to run it but it crashed my whole computer at startup.


(smith123) #14

It downloaded quickly and has opened OK with the demo cube. Windows x64.

Thanks for the heads up Terrance8D.

What would be a good test, or should we look for when bumping things?

…or in other words how do you use it???


(DavidGasku) #15

wow, thanks for finding it. Its so great, it runs great in ubuntu 14.10!


(riveter) #16

I got it running. But it locked up my computer hard when I tried to make it do it’s thing.


(Dam-Org) #17

Oh
My
Cthulhu
Thank you @Terrance8D for finding this and thanks dev for creating this big time


(xrg) #18

Same boat as NinthJake – OpenGL isn’t high enough in Linux using Open Source Radeon drivers. I’ll have to remember to give it a go next time I boot into Windows though.


(Terrance8D) #19

The creator has a lot of tutorials on the website: http://awesomebump.besaba.com/tutorials I assume you really want to know how to generate the maps. This is a little confusing at first, but you get used to it really quick. Click on the ‘Diffuse’ tab, and drag your image into there. At the bottom (make sure the Diffuse tab is active) click on the checkbox labeled “Basemap to others” and then click the button that says Convert N to H. From there you can tweak the settings.:slight_smile:


(Terrance8D) #20

Sorry to everyone who wasn’t able to use it, you might just have to wait a little longer to get OpenGL 4.0.:confused: