Background/reference image looks blurry (viewport) - settings?

Hi. I am a beginner. I made a new scene and added a background/reference image (Add > Image > …) to use as a guide for modeling.
The problem is that the image looks a bit blurry (in the viewport).
I am using the same image in Autodesk Maya and it looks properly (viewport). But if i remember correctly (old project), i had to change several quality/filter settings in several different places to achieve that (now it is indistinguishable from the image being viewed through an image viewer).
What can i do to improve the quality in Blender? I have failed to find the appropriate settings.
Thank you.

If you had to make it look better in Maya…then you would have to use an exterior prog, like Gimp or Krita and just make it look better…then, when you import as reference in Blender it should look the same…even low resolution pix imported here look good, even though they will pixelize when enlarged and examined closely…the higher resolution, the better.

Hi, thank you.

  • No, you misunderstood. I did not make the image look “better” in Maya. The changes i made in Maya was increasing the viewport quality settings, the image/texture quality settings and removing any kind of texture filtering. These are just quality settings for the viewport. The image is the same file and has not been edited in any way inside or outside Maya nor is it better or different than the source image. It just looks as it should and not how it would look with low quality settings.

  • So, your suggestion would not work at all. The same image, at the same level of magnification looks blurry in Blender just as it did in Maya before i changed the quality settings. If the issue is the same (the quality/texture settings in Blender) then no matter how much i edit the image in an external program, it will still become blurry inside Blender.

  • In any case, i am not looking for a workaround, i have a workaround, Maya. I am here because i read a few discussions about the issue and most suggestions were about settings very similar to the ones i changed in Maya. The instructions were outdated though so i could not follow them but i am confident it is just a matter of settings.

In Edit->Preferences and in the “Viewport” settings maybe you can find something there.

Hi. Thank you.

  • Yes, i have already disabled everything in Edit > Preferences > Viewport settings. Strangely, the Quality and Texture settings do not affect the reference image at all. I saw some effects on objects and wireframes but not the image.

I found some clues but it looks like it is an issue with Blender.

  • I took a closer look of the image in Blender and it looks like the issue is indeed some filter because the image looks anti-aliased and not as if it was missing image information.
  • So i went back in Maya (remember that in Maya i had to change several different settings). After some testing i identified the setting that gives the same result as Blender. It is a texture filter setting with the options: Off / Mip Map / Box / Quadratic / Quartic / Gaussian. The setting to keep the image unaltered is of course Off.
  • But i recognise these filters. I read about them yesterday in Blender discussions while researching the issue. Where can i find them now?

For example where i can find this option in the latest version?

or how can i do this for a reference image (second post)?

If the texture is on an plane then you can select in the shader editor and the texture material node that you want the interpolation mode to be ‘closest’.