Bake Wrangler (beta) - New Nodes based Baking tool (with PBR support)

How do you mean to reuse them? Like save the set up and use it in another blend file or what?

Some variation on Node Bake System perhaps?

I bake without error, but no texture file in the path folder I’v setup. Peraphs is caused by “relative path”: which is staying unchecked even if I enable it.
You select the path, then check relative path, click accept, bake, no file texture, you take a quick look to the path by clicking the button from output node, you notice that “relative path” is still unchecked, so looks like the bake process is running with “relative path” unchecked even if you enable it.
Blender 2.80.75. here

I wonder if you can add nodes to bake using collections, one that contain highpolies and another containing lowpolies (from the user part the lowpolies share the same UVmap, while their prefix/names/suffix are setup accordingly to help the node recognize them). It will unclutter the node setup a lot and make the process more direct and easy.
Can you add a “use lowpoly instead of highpoly” in the ‘mesh’ node?

Edit- this addon EasyBake - Tiny and easy texture baking UI use the collection method I’v mentioned, you can check his code to see how you can do a similar work.

@Tosky The path gets converted to an absolute path, because the background process that does the bake is running from your ‘tmp’ location. So a relative path wouldn’t be valid. Is this causing issues with symlinks or something? A more detailed log is output to your ‘tmp’ directory (you can see the name if you run blender from the console and look at the console messages). It should tell you what is going on with the image creation.

The current version reports ‘Bake Complete’ when the background job finishes, but it doesn’t check that it finished properly. I’ve added a check that the script gets to the end in the next version and will say ‘Bake Error’ if it exits early for some reason.

If you don’t put any ‘high polys’ in the ‘mesh’ node, it will just bake the lowpoly directly. Is that what you’re wanting to do?

It would be possible to use collections, but the names would have to match between the sets.


No problem at all! I’v linked in my previos -now edited- comment an addon that use collections. Thank you for your contribution!!

Ok, my previous problem was caused by “disable in renders” in the outliners (silly me) , but now my new problem is that the exported file is literally just a generic file



(it should be a PNG) , opening with GIMP just show me a plain blank blue texture, so a problem within a problem.
When I use other bakers on the same pair of objects, the (expected) result is this: export_normal.tga (2.1 MB)

Tested with a fresh install of 2.80.75 (just your addon is activated). My log: _Bake_Pass__NORMAL_1.blend.log (13.5 KB)

-EDIT: added more info and files

Thanks for the report!

So, I’m not seeing anything wrong in the log file. What did your node set up look like? I think I may need to install a linux to test it myself.

Update: I’ve tested it myself on linux Mint and I’m getting the same problem your reported. I will investigate further.

Okay I think the issue is that you have no material on your high poly object? This causes the mask to bake incorrectly. I thought I had logic in place to deal with that case, oh well. For now just add a material to your high poly object(s) and it should work.

I will fix that for the next version.

I’v added material to highpoly but solved nothing. Here my node setup:


Okay, then I don’t know. It works for me on linux and windows so long as there is a material on the high poly object…

@Tosky can you maybe link me your blend file so I can test it?

bakertest.blend (1.3 MB)

Thanks. So your file outputs the expected image for me when I tested it on windows and linux. On linux I’m using the .tgz file I linked earlier and manually decompress and copy it into the addons folder.

Maybe something is up with your addon install? Try deleting it and replacing it manually with the tgz file?

Where? I’m a windows 7 user btw. I’ll try to install manually into addons folder.
EDIT- no difference :confused:

Oh sorry, for some reason I thought you were on linux. You are using the 0.5.2 version on windows right? Are you doing anything different like running Blender as Administrator and trying to save the file to a place that only Admin can access?


My texture path is just C:\export , it shouldn’t be an admin-only area. Btw I just tried to run Blender as Administrator, same result :confused:

The last thing could it be that I run the addon from a Blender inside a portable folder (so I’m using the zip version of Blender) which is running from my C:\Users*myname*\Downloads . I’ll try with the executable install.
-EDIT tried using an installer version of Blender, still same result :confused:

Can you try saving the file to your user folder? Like just put it in Pictures or something?

Is it creating the file? But the file is just blue with nothing else? Or do you not get anything?

The file must be force-opened, by using Gimp or Krita it just show a blank plain blue color (normal map tone).

Edit- no wait a second, I rebaked and the texture now seems fine something something happened but I don’t know what. Still generic file format sadly.

Edit2- saved in user documents and pictures too, still same result, generic file that must be force-opened. At least the texture inside looks fine.

Just add .png to end of your file name. It doesn’t auto-add a file extension. I guess I can add an option to do that…

1 Like

So far so good, the ‘file’ output bug was just the lacking of proper extension naming.

Some questions, suggestions and reports:

  • The textures are forcely baked at 8-bit? I’v changed to 16-bit from ‘output’ panel, yet the textures are baked at 8-bit: which could create ‘banding’ effect issues on normal maps: any plan to let the user select 16/32-bit too?
  • Your script could manage to make nodes like roughness/metalness/normalmap to automatically switch them to ‘non-color’ when you bake using their material? If non-color is not chosed for those slots, the baked result are flat colors on the uv islands (like bright pink for the metallness texture). At least I would add it as a troubleshoot in your addon description to avoid false-bug reports.
  • For the ‘albedo’ can you add a check to enable ‘environment/lighting’ baking and AO baking to turn albedo textures like diffuse textures? And the option of ‘Object/World space’ for the normal map? ID map bake would be useful too.
  • I would suggest an option which rename using the lowpoly name as a prefix; the type of the selected pass as a suffix; the selected format as file extension naming.
  • The automatic creation of a material which use the baked textures would be dope: but that would be hard to do if you can’t bake all the necessary passes in one-click(?)
  • Seems like the baked texture don’t have an alpha channel even if I feed the alpha slot (‘output image path’ node) with the color input (from ‘bake pass’ node).
  • The aforementioned feature of baking by using collections would be a big feature.

This addon has huuuge potential, hope you’ll not abandon it! At least let other devs help you to develop it! Cheers!