Blender 2.35 Released

Weee!!! Just wanted to let everyone know that it’s out.

Some bugs were fixed and hey, anaglyph (with some 3d glasses and your game will be truly 3d).

Check out the improvements here.

Jason Lin

Yeah, but now my game controls quit working :x

Well, I’ve got some rewriting to do. I was working off the frame rate. I’m still really glad because it brings consistency.

Hmm. The loop speed has slowed down dramaticly on my game. I was using it to position animations and now it looks all choppy. If they did it for consistency, I think they went too far.

I tried out the race car game from the game kit and it runs patheticly slow now. About 5 times slower than it used to.

Logic & physics no longer depend on frame rate. Logic happens at 30Hz and physics at 60Hz, this can be configured via Python.

Anyone know how to find out how we configure the rate in Python?

The problem with my game is more of an inconsistency now.
I used two scripts that were basically written the same, and they rotated two different objects. The first object moves a lot slower, and the second object doesn’t move at all.
It’s just really weird because of the scripts being almost identical in code.

I’ll just hang around and see what the realy Python coders come up with to fix their projects so I can attempt to adapt mine.

Regardless, I love the new mesh editing tools, especially the new select modes and Extrude Individual Faces.

In case there’s a game engine guy reading this, please reset the default logic to a minimum of 40 hz. That "eye can’t see anything over 30 hz "is complete garbage and some of us need to change frames via logic for exact positioning. At least tell us how to change it instead of giving us a teaser.

How about 60hz? Having consistently WORSE framerates is much worse than inconsistently bad ones…

I did some hunting around on the source site. In case anyone else needs it python code to change logic rate is:


The set function takes a float and it’s in hz.

Well let me be the first to thank alien-xmp for his continued work on the engine! Being able to control the update rates is a fantastic new feature.

New versions nearly always cause problems in older files guys. You can’t keep perfect backwards compatability forever…

Yeah, I probably sounded a little frustrated there because my game wasn’t working very well. I guess the disappointing thing I found out while looking for the Python code was that there is only alien working on the engine. Kind of a serious situation. Much as I hate c++, I guess I should start looking at the source code and trying to upgrade my skills. What seems like the best idea to me is to start a Blender/Ogre fork. I’ve gone all the way to downloading and compiling Ogre and playing around with it a little bit, and know absolutely nothing about Blender’s inner workings. The thing is, you’ve got a lot of guys working on the Ogre engine and keeping it updated.

I tested it on Mac os.

  • where is save dynamic runtime?
  • why blurs the game engine when you move? Low hetz frequention?
  • some of my chars fall trough floors again

I test tonight on my windos pc :slight_smile: I hope my new project runs smooth :smiley:

Well, my biggest problem has been that games that run beautifully on the old engine are slow and choppy on the new one. And until this is fixed, my game making will still be done in 2.28.

cool to see an update, the new editing functions and global undo will be very useful…but unfortunatly my demo is really “choppy” under the new 2.35 :frowning:
as said, it’s good to have logic and physics not to be framerate dependant but theses changes semms to screw everything up…and i don’t have complex scripting, just a mouse script for FPS camera
the framerate is constent but movements are really “jittered”, like if’ ur shaking the camera…that causes headache :o

so if anybody knows what to do, or where to search…

The jitter occurs because of the low logic update rate of only 30Hz. You can remove this using a python script to change it:

g = GameLogic


Initialise this script at game startup to give a 100Hz update rate, which should remove the jitter.

Whilst it may be set too low by default. The performance improvement is amazing. My current game went from 15% logic & 35% physics in the 2.34 profile, to 2% logic and 4% physics in 2.35 :o

I’ll check it andy, I hope you’re right :slight_smile: Well the default hz is minimum human eye hetz. The monitor refresh hetz is 65 I thought, so that should run a game very well if you would apply that. But the stupid thing is, they say it can be done with a python script to change hetz, but they don’t put a example in it. I’ll write that down and find another things to tweak the engine.

I also found out that python coded controllers are a lot faster then a normal controller. :smiley: And blender 2.25 saves blends different then 2.34 and highter. scripts that works in 2.25, don’t work in 2.34 >, but they can work if you save the blend in 2.25 and open in 2.34, really strange. But afther saving the blend file a couple of times in 2.34 may the script not run anymore in 2.25. No idea if this is a bug or not. Didn’t tested it with 2.35 yet, but I’ll try it out. :-?

andy. when i put Your code:

g = GameLogic

as Alwys->Python

my character doesen’t rotate and stop moving =(
what is wrong with my method?

i tryed to change “hz” and it works…it’s better but not at the level of 2.34, so i think that it’s the mousescript or something that don’t like the new engine. But by doing that i also screw the physics and animated textures :o i have also seen the physics/logic improvement that andy pointed and i will be good for big projects that runs slow…but will surely need a big rewrote/ajustement of pythons scripts and so :-?

the same problem^

must I add “importGameLogic” in the beginning?

Jep! :wink:

There is an other Problem with the Compatibly now! IPO/Property Actuators no more jump direct to the Property You set. Now they do a Slide from the last Position to the New. Try it!
I use IPO’s to set Objects directly to specific Positions while the Game is running. Now i have a biiiiiig Problem! Now i have to do thet direct Positioning with Python and ‘setPosition()’. With IPO’s, this was more flexible.
Anyway, a nice Feature (if it is one), but not always wanted! A disable Function would be necessary!

At last, for smooth Animations (LinV Objects, Texture Animation Scripts … ) i have to use:
I don’t know if this Settings are to high. What happens, if they are, on slower Machines?

That setLogicTicRate(…) works perfect, I tried with rate 10, it lags incredible, afthe set it to 60 it runs smooth. When I tested 100, it gives me some bugs, like limited amount of mouse moving in the game screen. I would recommend you to use 60 hz, runs really good. :stuck_out_tongue: