Blender 2.5 Alpha 2 UV Layout export

Is this feature working in this version of Blender? I am really liking the way blender is going and I dont really want to learn the old version now.

Many thanks for your help.

In UV/Image editor window, use UVs / Export UV Layout. Select location in the next window and format (either .eps or .svg) from the dropdown at the lower left of the screen.


Thank you for the quick reply Richard, I must be doing something wrong here, I rename <memory> to myuvlayout select all uv from the left and click save. Then I try to find the image file and I can’t see it in the directory? Do I have to manually add the file extention? Also I checked the console log thing and that says something about no _socket?
this is the error i get. Im really not sure what I am doing wrong :confused:

I have better results with svg. You have to add the file extension yourself in the name field. I don’t use the windows version of blender so do not see the same error message.


Is anyone else finding this problem?
I think I may have to install Linux and try it there also. That would be a bit of a pain though. I am working with the Unity 3d engine on windows.

Ive got the same problem
Well, I havent checked the conosle, but the exports not working.
On top of that I can’t see that UV Test grid in the viewport.
Did you get any luck yet?

No, no luck as of yet. I presume that something is not being referenced correctly and is therefore a bug. I will try the 32 bit build tomorrow before installing Linux mint.

I just tried a build today, 28237
And im getting no results.
Tried on the default scene and nothing either.
I’m wondering if its a problem with the OS?
I’m on WinXP SP3
and here’s the text from the console.


Just tried the 2.5alpha2 from on a WinXP SP3 machine and it exports fine.


Just redownloaded Alpha 2, and im just getting
“RNA STRING SET UV OT export layout. filename not found
RNA String Set : UV OT export layout. directory not found.”

I thought it might be because I was trying to save onto a different partition (ext3)
but tried on the C drive and same error.

But are you getting a file output. I got some errors like this in the console window but the file was created anyway. You also need to add the file extension when you set its name.


smells like a python library configuration / python path issue.

Yes I’ve set the file extension.
And I just reinstalled python.
So checking again now.
And its fine. No error code, and opens.

smells fine now :slight_smile:

I installed the 32 bit version now, and I only get the same error
“RNA STRING SET UV OT export layout. filename not found
RNA String Set : UV OT export layout. directory not found.”

In Blender file browswer it finds the files, the testcube.blend testcube.svg and testcube.tga
However In windows 7 I cant see any file in the folders and I have the show hidden files option enabled :confused:
This is really puzzeling me now. Any thoughts?

Just a quick update, I have now installed ubuntu and the Linux 64bit Blender 2.5 Alpha 2 and the UV layout works just fine. I guess I will have to OS swap until this is fixed in the windows version.

Or your own specific configuration whatever that may be as the windows version of blender can export files for me which I can find fine.

I have to admit that I got it wrong. I checked and double checked everything. Finally the issue was that I had the wrong version of python installed.
All is working now although I still get that error in the log?:cool:

I didn’t have any problems with the export… but I use Paint.Net.

Is there any way [besides Inkscape] to get SVG into Paint.Net?