Blender 2.8 ALT M not working

I thought I posted this earlier… but don’t find…

 I am trying to learn modeling in this new blender 2.8   am trying to merge two verts together ... I have done ALT M and clicked  "at center"   tried "At last" and I've tried "At first"    nothing is working...  I decided to try to select the two verts and then push F and that didn't work...  

Is there a secret to doing it in 2.8   I've been trying to learn modeling in 2.79B and I have learned a lot, but still have a long way to go yet and now am totally lost in 2.80 but am trying to learn my way around it... 


You posted the question in another thread.

The only way I can imagine this happening is if you are editing more than one object at the same time and you are trying to merge a vertex from one object with a vertex from another.

I had two objects and joined them… what I did was select a line of verts from one object and did “P” and selected “selection” then I selected a line of verts from the other object and did the same… separated it… Now I had two lines of verts and joined them… went into edit mode and tried to merge the two verts near each other in the complete line… I have done it in 2.79B when modeling a car many times… not getting it to work in 2.80

It still sounds like the vertices you are attempting to merge belong to two separate objects.

they were two different objects, but before I tried to merge them… I joined the two objects as one object…and then went into edit mode to join these two verts… . It always worked in blender 2.79b but guess it won’t work in 2.80 so will have to find a different way to get what I need


Can you show us a screenshot, especially including the Outliner while doing this? Alt+M works flawlessly for me in 2.80 as long as the vertices I’m trying to merge belong to the same object.

I just did a test of it in a new blender 2.80 and it’s working… so something about my two objects in what I’m doing… so going to see if I can figure out why it isn’t working…

I was trying to make a car… I took an edge of the fender and an edge from the hood and did P to separate the edge… Once I separated the edge from each, I selected them both in Object mode and and joined them together… then went into edit mode to join them to create a section of the front of the grill… and they wouldn’t join… I’ve modeled quite a few cars in 2.79b and did this all the time when creating the models and always worked… It worked just now in a test in blender 2.8 so going to try again with the car i’m trying to make

I’ll get a screen shot and post …

1 Like

I took an edge loop from the hood, an edge loop from the fender… separated them, then in Object mode, joined them… then went into edit mode to join the two ends to create the one edge loop… but they won’t join… I’m not sure why… I never had any issues with doing it in 2.79B. I had followed two tutorials in 2.79b that did it in several areas of the modeling… so I have used it all the time when modeling a car… but no idea why not working in 2.8

If you look at the Outliner you can see that you have two objects selected Plane 010 and Plane 011. You are editing both of them at the same time. So vertices from one can’t be merged with vertices from the other.

Okay… so in blender 2.8 when you join two objects in object mode, it remains as two separate items? so it looks like I can no longer join two objects togther in object mode and then go into edit to join two separated verts
okay… got to create it a different way now… or go back to using 2.79b when needing to do this…

thanks for checking it

If you are looking for the alt-m ‘remove doubles’ it is now in the header under ‘Mesh’>‘Clean up’> ‘merge by distance’.

Okay… I totally redid the function… I deleted the two edge loops and recreated them from the fender and the hood and then joined the two together this time and went into edit mode and this time it worked… Not sure what happened the first time… but got it this time working… third time is charm they say :slight_smile:

thanks for checking it for me… I will double check the outline next time
have a good day

1 Like

No. Ctrl+J joins object just as it did in 2.79. If that isn’t working for you in 2.80 then something is wrong. Either something has changed the shortcut for Join or something is up with your version of 2.80 somehow. You could always try Loading Factory default preferences if the latter is the case/

Thanks… i’m hoping I get this all figured out eventually… was doing fairly good in 2.79b and now things are so much different… almost like starting over


Once you’ve used 2.80 for a bit there’s no going back :stuck_out_tongue: I hate having to open 2.79 now. The thing that tripped you up a bit in this very specific case, being able to enter Edit mode on more than one object, is great in most other circumstances.

Yes… I was doing the Ctrl J to join them… not sure what happened… I closed out blender and reopened and then redid the whole thing and it’s working right now… I had something else that wasn’t working and had to close it out and reopen and then it was doing okay… so I might have hit something wrong that messed it up … I had a weird cursor showing at one point so had to close it out and open back up to get it back … I had hit something that changed it but didn’t know what I hit…
I’ll get it all figured out at some point I hope…
thanks for your help and patience… I’m learning … using tutorials and trying to do some on my own after watching them… taking time to learn it all…

have a good rest of your day

1 Like

I hope so… I’m trying to get used to it… this is the first thing i’m trying to make in it now…and I’m not that good at it yet…

It will come in time - the switch to 2.8 has been a slow one for me as I started back with earlier beta and on from there. Changes kept coming and kept me on my toes - but that is what we are here for as community, ask and we will find a way to help if possible.

thanks… I saw the beta out but when it gave the warning that it could messed up your files, I decided not to try it and just wait for it to officially come out to try… didn’t realize it was going to be a huge difference in them… I’ve been working with 2.79b since it came out… trying to learn … I still run into issues and things don’t always come out as good as I hoped… but I keep working at it and making notes for next time… I usually try to solve the problem before I come in here… using tutorials and doing searches online for whatever issue i’m having and when all else fails, then I come in here and post a question… I love working with blender learning it… and am generally working on it about 5-6 hours every day… I appreciate everyone’s help I’ve gotten through the years of my learning this…

enjoy the rest of your day… :smile:

1 Like

if you need more help on specific questions, you might also do a search on and see if it hasn’t already been answered there, or at least some of us might find an answer for you directly like that.