Blender 2.8 Cycles rendering with portals

hi there,
i have a small test scene. outside a hdri. two windows. I created two portals for the two windows. So two areas lights and the hook on at portals. However, I see no difference in the result (with or without area light/portals). Also, there is no difference in the render time. the portals fill the complete windows and they point inwards.

here with portals on:

here with portals off:


without it is even better?!?!
I’m sure I’m doing something wrong. but what?
iam also missing refraction and reflaction for the multipass/layer compositing. i do not know blender 2.79 or younger but i know there is this passes. i didnt find it in 2.8 yet ?!
any ideas what i am doing wrong?

I am looking forward to your answers. thank you!

Portals aren’t going to lower your render time, if anything they might slightly increase it. They can help you get less noise in the same amount of time, however that’s not always the case.

Basically you are trying to help Blender deciding on how to spend its “ray budget” by adding these portals. Rays spent tracing towards portals can’t be spent on tracing towards other light sources (such as the environment).

If your windows are large (as they are here), the overhead of sending rays towards the windows first doesn’t necessarily pay off, compared to just sending the rays towards the environment directly.

You can also try turning off “MIS” in the world settings and see if that helps.

Thank you for your response. But i do not get less amount of noise in this example, more the opposite . Is this a bad example/test scene to test the effect of the portals?

With the size of the windows you mean it is possible that it could help to make them smaller? Does a portal in the wall have an effect on the noise inside the room?

You shouldn’t make portals too big. Just make them slightly bigger than window area and bring closer as much as you can.

Hi. Could you do the next test? From World tab, under Settings item, you configure:
Sampling: None

or

Sampling: Manual
Map Resolution: 256

And you compare now differences between Portal and No Portal.

Portals is definitely working in 2.8.

I created a very difficult scene for a path tracer (a camera obscura). The only light in this scene is the environment HDRI that is leaking through the very small pinhole window on the right.

This is the difference between portals and no portals - 500 samples:

untitled

untitled2

5 Likes

Just trying to understand why when Portals was implemented in 2.75, nobody doubted the advantages of this with respect to the lower noise (no lower render time). The advantage of Portals was clear in many user tests, obtaining much less noise. But then in new versions of Blender some users began to question the advantages of Portals in some interior scenes.
The think is that in 2.75 default scenes were set in World tab by default: Settings > Multiple Importance=OFF (Map Resolution=256 if you enabled it). So I think that many tests by users when Portals was implemented were done with Multiple Importance=OFF.
Then from Blender 2.77 that configuration began to be by default: Multiple Importance=ON and Map Resolution=1024.
Then in master (2.79 and 2.80) Sampling methods were implemented: Manual, Auto, None.

Edit:
Some tests in 2.76b (CPU):

*No Portals - Multiple Importance OFF

*Portals - Multiple Importance OFF

*No Portals - Multiple Importance ON - Map Resolution=256

*Portals - Multiple Importance ON - Map Resolution=256

*No Portals - Multiple Importance ON - Map Resolution=1024

*Portals - Multiple Importance ON - Map Resolution=1024

Scene:
portals_2.76b.blend (1.4 MB)

Edit 2:

Do you know what the equivalent of setting Multiple importance Sampling = OFF would be in 2.8?
I can only see the new Sampling methods in World tab. So setting “None” would be the same thing?

1 Like

None = off, I believe.

Thanks for your answers, I will test a little further. I assumed that portals are there to provide a better result with the same rendering time?

Unfortunately, I have another problem. It takes forever for the rendering to begin. Actually, I do not have a live image, because I have to wait a few minutes after a change, until the rendering is updated. That can not be right with such a small test scene. In C4D+Octane i have a much better and quicker response after i made a change.

I’m not sure but having lots of large textures may cause such thing (They need to be calculated prior to rendering).

i think it have to do with the hdri. its a 16k hdri and after each change (rotation or the brightness) it take a long time to “updating lights” its annoying. because in octane/c4d it happens seamsless…
is this normal for blender/cycles?

For 16k, yes. It’s loading the 500mb+ file to memory after changes.

It will be fixed after they introduce the change that causes non-modified elements not to be recalculated.

1 Like

is there a roadmap or something like that, so i can see when this fix maybe comes? with the final release in july? or earlier?

First release candidate in july. Will take a few iterations of those before the final 2.80.

This change will be in 2.81 AFAIK.

why is this not so important? i think, this is one of this things which are keeping me away from blender :frowning:

There is much stuff I find important yet there we have Eevee development as one of the most important. Have to wait.

is this such a big thing? i dont know

i try to make the hdri smaller and if i finished the scene and iam going to final rendering, i switch it to the high res :smiley: think, it could be a workaround with which i can live until its got fixed