(Blender 2.8 Dec21 build) Solid view objects are semi-transparent in edit mode

Yeah, I just want it to be solid, like in 2.79. If I want to see through it, I’ll enable x-ray or wire frame.

batter share the Blend then, for more investigations

OK, I just stuck a couple cubes overlapping each other so you can see it.

Was too big to zip up and drop here, so it’s on Google Drive.
https://drive.google.com/open?id=1XDM4GSJhcIC0kzEryu9v60KzR7Nmnvef

It’s some setting somewhere I’m sure. I opened up a brand new file to make these cubes and didn’t have the issue. It wasn’t until I dropped the cube into the project I was working on that the transparency came back.

I saved my project with another name so I could delete all the assets, and just have the cube, the idea being to keep the file size as small as necessary. So this would be the same just without all the assets.

(I suppose I could just copy/paste all my assets to a new file, but what would I learn? :stuck_out_tongue: )

Your .blend looks the same here. I think this is considered a feature, that edges which are behind other objects (or parts of the same object here) are made visible in cases such as when penetrating a ground plane. With this feature you can see through the ground plane and see the bottom of the object so it’s easier to position relative to the plane because you can now see “how much of the iceberg is under water” as it were.

I know I recently saw a demo of this “new feature” but I’m unable to find it offhand (looked at release notes and a couple other places.

I’m not aware of any way to turn this off at the moment (which doesn’t mean there isn’t some way I just don’t know of). It’s not an overlay or any other specific thing that I can find.

Copy the cube, and paste it in a fresh, brand spanking new .blend file and it won’t look like that. (At least it didn’t on my end) It looked how you would expect it to look.

And I do remember the ground plane feature too, but I don’t remember much about it. It’s not something that was going to improve my quality of life, so I saved that limited brain space for more important things, like new hotkeys.

So I’m still having this problem, not sure if bug or feature, but it’s really distracting when I don’t want x-ray to have a little x-ray anyway.

x-ray off;

x-ray on;

As you can see it’s not full on x-ray, just a little bit x-ray.

Have you udated to the latest build? That was driving me nuts as well, but It’s fixed now.

Just downloaded the latest build this morning (Jan 07) and the problem is still there.

Have you updated your GPU driver? I’m not experiencing it my end.

Yeah, just updated it a few days ago.

Weird. This is how it looks my end. Not much good to you, I know, but just so you can see it’s not a ‘feature’ but either a bug or some setting you’ve enabled by mistake. Are you saying it doesn’t happen on a default scene, only the object in question?

It only seems to happen once I get a pretty good size file going. And it’s happened more than once, which means I would have had to accidentally changed the same setting at least twice.

So if I start a new scene like you did there, it’ll look the same, but if I created those same objects in my current working file, it would have that almost-x-ray look to it.

Current “mature” file;

Copy/pasted to a fresh blend file.

Definitely a bug then. I’ll test it on a larger scene. Or are you only getting it in long-running scenes, or scenes you’ve been progressively saving over a long period of time?

I would call it a scene I’ve saved many times over a long period of time. I’m using the outlier and collections to organize. So I have dozens of objects filed away in this scene, and I’ve been working on it for about a week or so.

Also, I’m just creating objects for a game, so it’s a lot of the same sorts of things over and over again. No lighting, no backgrounds, not even materials beyond some basic colors to help me visualize the objects different parts that will be dealt with by the game engine.

Maybe you could just save all the objects in separate files and copy/paste as needed between files? This sounds like garbage collection in a long-running file. Something might have corrupted the file and hasn’t been flushed. This used to happen in Max, a few years back, due to garbage collection in the undo buffer.

That gave me a thought. I copy/pasted EVERYTHING into a new file, and the problem went away. However, my collections aren’t organized. I wonder if there is a way to copy/paste everything and maintain the collections too?

(Currently I have 57 objects)

@HardRooster, it’s your clipping planes.

1st time I loaded your scene, I unchecked Load UI, and everything was fine.
Next time I loaded UI (with your scene), and I got the same issue. I had a feeling it was the clipping planes

To fix it change the clipping plane in: N Panel > View > Clip Start from 0.001m to 0.1m

While you’re at it, the blender default for Focal Length is too low for most purposes, try upping it up to something between 80-100.

All this depends on the actual scene size, there is no one fits all solution.

2 Likes

It sort of helps, but I have to set it to an unacceptably high number to even put a dent in it. Here it is at 25cm and still you can see some x-ray.

It’s the ratio between the 2 clipping planes that is creating that unwanted effect.

If you’re getting too much front clipping and you still have the issue, so you can’t raise the Clip Start, then lower down your Clip End.
You just gotta find that sweet spot for whatever your scene scale is.

What’s your GPU/Video Card?

Messing with the clip end doesn’t do anything to obscure the x-ray effect. It just…eventually…hides what I’m looking at while preserving the x-ray mess.

I’m running a GTX 1070