Blender 4.1 Auto Smooth is now a modifier ONLY!

In latest 4.1 alpha the auto smooth option has been removed and replaced by a modifier.
This means that every mesh you using auto smooth on, needs to have this modifier.

Adding this optional would have been cool, but without the base function it means that linked object can’t inherit any changes, like auto smooth.

So if you have a mesh, with 20 linked objects and want change normals to auto smooth, you have copy the modifier to all linked object data. Or you apply the modifier to the base mesh.

This makes a lot things much more complicated in my opinion.

For example, if you use smooth by angle, the normals get applied directly to the mesh. If you change your mesh, you need to redo it to work probably. Each time in object mode.

Example using Subdivision Modifier it inherits either the angle from the base mesh or you have to set all too smooth. Which will break the edge creasing. As creased edges need to be set to separately to sharp edge to work. There is no option to automatically set 100% creased edges to sharp. You would need to add a modifier for the normals. Again, that breaks linked mesh. And all linked geometry need to copy the modifier. (Yeah here you see what happens without having instances in Blender).

28 Likes

You should post this on devtalk.blender.org to get developer’s attention on it

6 Likes

I read the earlier developer notes on taking this approach, but I must have completely misunderstood something in the thread.

I thought they said that this modifier situation was an additional, not completely replacing autosmooth and forcing you to use the modifier on every single thing in the scene.

So this is not the case?

(Downloading the 10/22/23 4.1 build now.)

The did it like that:

  1. Take the modifier
  2. Apply mesh smooth to the base mesh once. Its not costume split data, but some kind of hidden data.

The main difference is, that auto smooth before was applied after the modifier stack and now before the modifier stack.

PS: https://devtalk.blender.org/t/auto-smooth-removal-in-4-1/31691

2 subdivided cubes; one shaded flat, the other smooth. Neither has been given a ‘smooth’ modifier at any point. I can also mark/unmark edges sharp on an object as I would expect.

What am i missing?

I tested 4.1 October 22, 03:45:45 build
Shade smooth command are still there + smooth modifier as addition.

Crease should automatically change the edge too sharp.

Plus when you model, you can’t repeat the auto smooth process each time you move a polygon.
Indeed that a really stupid thing. I can apply smoothing to a cube. Change an edge move it to be more flat and I have to tab to object mode again and re use auto smooth by angel then again and again…

How the hell should I model in the future?

1 Like

They removed the dynamic “auto-smooth” that was applied after everything else…
You need to have the modifier enabled if you want the smoothing to auto-update.

It’s a kind of a regression, it was a bit simpler before, but I suspect it caused a lot of issues too, especially with future development in mind… For instance deformed objects where very slow to compute with auto smooth enabled.

Having it that way will allow for more control over the autosmooth especially in geometry nodes, so we probably have to adapt to that and we’ll end up being rewarded with a better blender eventually.

In some ways it makes sense, when you model you use the modifier just like with the mirror modifier …
At some point the model is done, and you either apply these modifiers which is what you should do most of the time, or you decide to keep them dynamic if the model / project asks for it…
But for now we had a kind of hidden “auto-smooth” modifier at the end of the stack that we were forced to over abuse, now it’s time to let it go and change our workflow a bit … :smiley:

7 Likes

Why? It’s two different things.

1 Like

not it is not, its called workflow. I never had to do that Maya, 3dsmax, just turn on auto smooth done… no. brainer.
Now I have to add a modifier each time on each model.

In my opinion it ruins modeling in Blender.

4 Likes

Like I said, I must be missing something… I see no modifier applied, and I’m seeing smoothing where I’m marking it (or, doing an auto-smooth).

Where’s this modifier that is being referred to?

In 3.6:



It’s 2 different operations and results. Sharp isn’t the same thing as Crease.

3 Likes

Here’s a plain which was subdivided and i used “shade smooth” command. After i put bevel modifier and make some extrusions.
I doesnt see the needs to set smoothing again or put a modifier after this, its already smooth.

Oh, thats the thing which was changed:
If you make a plain and set smooth angle in object property to, let say, 45deg, you can extrude/move edges, vertices, whatever, and all your adges with certain angle will stay sharp (or smooth).

Now it doesnt work that way. If you use “Shade Smooth by angle” command it will work only with current state of your model. If you change something - you will need to apply those command again.
Or - use a “Smooth by angle” modifier.

Shade smooth/flat/angles its all was a bloody simple thing. I have no idea how blender developers was managed to screw it up in such a dumb way.
Absolute loonatic way to solve problems. Jesus!

Now each time you collapse the whole stack of modifiers after an array modifier, as example, you need to make extra step to put smooth modifier again.

1 Like

Yeah, actually I just tested it looks simpler now :

The mesh looks clean with just a bevel and harden normals option…
no need to activate autosmooth :slight_smile:
and the smooth by angle wasn’t useful in that case…
Maybe the behavior changed a bit and it more about making old mesh compatible…

I’m a bit lost too, now , but anyway, @thorn you can see the new modifier in the screenshot, and this panel disappear in 4.1 :
image

Ok let’s keep using 4.0 forever ! anyway, doesn’t seem that bad beside the annoyance to cleanup old projects… but that’s why they said 4.0 is a breaking release :smiley:

6 Likes

Yeah, lets brake the common sense of logic and usability.

Each time modifier stack will be collapsed it will be means the +1 step of adding those modifier back again. It’s just incompetence of people who was solve the problem.

1 Like

So, some of you guys actually used the autosmooth option? Like ever?

Maybe it’s just me, but I always thought it was a mess and more of a burden than a helpful thing. As I see it, the problem was how it was hard to control the effect. That is to say, it would easily sharpen edges I’d not want sharpened etc.

Only usecase I personally saw for it was with imported models (which may have been topologically too messy / too dense to mark edges sharp).

greetings, Kologe

5 Likes

A lot of people use it, actually.

Im personally only use it sometimes under prototyping process where i doesnt want to spend times on setting sharp edges manually.
Now those process will become more clumsy.

1 Like

No normal tab here. 4.1 alpha, just downloaded.

1 Like

Well, I must admit that what we had before wasn’t perfect either, having to switch panel each time I add a bevel or a weighted normal to activate autosmooth doesn’t looks good to me either…

Maybe we should just try to adapt to the new feature, in practice it might not be that of a concern that you might think it is, and if it’s really a big regression, chances are that a better solution will be provided eventually…

8 Likes