Blender is a bitch...

So just lost 4 hours of work on my model. Dunno how, but everything I did in 4 hours just disappeared and ctrl+shift+z does not work. Things like this makes you wanna give up…

Save often!
But you may be able to recover some of your work from an autosave or the .bend1 backup.

Could you explain a bit more what has happened?

I don’t know. Suddenly all my work was just gone while I was working with the model and I have tried everything to get it back. I must have accidentally pressed wrong buttons. Ah well, nothing to do I guess than to start over. Wished I remember to save more often.

Well, if I have to guess maybe you were working in edit mode, then you changed to object mode and applied Ctrl+Z (or something like that). Then you’ve changed to edit mode again. It is a known problem with undo/redo system. And yes, you should always save your work periodically with incremental name: work_01.blend, work_02.blend, etc

did you accidentally add a new scene? check the scene tab to see if your old scene is still there.

i think i know what happened, since you said you tried Shift Ctrl Z.

You used CTRL +Z in object mode, then went into edit mode for a moment. entering editmode will delete the progress you recently undid in object mode.
just be more careful.

By default blender autosaves every 3 minutes?, so when ever it crashes, re-open and try file - recover-autosave, that will take you to your autosave location, all autosaves should be in there, order them by date and you should have somehting to fall back on, check user preferences - file and the auto save setting, make sure it is on.
If your lucky you only lost 3 minutes of work, not 4 hours.

My guess is you simply switched layers. Happens a lot when you’re new to Blender.

omg that happened to me!! xD ohh dear… memories :slight_smile:

Robeloto if you have a referance image i can recreate what you lost. i assume you are new, so what takes you 4 hours would probably take me 10 min.

Robeloto, please check if you have a backup file of the original one and also don’t forget to check size of the original file. If it’s size gives a notion that there might still be something in there feel free to upload it here and we’ll try to resolve this together.

i must say, much as i love Blender i think the Object/Edit Mode separate Undo thing is extremely awful and dangerous. Not sure why it was implemented this way instead of simply a single list of actions but at the very least there should be a warning pop-up if you Ctrl-Z in Object mode after making edits. the fact that it is not undoable when you realise your mistake is a major issue too, IMO.

Personally i dont find it an issue, but i think this is a bigger problem for people who started out with other programs and for newer users, and i see no reason why it would delete the progress.

i mean if you Undo in object mode, you are literarly 1 button away form deleting everything you just undid with no chanse of redoing it.
i think it should be patched so that you can still redo for at least a sertain amount of time.

I think that just by looking at the file size he could determine if there’s anything left in there.

Couldn’t agree more, I have fell foul of this on more than one occasion, it is, ahem, annoying.

That’s a bad thread title do you guys agree? it should read “I made something wrong, how can I recover my work?” or something like this. also if you want help, you should help us helping you. Answer the questions, there’s even one guy offering his time to remodel your stuff!

You could write a novel in Word and after 400 pages if you don’t save, you can’t tell that Word is a bitch! :wink:
It’s not fair to say bitch, when you don’t even know what you did!

I agree. Don’t blame Blender for user error. Also, as folks here are saying, you can recover your work – assuming you didn’t turn off the autosave feature.

Something that I dont think has been suggested yet is that you might of changed layers. I had this happen once, took me forever to figure it out.

How many times have I lost hours of work because of a mis-typed key? It happens.