Blender is laggy when using material viewport preview


I recently had my PC upgraded with a processor that supports blender. Now, when I tried using viewport preview (solid), it went smooth, but using the material preview makes it lag, and unusable. Is there anything to disable to remove this lag?


Material preview is Eevee, therefore it makes extensive use of GPU (OpenGL)
You mention here the specifications of your CPU and GPU.
You can share a .blend file where you have that problem for other users to analyze.

Processor: AMD Ryzen 5 1500X Quad-Core Processor 3.50 GHz

Graphic Card: NVIDIA GeForce GT 330

It is a weak GPU for Blender 2.8/2.9
What is recommended is a GPU no older than 10 years and with a minimum of 4GB of vRAM.

Please, when you have the money available you open a thread here in the “Technical Support” section to ask about the best GPU you can get according to your budget.

1 Like

Yes, but is there a setting so I can still have material preview while it not lagging? There must be a setting, right? Or, at least something for it to have CPU?

CPU is important only at first when shaders are compiled, but then when you can see the materials then the work in Material Preview is pure GPU.
What is the resolution of your monitor/screen? As with games, with Eevee the lower the screen resolution the better the performance. So if you lower the screen resolution from your operating system, you may gain some performance. But this can be very uncomfortable to work with.
My recommendation is that until you can buy a better GPU, you use old Blender 2.79b.

Well, perhaps in the settings of blender? My resolution is 1080p. But I don’t want to disable the resolution on my PC itself, perhaps I can lower the texture preview quality?

Preferences > Viewport > Textures > Limit Size

Not sure why it is not en Simplify menu like in Cycles.

Still doesn’t work, I don’t wanna switch to 2.7x tho, is there really nothing I can do?

I don’t think so, that graphics card is really weak for Eevee’s requirements.

What do you suggest I do? I don’t have much money for a new graphic card btw (i got a new pc recently, we kept the graphic card)

Unfortunately there is not much that can be done about Eevee, more than what I have already suggested. Also using Sampling=1 for Viewport might help a bit. And don’t use heavy features for Eevee like Volumetrics, High Shadow Resolutions, Refraction, Depth of Field. Keep materials simple nodes.

Your options are:

  • Use Blender 2.79b.
  • Or in 2.8+ use only Solid mode, and Cycles for render and preview with CPU.
  • When you do manage to raise some money, be sure to ask in the forum about what your best options are according to your budget.

Even Cycles CPU has lag when preview. right now I guess I have 70€, but idk, i think i’ll wait a bit first

Like, I can see the preview just fine, it’s just that i cannot move, and my pc gets really laggy when i try doing that material preview

You also have to take into account your current PSU power capabilities for a new card. GT 330 is really very low power consumption.
With 70€ maybe you can get a second hand 4GB vRAM nvidia GPU. But personally I consider second hand card risky, there is no guarantee. You will see later if you can raise money for at least a GTX 1050 Ti 4GB vRAM. Or an AMD/ATI 4GB or more vRAM with similar or better performance than a GTX 1050 Ti (look for a Games Benchmark to compare performance)

1 Like

I have an integrated intel GPU that is a bit better than your GT 330, and I also get poor performance with Eevee.

Do you have that very bad performance with only one scene or with most scenes? Just in case you could share one of the scenes where you have problems, just to see if there is anything out of the ordinary.

One scene. I don’t want to share the file publically, though. Is there a way I can contact you privately? (It’s a head of a character for a fangame I am making.)

You click on my avatar in one of my posts and then in the new window that opens you will see the “Message” button.

it doesn’t show…

Do you have Discord perhaps