Blender to After Effects EXR issue

Hello everyone. I’m having this issue when rendering in EXR format my image in after effects (and also in ps, fusion, pdplayer) looks slightly brighter than in blender (if I import rendered image back in blender it looks correct). Other formats seems to be ok. I guess this is color space issue but I couldn’t find a solution so far, anyone had this problem?
upd: here’s the pictures, left one is what I’m seeing in blender, right one is what I’m seeing in other software

Screenshot your render and output settings so we can see if it’s something in your settings. Also not all EXR handling is made equal. You may have to download a plugin to get the transparency.

Additionally, take note of the Open Rasta Graphics format (ORA).

It’s becoming more available and currently works with GIMP. Instead of being one file that you have to render several layers to, you can work with pngs in groups with meta for all kinds of effects, and it can be accessed through compression software like 7zip.

Our industry will slowly adopt that and exr may subsequently fall out of favor…But that day is not quite here yet as far as I can tell :slight_smile:

Hey Thanks for an anwer. Settings are default.


What’s your technique for getting it into other software? Also what software versions on the outside software? I’ve noticed that Photoshop cc (21.0.3) doesn’t like importing the transparency as alpha channel, do you get the option to pick layer transparency as opposed to channel based?

I also tested your setup and layers have working alpha, just dragging the EXR’s into AE (version 17.0.2). I even tried with the multi-layer EXRS using the ExtractoR in aftereffects, still works.

I thought it could have been your codec setting (RLE instead of the default Zip setting’) But I get pretty much the same results either way. I also ruled out that under ‘film’ in your render settings that ‘transparent’ would be ticked for you to see the result on the left for the original post.

If you give me a test render with the same issues as you’re having here, I can try it out.
If it works for me, that will pretty much confirm that it’s most likely software/workflow related.

You could also try providing us a blend file to test.

Sure, here is the .blend
If just hit render right away you’ll get the exr with the problem.

I’m using After Effects CC 2018, but I can see that overexposure everywhere, pdplayer, Fusion 16 etc. except blender, if I import that exr back to new scene in blender it looks just fine.
My technique is just import, I’ve tried different ways to interpret it’s color space in After Effects and some of them were pretty close to what I’m getting in Blender but I want it to be precise when it comes to colors.

in blender you see everything through a “Filmic” LUT by default. It is variation of the ACES color pipeline standart. Picture on the left looks like it is on - one of the most prominent features is how it handles overbright areas. It has S-like curve that pushes subep bright values down to make it look more like how real film work.
This kind of look is a standard in CG industry but it isn’t supported by everyone yet.
so you need to:
1 - disable Filmic in blender and work old-school in sRGB
2 - read about Filmic/ACES workflow and how to intergate it with after effects (I’m sure there are LUTs for that somewhere)

Yeah I forgot to mention this! I seriously don’t get why Filmic is default.

I was more obsessed with getting the alpha working haha… tunnel vision.


bacause it is actually should be )))

And yet it’s not default everywhere else yet… so we have to keep wasting time changing a setting for the sake of argument. Lol It’s like putting ORA as an output format… would be cool, glad it’s there, but not currently useful as default.

Filmic is default because it is a step up from the awful sRGB display transform.

Adobe doesn’t properly support OCIO. You can either save 16 bit .tiff from Blender, which will still have plenty of data for compositing with, or try setting up fnord’s AE plugin -

1 Like

So I just tested the blend file, did the render, output to Aftereffects and it’s working for me. It seems as though exr functionality may be missing from older versions.

So the next thing you might want to try is testing this in the latest version of adobe CC if you can grab a trial. OR find a plugin that provides better support for EXR. Have you tried the plugin I mentioned above? (EXR-IO) That’ll get you by with Photoshop. There would be others like that for AE.

For the record, you can also control


It need just one time to understand how it works.
It looks like some unnecessary extra step at first but then you just couldn’t understand how have you been working in sRgb before

I agree, it’s much better work in Filmic than sRGB. Actually I think working in linear color space is default now for other 3d softwares too, coming from my C4D experience where linear sRGB is default. I’ll try the solutions suggested here to get the same look in after effects.

Yeah… linear is also the default in Modo…

It was maybe confusing the way I spoke about filmic, but I know what filmic is good for. I’m simply telling you guys it doesn’t make sense that it’s on by default, and that’s yet to be proven otherwise tbh.

Even from standpoint of having more dynamic range of colors, why not leave the default at ‘Filmic Log’?

my argument stands, and I’ll make it even more clear:

Filmic is very flexible and awesome. IF you’re working IN Blender OR software that SUPPORTS it.
Always had that understanding.

But does this guy have filmic settings in after effects? it doesn’t appear so…

Damn Blender and it’s alternate names for things. (I’m kidding, I love blender btw)

You said before that render from my .blend worked for you, no? You got the same result in AE as in Blender? I’m talking about colors and overexposure, not the transparency or something.

Oh ok, two things, I thought since your right image had a black background instead of trans checker, that you had a problem with alpha as well. My mistake.

I’m also really tired :smiley:

I just tried filmic LOG and it seems to be the same as Linear. It tried it and it gave me the correct colors in AE.

Yeah, this is it. My first thought was about color space issue, I guess using raw(which is linear srgb right?) or conventional ACESis the best way for now.
Anyway thank you everybody.

Playing devils advocate about my argument because I care more about being corrected than being right :smiley:



Because the basic sRGB nonlinear transfer functions (OETF / EOTF) were designed to describe an aspect of device response and never for rendering. This configuration is a step towards providing imagers with a reliable camera rendering transform and a base of aesthetic looks useful for modern raytracing engine CGI, animation, and visual effects work with real-world cameras. "

It does appear to be visually closer to SRGB while having that high dynamic range. That’s the argument I wish someone made :slight_smile: STILL though, I can’t simply pass filmic transform renders to my team, they’d ask me to re-render in RGB or linear. Most people don’t composite much directly within Blender like the OP.

While we’re here though, I kind of wish that Blender just called it Linear instead of Filmic Log. This post might never have happened if it were more intuitive like that. Most people refer to it as Linear.

1 Like

Filmic is a display transform. If you need your render to display the same in other applications it will have to go through the same display transform. So, either apply the transform before the image leaves Blender, or after it arrives in After Effects.

btw, linear is not a colour space, and when mentioning gamma, please refer to GammaCat’s excellent advisory -

1 Like