Can't find any animation curves in Graph Editor

Hi, total newbie problem here, but I’m trying to use the Graph Editor to do things like make my propeller animation cyclic, and my problem is that in all the tutorials, people seem to just add keyframes to an object and then go to the graph editor and start modifying the curves they find there. However, nothing I have done so far has resulted in anything but a horizontal green line in the graph editor. I have added keyframes to my propeller blades, they rotate, I select the parts that have the animations on them, and clicked around on everything I can think of, but so far, no curves.

Obviously I’m missing something that everybody else figured out on day one… any suggestions as to what it might be?

Many thanks for any advice.

Hi,

maybe you haven’t turned autokey on. That’s in the timeline header. If left unchecked, one needs to actually right click and choose “add keyframe” on each property (translate, rotate, etc) when changed, otherwise changes are lost when moving in the timeline.

Hm, thanks, I wasn’t looking at that, but it seems like I did it, at least now… I now have an orange bar between the first keyframe and the second keyframe, on a different part I just added rotation to with autokey turned on (I think). But still no curves. Here’s a screenshot, see anything obviously wrong?

(The propeller looks stupid because I’ve been testing rotations on one blade at a time while I figure things out.)

You have the graph editor set for only selected objects. Uncheck it and hit home and see if that brings it back. Else post a blend.

Hm, still no good. Here’s my blend though:

http://megamotionsoftware.com/files/mainrotor_w_disc_spinning.blend

Thanks for your help!

Btw nice demo reel @Hadriscus !

Ah, well, I still don’t know what’s wrong with my file but I started over with a fresh cube and found my curves, and started importing my model and they’re still there, so I guess I’m back on a forward path. Thanks again, happy blending!

Your object level filter is turned off. I think if you turn it on you can see the object level keyframes. Fourth filter from the left.

Ah sure enough, there it is! That was it. Thanks!!

I have same problem but I can`t find < object level filter >

It’s now in the filter popover, the icon that looks like a funnel.