Can't move the camera in Blender 2.8 more than once - camera keeps snapping back to position

Hi,

Trying to animate the camera, but it just keeps snapping back to it’s previous position as soon as I want to set a keyframe. And instead of the camera icon moving in the viewport, there’s like a pane from the front of the camera that moves when moving the camera.
The weird thing is, I can animate the camera once after opening a file, and all works as expected. But not a second time.
Using blender 2.8 from yesterday.

I hope someone can help as it’s costing me a lot of time, and this is kind of urgent :frowning: Thanks!

Sure you don’t have auto keyframing on?

Hmm, good point but no, auto keyframing is not turned on.

I recorded the problem:
As you can see (I’m using a camera rig in this case) I can move the camera until I set the first keyframe. After that it seems to be snapping back to that keyframe whenever I try to move it.

Seems like it has to do with the follow path modifier. Animating outside of that works fine. Hmmmm… However if you edit the motion in the graph editor it works, but there is no real time feedback in the modifier offset display. Perhaps this is something that is not quite working as it should yet, or a standing bug. I don’t think they will take a bug report about this until the beta is out.

The same problem is there with just a plain old camera with no constraints or anything.
It’s weird! Like I said, I’m able to set keys once - just not twice … It’s like you can delete the keyframe, but they are still kinda there in the background. I’m deleting them from the timeline (which is a big improvement over the ALT+i thing from before btw). I dunno… maybe it’s just a temporary thing. Thanks for your reply!

Other than this little problem though, I’m in love with Blender 2.8. It’s so great!

This is what I got in the graph editor. When I opened it up the keyframes were flat

Thanks, I appreciate your help.

I am still struggling with this. Even if I delete my camera, add a new one, after setting a keyframe I can no longer move the camera. Any help with this would be appreciated.

EDIT: It seems to be fixed in the new update.
EDIT2: Nope, spoke too soon… could only set 2 keyframes the one time.

1 Like

Seems like it’s a bug or something. Happened to me just now and it’s just so frustrating. My solution was i added an empty and parent my camera to that. It seems only work with objects except camera.

1 Like

doesnt happen when you change view/shading (the option next to wireframe-view, forgot the name). will doublecheck later.

Update: Cannot reproduce the issue anymore. View where problem didn’t occur is Display in Solid Mode.

1 Like

The same for me, changing the position of the keyframe with auto keyframing it’s not possible in rendered mode, only in solid mode. To reproduce:

  1. Turn on automatic keyframes;
  2. Set to rendered mode on viewport;
  3. Select the camera are move it’s position with;
  4. Go to frame 10 or another one and move the camera;
  5. It will return to the first position.
1 Like

"LQQK" at the actual animation curves: don’t try to guess what they are. If you move the camera in frame #10, you must keyframe the camera before switching frames. You’ll see that, when you do so, a point has been added to three or six of the animation curves (Loc and Rot.). If keyframes, hence animation curves, exist, they will determine the location of the object for each frame.

Modifiers such as “follow path” can have a similar effect, but they can be temporarily switched-off.

This happens at the moment. I find that switching to Workbench or Cycles can (sometimes) allow you to set the keyframes without the camera jumping back. Sometimes if you are not viewing the scene through the camera you can set the keyframes but I’ve had cases where this doesn’t work either. It’s a bug and I’m sure it will be addressed soon as this is pretty important to a lot of us. I’ve a feeling this is tied to an out of date camera position/orientation keyframe or interpolated position that is overriding the one you thought you just set when the viewport refreshes.

1 Like

I’m so glad I stumbled on this, I couldn’t figure out why it worked and sometimes it didn’t. I can confirm that setting the view to Solid instead of Rendered (at least when set to Eevee, didn’t try Cycles), allows you to keyframe camera location/rotation. Thanks!

1 Like

So it does the same thing for me too But it does NOT fix the issue to do it in solid mode. I get the same issue. Neither does saving, Opening a new file, Turning off Auto key, nothing mentioned here worked for me…

it used to happen to me with auto IK in a previous build. After having assigning keyframes to an action, whenever I tried to move the character, it would aways snap back to the previous transformations from previous keyframes. The “solution” i have found to the problem with auto ik was by pressing “w” in pose mode, and clicking on “clear user transforms”. But idk if that function is available for object transformation.

I can confirm this issue as well. Just found it out today. Thank you all for offering some solutions. Changing the rendered view to a shaded or wireframe viewport seemed to solve it for me here. So this does seem to be a bug. Has anyone reported it yet?

1 Like

I’ve had similar issues for a long time, and have submitted bug reports. Not sure it’s been totally fixed, because I’m using a March 7 build and still having problems. I did just switch to solid mode and could move the camera in the 3D view. Otherwise, with EEVEE, I can only successfully move it in the graph editor, which is extremely slow. Thanks for the work-arounds. I’ll keep trying others.

Great community.

Having some issue with Blender 2.80.49 (downloaded today from latest build) Win 64bit – I do not have the issue when switching to solid mode. It has only been occurring when viewing with EEVEE. Thank you Blender team for getting this fixed ASAP :slight_smile:

Yeah, I’m experience that kind of problem right now as well. Perhaps someone can help us :slight_smile: