Can't Select Anything

For some reason, I can no longer select or manipulate any objects with my mouse. I can use A to select and deselect everything, but that’s it. Besides being unable to select anything in any way besides the A hotkey, there are no problems. Once something is selected, I can still move it around with the mouse like always, I just can’t select or deselect with it, making me unable to manipulate vertices.

I have tried every Blender version from 2.52 and up, and it brought the same results, making me conclude that it’s something to do with my computer. However, this problem was not there originaly, as I have been able to select and deselect before. I just started Blender one day and suddenly I could no longer use the right mouse button to select vertices, and I have made no changes to my computer besides installing a couple of games.

I was wondering if anyone here would have any insight on what the problem is?
I’m using Windows 7 64 bit, with 2 Intel®Core™ i3-2310M CPU 2.10 GHZ processors.

1 Like

*** Moderation ***
moved from: Game Engine Support and Discussion
reason: belongs to Blender
*** End Of Moderation ***

Hi MadmanRobz,

that would make/drive me mad, too!

Help’s on the way, though. :smiley:

Did you try selecting anything in the Outliner?

If it’s a problem with different Blender versions, maybe it’s the mouse, or mouse drivers (?)

What is “The Outliner”? I’ve never come across this term before.
I’ve tried 2 different mouses and neither of them work, so I can’t imagine that to be the problem.
I’ve used basically the last 12 Bleender versions, and the problem persists, even though they’ve all worked perfectly previously.

The Outliner is usually found in the upper right of the default gui…if not, drag one into view (where ever you want it).

You can select objects there…also cameras, lights, etc.

But still don’t understand why you can’t select in the 3D view…maybe someone else has a clue(?)

In the mean time, hopefully, you can use the Outliner to make selections.

Attachments


Selectability for the objects may be turned off (the arrow symbol in the outliner).

I checked the Selectability, it’s not turned off. As I said, I’ve tried over 10 differet versions of Blender (reinstalled all of them several times) and the problem is there from the start in all versions, so I strongly doubt that it’s got anything to do with the program settings since the factory settings have worked before and should still be identical every time I reinstall it.

Ah, so that’s the Outliner. I know what that window is, I just never learned the name of it, so I got confused.
Still, it doesn’t solve my problem since it’s the vertices that I can’t manipulate. The Outliner only selects whole objects, not seperate vertices. I can select objects and move them around like always, it’s just the individual vertices that I can’t selector deselect or manipulate.
I can’t do any actual modeling without that ability :confused:

1 Like

Hey I’m literally having the same exact problem I know I’m clicking the mouse the right way did you ever figure out this problem if so how did you fix it or what did you figure out… desperately waiting for a reply :confused:

You are using Edit mode right? Because inability to select vertices sounds like you are in Object mode. Use Tab key or mode dropdown menu on bottom menu bar of 3D view.

I’m also having the exact same problem. It was working just fine, then it stopped working suddenly, but only for a few minutes then it came back suddenly… now it’s gone again and hasn’t returned. I restarted blender a couple of times; that didn’t help.

I encountered the same problem today in “Object Mode” today after adding a Quick Favourites and saving the system setting.

The only way I can continue selecting by Left Mouse Button in Object Mode is pressing the CTRL or SHIFT key at the same time.

Working in Edit Mode seems no problem.

It seems that this problem affect and persist in the .blender file only, not the Blender program system.

Temporary solutions:

  1. Change the “Select Key” option in [Preferences / Keymap / Select With] to “Right” (I use left mouse button to select in my case).
  2. Add a new Workspace and then delete the corrupted workspace. User can then resume selecting over the 3D Space using mouse buttons in the new workspace.
2 Likes

Hi,
I was got this problem also … i was fixed it same in [Edit / Preferences / Keymap ] down to 3D View and on the right was an option to reset… so i have try it and it was fixed the problem .
now i can chose objects back in Object Mode as usually.

For Blender v2.80 or later version, activation of “Tranform / Affect only / Origins” in 3D viewport / Options (at bottom right corner of 3D viewport) will restrict the gizmo’s MOVE / ROTATE / SCALE functions.

Same sort of thing happened to me just now in 2.81.
I was doing a bunch of point animation, then decided I didn’t like a lot of it and deleted small groups of keyframes. Blender started getting the whitewash screen over and over. I restarted the program and I could no longer see selected Items though I could select them. In edit mode, same thing… I could not see selected vertices/edges/faces, but I could blindly select things.
The only fix was to copy and past everything into a new Blender file, but that is a very time consuming fix as I have to now transfer all the different textures and materials.
This is a huge bug that needs to be fixed.

The problem might be because you use “select circle” as a tool. Try use any other tools (like Select Box) by left click at the icon and hold.
Screen Shot 2563-04-17 at 5.44.30 PM

3 Likes

I also just discovered that if you accidentally click the “eyeball” or hide something in the outliner, especially an entire collection, while you are working on it in local mode, you’ll still be able to toggle between edit and object mode on it and even select it in object mode, but you will not be able to select any vert, edges or faces. Pissed me off for ten minutes trying to figure out why I suddenly couldn’t select anything.

Hi everyone, I got the exact issue today and after one hour of search, I’m desperately not fixing the issue. As everyone in this thread, I can’t select any object in the scene but only in the Outliner. I tried each solution said here :

  • User pref : Reload Factory preferences + try each presets like Blender, Blender 27x etc.
  • User pref : I restored manually every custom kepmap.
  • I checked the Ouliner for any Selectable toggles and everything is selectable.
  • I tested all selection options in the viewport (Box, Tweak, Lasso etc).
  • I rebooted my computer.

The weird thing is that I opened a new General Scene and everything is ok. So I saved that as Startup file, opened my file making sure to uncheck Load UI but still, that did not work.

It seems to come from my file but I can figure whyAnd now I’m stuck. I can’t even Parent objects selected from the Outliner because Ctrl+P only works in the viewport. Could anyone help please?

If the issue is connected to only 1 file make sure you are in the object mode (or Edit mode if you want to select mesh instead of objects).
If that doesn’t help you can create a new file and append everything from the old one.

1 Like

Thanks @jerzygorskiart, appending my file in a new one was exactly what I was doing and found out that it solved the issue. But wow, that bug made me crazy and not knowing why even more.
Thanks for your help.

Kimp, you just saved me from hucking my PC across the room. Super frustrating. I guess I accidentally switched when I pressed W for the 75,000th time and remembered it’s now right-click to get to that menu.

2 Likes