Collection Manager Feedback

I have now re-enabled version 2.17.3, the version pre-installed by Blender. Now it works as well. :smiley:
Thanks anyway for your offered help.

Thanks for the info, this helps a lot! :slight_smile:
I’ll see what I can do about fixing this.

I’m sorry, but I can’t reproduce this on my end or think of a reason it should be behaving this way. I’ll keep my eyes open, but for now it doesn’t look like I’ll be able to fix this anytime soon :frowning:

What that numbers (50, 7, 26) stands for?

Zip Update for 2.93:

  • Added undo/redo support to CM popup (buttons near the top)
  • Added selection buttons next to the collection name to select objects in collections
    • LMB - Select all objects in collection (replaces selection)
    • Shift+LMB - Remove/Add collection objects from/to selection
    • Ctrl+LMB - Select all objects in nested collections (replaces selection)
    • Ctrl+Shift+LMB -Add/Remove nested collections objects to/from selection

Collection_Manager_v2_21_0.zip (44.8 KB)

Zip Update for 2.93:

  • Change CM popup selection indicators to diamonds.
  • Fix QCD renumbering adding a 21st slot.
  • Fix phantom mode not disabling the add collection buttons, undo buttons, and specials menu in the CM popup.

Collection_Manager_v2_21_3.zip (44.9 KB)

2 Likes

Also faced that issue on files that was made with using UI changing addon or something.

Example file
No QCD.blend (639.1 KB)

1 Like

This is wonderful that you managed to reproduce! What UI changing addon are you using?

1 Like

I received this file from a freelancer and am now asking him questions.

Ah, okay. I’m looking into it here, that file exhibits the problem on my computer so at least I can do some tests now :slight_smile:

1 Like

As it turned out, it is default Addons Filtering feature.

I was told that only MESH MACHINE addon survive filtering.

1 Like

Oh, so it was being filtered out? I think that’s expected then, when you check Filter Add-ons I believe that only the addons that are checked in the list below should operate (it’s actually a bug that the hotkeys for the Collection Manager still work when it’s filtered out).

@Dominik123 Can you check and see if you had Filter Add-ons checked and the Collection Manager filtered out? (Fingers crossed this is your issue as well :crossed_fingers:)

@Dominik123 Can you check and see if you had Filter Add-ons checked and the Collection Manager filtered out? (Fingers crossed this is your issue as well :crossed_fingers:)

Filter add-ons is not enabled. Since the 2.21.3 update, the problem has disappeared. It runs as it should at the moment :slightly_smiling_face: :+1:

1 Like

Ah, okay. Well, it’s great that the problem has disappeared. :slight_smile:
I’m still not sure why it didn’t work in the first place, but at least it works now!
Fingers crossed it continues to work :wink:

Well done, continue to refuel. This is a good function. I hope it can become the default setting of blender

1 Like

Thanks! :slight_smile:
By the way, is that “Well done, continue to refuel.” a quote from an old USAF flight simulator game?