Come give your opinions about Blender video editing

Hello! I’ve been using Blender for quite a while now (many years of hobbiest work). My friend and I recently decided to use it to make a movie. We took our video camera, recorded some cool scenes, and are using Blender’s Sequence editor to put the movie together and add special effects. However, there is s serious problem… Blender ABSOLUTLY WILL NOT do the audio properly. It is out of sync and messed up. I’ve tried everything under the sun, Disabling game sound, changing the sound buffer size, messing with the FPS, sync, rate, format, etc… It simply will not do the audio for the movies (I am outputting with the FFMPEG format). However, I reallly like the video Blender outputs, so I was wondering if you guys knew:

  1. If it is at all possible to make Blender’s audio export (with FFMPEG) work, or

  2. If Blender really is the best choice for video editing? This is where I need your opinions.
    Is there another video editing program like PowerDirector, Roxis Video editing, or some other suite that doesn’t cost too much but will still do what Blender will do? Another thing that would work fine is if anyone knows a nice program that will simply let you add audio to a video… that way I could use Blender to output the video, and I could use another program to add the audio to the final movie.

Any opinions, help, advice is much appreciated on how to make a home video. (Windows Movie maker IS NOT an option)

I’d look up all the threads that have been answered by PapaSmurf for tips that work.
I know that the VSE si a very powerful resource, and there have been problems with users trying to do stuff that overloads Blender ( I am the biggest offender of this, so I speak of myself), but the thing I see happening most is the need to cut out frames to get the audio back in sync, and I believe Papa said it was like cutting out a hundred per 1000, or something like that.

Actually, he said he’s been making the tutorial videos in the VSE, so look for answers there.

Good luck.:smiley:

You could always pirate a version of Final Cut, or After Effects or Adobe Premiere to edit it all together, that’s just my opinion

Uh, we don’t pirate, so I’d advise against it. Download the trial versions if you must, but no good comes from that other stuff.

I agree. Pirating IS stealing… period. Same as if I go out and steal a car… no different. No thanks!

Eh… actually, pirating is copying, not stealing. Same as if you used a Star Trek replicator to copy someone’s car.

I use VirtualDub (Vdub) to do my final audio/video mixes, with excellent results so far, very few probs with sync skip as long as the fully-mixed audio’s tight to begin with. VDub takes image sequences as video input as well as “normal” video like .avi’s, and you can do rudimentary vid editing (frame-frame cuts only) with it. I use the XviD codec and an mp3 codec for the final dubbing, get great quality with excellent compression ratios. So far my stuff is targeted for web delivery or standalone media-player use rather than TV or HD formats, but imo there shouldn’t be any huge issues with those, either.

I did my audio “mixing” for the about-to-be-finished Monster Movie in Blender’s VSE, starting with sound & music files recorded, processed, and edited to a certain degree in Audacity. I placed the WAVs in RAM (it’s a short movie, only 80sec total) in the VSE and synched them to the master scene’s animation (viewed with Alt+Shift+A in Wireframe for fastest playback) for preliminary timing, and after rendering out all scenes, used the VSE + Compositor to nail the sync. Only drawback I can see to this is that the VSE has an integer frame-based timeline, so getting lipsync hairline exact may be tricky. A couple of times I wanted to place an audio cut on a fractional frame, but had to choose between integer frame numbers

I haven’t used Blender for video editing in the VSE yet, but for image sequence editing, I find it excellent via the Compositor rather than the VSE. I was able to incorporate all my transition FX (lap dissolves and cuts) as well as timed text supers (sort of like subtitling) all in the same “master noodle.” The short has 4 animated scenes plus opening titles and end credits, all rendered and assembled in Blender.

Once I had the images nailed in the Compositor and the audio set in the VSE, I exported a “Mixdown” WAV of the VSE audio mix, and output the Compositor frames, then used those in VirtualDub for the final A-V mix. It synched perfectly, and it took only three trial mixes to get the audio timing perfected.

If you’re looking to do live-vid and rendered-image composites, VDub can also save video sequences out as frames, which might simplify some compositing tasks.

Everything I’ve mentioned is either Open Source or freeware, btw.

Thanks so much! You used the Compositor instead of the VSE? I didn’t even know that was possible. Does it fix audio errors? What if I want to add special effects with the VSE, and I still use the Compositor?

I’ll try out VirtualDub… it looks very promising. Thanks again!

Edit: Actually, another problem I am having in Blender is that it “chops” the audio up in certain places. When I do the “MIXDOWN” it actually records the “chops” in the mixeddown audio file… This has been bugging me allot. Is there any way to tell it to MIXDOWN properly… making the audio buffer larger doesn’t seem to help.

For editing and doing transitions on image sequences, yes. I’ve not tried using the Compositor with video clips.

I doubt anything in Blender can “fix audio errors” but that depends on what you mean by “errors.”

Without knowing more about how you’ve set up the VSE for an audio mixdown (RAM or HD? What source/type for the audio clips), it’d be real hard to venture even a guess about the “chopping” you report, which I suppose means that portions of the audio are clipped or distorted in the mixdown. Have you paid close attention to your mix levels (dB values)?

After I get my Monster Movie files sorted and archived, I’ll be doing some tests with the Compositor and the VSE with video clips made from the movie. I’ll report back after I see what’s up with video editing.

I am loading AVI files (videos) + Audio. The audio is from HD and out of the AVI file. What I mean by errors is that it isn’t “synced” and it is “choppy”.

Do you know what codecs are used for your .avi? If I can, I’ll use my A-V resources to try to imitate your process, see what I come up with.

You can’t alter or even see audio in the compositor. You don’t have quite the same level of control over movie files as you have when you import movies as a deinterlaced still sequence. If you want to use VSE Effects you’ll have to render from VSE then reimport to the compositor. If you use the compositor then you can enable do composite and do sequence and everything will go first to the compositor, then to the VSE in the render pipeline. This allows you to use compositor based effects in the VSE but not the other way around.

No need to quote entire posts in order to respond either.

Here’s what I can report using Monster Movie as a “test case.” In recap, it was produced by rendering composite image sequence frames from Blender, with a synced audio mixdown from the VSE saved as a separate WAV file, then muxed in VirtualDub using the XviD video and mp3 audio codecs. The resulting .avi I treated as one might output from a digital camcorder, and dropped it directly into the VSE (Movie+Audio - HD).

This split the video and audio into separate tracks/strips. The “split” audio was out of sync by exactly 15 frames (0.5s @ 30fps), with the video lagging. From what I can tell, this 1/2 second was “trimmed” from the front end of the audio track. I gauged this by loading my separate audio file from the original mixdown and syncing it with the video track in the VSE, then grabbing the split audio from the .avi and sliding it around 'til it synced with the original mixdown, which took an offset of 15 frames. Once re-synced, the VSE playback looked to be very smooth and kept sync through the entire 80 seconds.

One oddness: the frame-length shown in the VSE strip labels was different for the video and split audio – the video showed 2400 frames (correct) while the audio showed 2402, even though the audio seemed to have been shortened given the sync problem.
I experienced no audio distortions or glitches other than the lack of sync. Since I had no audio at the very front of the movie (the music comes in a tad later than the first video frames), the 1/2 sec trim wouldn’t be noticeable. I’ll try a more definitive test case later.

I was able to generate a clean mixdown from the “split” audio track, using the default settings.

I was able to generate an .avi sequence from the video track, uncompressed, that looked to be a faithful copy of the vid track in the VSE (compression artifacts and all). I was able to generate an image sequence (BMP format) from the vid track in the same fashion.

No surprises here so far. I’ll have to read up on using the VSE effects before I can test that end of things.

@The_Nerd: any chance you can make a clip from your problematic .avi available, so I can see/hear what you’re getting (if I have the same probs, that is)?

EDIT: I took a look at the waveforms of my original mixdown audio track, and there’s 0.7s of “silence” from the start of the track to the first audible waveforms. In the “split” mixdown, there is only 0.2 sec before 1st audio (hence the 1/2s sync slip), plus a 0.05s “artifact” waveform at the very start of the file, which sounds like it comes from the music. Obviously, there’s a bug in the code that splits the audio and video tracks into separate VSE strips.
Original mixdown on top, mixdown from the “split” audio below, courtesy Audacity.

By comparison, a WAV export of the .avi audio from Virtual Dub shows no sync prob and no artifact.

Could you be more specific about this process, please? I set up an editing session in the VSE using scenes from Monster Movie that had been made into uncompressed .avi with VDub. Using the built-in VSE FX the lap dissolves (called “Cross” in the manual) and straight cuts were somewhat simpler than with the compositor, but I have a more complex transition from the last action to the credits that had to be done in the Compositor. I built the transition in the Compositor, “cued” to start at a certain frame. Then I truncated (Kut) the VSE vid strip at the corresponding frame -1. My intent was to have the VSE render out all up until the transition built in the Compositor, then have the Comp’r take over. I enabled both Do Composite and Do Sequence, rendered to a .avi, uncompressed. The result was that all the VSE strips rendered out fine, but at the point where the Compositor was to take over, just black frames were output.

By switching to just Do Composite and rendering the range the Compositor was handling, it works fine.

This seems to indicate that you cannot output from both the VSE and the Compositor in the same session, which seems a bit limiting. Or is there some step I missed that would allow the Compositor output to be recorded as intended?

@ The_Nerd: Here’s a possible workflow for your project. First, get hold of VirtualDub. Use it to export the audio from your .AVI files as WAVs. Then drop your .avi files in the VSE and erase the audio strips that are generated (the out-of-sync and “choppy” ones). Replace them with the WAV files from VDub. Hopefully you have easy sync points like clapper frames to sync to. If not, best of luck. Perhaps you can use the “choppy” audio strips to help sync the VDub WAVs before deleting them. Now you have clean audio and clean video strips, hopefully synced as well as the originals. You can do the built-in transitions and FX (see the manual) right in the VSE, but if you need to do Compositor FX, you’ll likely have to render them out separately first and then bring them into the VSE (see above).

Keep in mind also that if your .avi files are from anything other than a very high-performance digital camera, they’ll likely have some compression artifacts that cannot be removed and may contrast with very clean renders from Blender. This will be compounded to a degree in the final A-V mix in VDub, where another layer of compression will be added.

As far as I can tell, anything built in the compsitor renders first then it moves on to the sequencer. I don’t think you can do it in reverse order. I have only used the sequencer on a few occasions. I find the workflow distasteful because I cut my teeth on Adobe apps and still rely heavily on them. It’s fine for video editing I guess but I don’t do much of that. Here’s 2 images output first with only do composite enabled, then with do composite and do sequence plus the glow effect in the sequencer. You can tell the compositor is working in the sequencer because the green cubes were originally gray and were multiplied by 100% green via a mix node which makes them appear shadeless. You can seperate into scenes by render layer in order to apply VSE only effects to what were formerly render layers without having to apply the effects to the entire render. I mainly don’t like VSE because it re-renders every time you move the time marker. I don’t know of any way to disable that function and it is not ESCapable.

Edited to show the original. I’ll upload a file if you want but it’s a fairly simple process.


So what is the connection between the Compositor and the VSE that allows the Comp’r output to be subsequently modified by the VSE effect? Is something placed in the VSE that is the “pipeline” from the Comp’r? I guess a .blend would be helpful.

Well, when you enable both render options you then place the scene strips in the sequencer and sequencer effects are added after nodes are calculated (I think). One .blend coming up:


You need to be in the sequencer in order for this to render them both. If you are not it seems that only the compositor gets output.

“Scene” – that’s the ticket! Thanks, RB. I wasn’t cogitating the Compositor setup as being part of “Scene”, since that seemed to be a component of the Blender universe somewhat distinct from the compositor. Sussing all the inter-relationships can be a bit brain-boggling, 'specially at 1 a.m. or so. Didn’t help that you can’t scrub through the scene strip like you can through the video strips, makes it seem like using the Scene component has no effect. At at least :slight_smile:

Anyway, placing the Scene element in the VSE got the Compositor output into the render stream. Cool. And thanks again.

I did some further testing of the VSE’s treatment of imported Movie+Audio -HD items, specifically various types of .avi sequences muxed in VirtualDub. I used some carefully constructed sequences that have built-in timing elements: a 5 sec image sequence with “blink” frames at 1s intervals, and an audio beat track with both 1/10s and 1s patterns.

The results were interesting. In ALL cases, whether the .avi used any compression codecs or not, the split audio produced by the VSE import was out of sync and distorted. The amount and type of audio glitching seems to be codec-dependent – I got different results using the mp3 and the CCITuLaw audio codecs, or even no audio compression.

The video was strange as well. My first timed vid track was all black with white blink frames every 30f (1/sec) to sync with the audio beats. With no compression, or using the Cinepak codec at Q=90, there was no prob with the video in the VSE. But when using the XviD codec, very strange things happen. The white frames no longer appear at the proper intervals, and in fact appear at different intervals depending on when you “scrub” the track! The first scrub after importing the XviD .avi gave very odd intervals, like white frames at 26f, 31f, 57f, 77f, and even 97f (even though there are only 4 white frames in the sequence). After this, every scrub showed white frames at 21f, 41f, 61f, and 81f, a 20-frame interval instead of 30. Weird. In repeat tests, each “first scrub” showed odd (and seemingly random) intervals, all others showed the 20f interval.

This does not apply to all kinds of video, though. Thinking that the large amount of black frames in the test strip might be glitching things somehow, I made a second strip where the frames ramp from near-black to white, each ramp = 1second. In this case the XviD import “lost” no frames and kept the proper intervals.

This may not be an issue in most instances, but if there are cases where an XviD .avi file has lots of black between some segments, the resulting strip in the VSE may (and this needs to be tested thoroughly) have some issues with this odd frame-dropping glitch.

XviD is an Mpeg-4 codec, as I believe is DivX, one of the more popular commercially-used video codecs. The results of importing Movie+Audio into the VSE should be tested with a wide range of codecs to see what differences there may be. Those used by digital camcorders should be targeted in particular since many folk will likely want to use this source of A-V for some of their Blender projects.

I’ll write this up and package my test files for a bug report as well.

I know what you mean about the brain-boggling part. As far as imaging apps go Blender probably has more functionality than the next three runners up combined. The only other software that I’ve ever seen with this much diversity is operating systems.