DAZ Importer

add-ons

(Handel) #162

Done.
Here is the render preview -


Please notice the black outlines around the clothes.

Edit: Weird - did the same test render with the same basic G3 guy with standard Daz bought clothes and more or less the same lights. And no black outline around the clothes besides the strange light effect at the shoes:


(TwoDads) #163

I have installed and setup the plugin as per : http://diffeomorphic.blogspot.com/p/daz-importer-version-13.html

However I don’t have the option in Blender 2.79 to Import a JSON.

Everything exports ok from DAZ Studio.

What am I doing wrong?


(TwoDads) #164

Using the “Import DAZ File” button ->

This is the Console Window Output:

Fitting objects with .json file…
Traceback (most recent call last):
File “C:\Users\twoda\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\import-daz\daz.py”, line 51, in execute
getMainAsset(self.filepath, context, self)
File “C:\Users\twoda\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\import-daz\main.py”, line 72, in getMainAsset
fitToFile(filepath, main.nodes)
File “C:\Users\twoda\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\import-daz\objfile.py”, line 249, in fitToFile
verts = objects[nname][idx]
IndexError: list index out of range

location: :-1


(ThomasL) #166

I have never encountered that problem, and have no idea how it arises. Perhaps with multiple instances of the same object. Anyway, the development version has been updated so the problem should not cause a crash. Rather, the offending piece of clothing is not fitted to the character, so that has to be done by hand.


(Daz1) #167

I have hair that does not work with hair dynamics. How do I get to work?


(ThomasL) #168

Could you be more specific?

Hair is imported just as any other mesh. To get dynamic hair in DS you use something called DForce, I think, but that is completely ignored by this plugin. How to make mesh hair dynamic is something that I have played with, but I dont have good answer to. Assigning a cloth modifier directly to the highpoly hair is not feasible. A cloth modifier on a lowpoly object and a surface deform modifier on the highpoly hair works in some situations without bogging down my computer completely.

Then the plugin has a tool for converting mesh hair to particle hair. This only works for certain types of hair (UV coords decrease vertically along the strands). Fortunately, most hair assets created for DS seem to be of this type. But again, you need to set up dynamics for particle hair yourself, and there are many people much more qualified than myself in that.


(Daz1) #169

I’m sorry for the questions being rough.
My question is the content of Blender.
I created a particle hair using the plugin of Ver. 1.3.1.
Next, I switched on hair dynamics of all particle hair.
And I played the animation.
Some hair moves, but some hair did not move.
The environment used is as follows.
Windows 10 Pro 64bit
Blender 2.79b
import-daz-v1.3.1-20181016.zip


(lexabesed) #170

Today I noticed that when loading face unit does not work protruding language(


(Daz1) #171

I checked the mesh of the particle hair which does not move.
The root of the two meshes was connected.
I started to move as I divided the foundation.
Thank you very much.


(steven850) #172

Hi Thomas, I was wondering if there is a way to add a pause into the rigify script. I prefer the rigify rig over mhx, but some options are currently not usable. When using rigify manually, you place the meta rig, and then you can select different options for each bone chain. The type of spine to use, the type of arm and hand rig etc.

You select each chain and set the rig type you want to use, before hitting the rigify button. your script runs through the entire rigify process without giving the option to make these changes, using just the default rigify settings. So is it possible to have the script pause to be able to select different hand rigs?

Thanks,
Steven


(ThomasL) #173

Implemented in the development version.

Apart from the Convert To Rigify button, there are now two new buttons: Create Metarig and Rigify Metarig. So you can create the metarig from the DAZ rig, do whatever you want with it, and then convert the modified metarig to rigify.

It is important that you don’t delete the original rig after creating the metarig. It still contains a lot of info (like drivers) that is needed in the second step.

I’m not using rigify myself, so I haven’t tested making any advanced changes to the metarig. But if you press the two new buttons in order, you get the same result as before. If you modify the metarig, things may or may not work


#174

I can not get it to install on 2.8, and doesn’t work well in 2.79 stable(non-nightly). Will only load the G3 mesh and hair. No clothing of any kind. Still have more trouble shooting to do just to rule out me being dumb. Doesn’t seem to like GoldenPalace G3F gens as well. I’ll send you what ever you need if it will help.


(ThomasL) #175

The stable version does not work on 2.80. The development version works on Blender 2.80 downloaded about a week ago. I haven’t checked if there has been any more recent changes in the api that breaks something. There are no guarantees that the plug-in will work on Blender 2.80 before there is a stable release with a stable api.

A G3F character with Goldenpalace should work. If the clothes don’t load, perhaps there is some problem with them. Are there any error messages in the terminal window? (You need to start Blender from a DOS/terminal window to see them).


#176

Ahhh, i see. Okay. I’ve been busy because of the holiday, but as soon as I can I’ll dig in again.


#177

Okay so it was more than one thing causing the problem. The list of messages i was seeing in the CMD prompt were so long i couldn’t read them all. However everything I was seeing seemed to be dealing with morphs that i narrowed down to being applied goldenpalace. Not exactly sure what it was, but I have also decided to not use that addon for other reasons. If I find anything more I will send to to wherever you like.


(lexabesed) #178

Greetings, today I downloaded a new version from bitbucket, but when I tried to activate the addon, I got an error


(ThomasL) #179

Yes, I just noticed that too, and fixed it. I still mainly work with B2.79 and only check that things work in B2.80 occasionally.


(lexabesed) #180

ThomasL, thanks, now everything works


(mercuryraven) #181

I imported my files and converted to to mhx, everything seems to be cool but why are the sleeves like this? Do I have to fix them manually? if so exactly where? (I am not to familiar with weight painting)

I think same thing happens with rigify too…

edit : I checked it out on studio and it actually gives the same result so its not the importer…sorry about that…would want tips on it regardless


(slawdos) #182

Hi, ThomasL!
I have scene with a two people with timeline animation.
When I import it in blender 2.79b(25.12 build) i have some errors. Importer download 25.12 from DEV.

WIFDW? May be needs export for each people?
Tanx. And Merry Christmas, and Happy New Year!