delayed path start?

i have a camera that simply follows a path.
how do i delay the following to a later frame?
i would like 150 frames to occur before the camera follows the path.
do i need to make three animations?
before, during and after? surely not!
thanks all

Add a follow path constraint to the object and keyframe the ‘Offset’ value in the constraint settings

Don’t use Ctrl+P to add the follow path constraint or you will have to first remove the generated f curve modifier in the graph editor before you can add any keyframes

when i click on the camera the modifier thingy does not show.
i assume i am still confused!

You need to be more detailed about your problem and tell us what you have done so far, or provide your blend file so we can look at it.

easy. i have a camera that will look at a sign for 3 seconds then follow a path for 4 seconds then be stationary for a long time while pictures appear in front of it.
i think the constraint is in the modifier thingy. which does not appear when i click on the camera. hopefully i am wrong!

Constraints are accessed by the constraints button, modifiers are accessed by the modifiers button


well i am still lost.
as i have written many times, these blender instructions are meant as a reminder for people who already know it.
they are no use to folks like me.
where and how do i get that panel?
thanks guys


slideshow2017–6.blend (1.42 MB)

The ‘follow path’ constraint is added to the object following the path, not the path you want it to follow.

Constraints are used to animate objects so you add them to objects you want to animate

great so where do i get the panel when i select the camera?

See the screenshot in my previous post

THANKS but why has blender in its infinite wisdom moved my camera miles away?
am i on the right screen?


i moved the camera close to the curve
pity the camera does not move in this set up

After you add the Follow Path modifier to the camera, it will jump to another location. Just hit Alt-G to place it on the path. Once the camera has the modifier on it, you shouldn’t try moving it or you mess everything up.

I usually lock the camera after putting it on a path so I don’t accidentally try to move it. You can do this via the 3D viewport property panel (press N to get it ) under the Display section (or is it View?). Just make sure the Lock Camera to View is toggled off.

thanks for trying but it looks like it is time to give up.
i select the camera, press alt-G and the camera just sits there. no movement. adjusting the offset moves the camera.
but the purpose of all this was to get the offset so it would delay the start of the camera by 4 seconds. is the offset in frames?

i can make a movie of the camera stationary with one blend file .
then make a movie of the camera moving in another file.
i can join them in pinnacle software. blender probably can do this but i do not know how to do that.



slideshow2017–6.blend (1.39 MB)

Don’t give up… Just take a break from the problem for a while and then start fresh.

I don’t have Blender in front of me so I can’t help you more at the moment, but I’ll be back…

What I said about avoiding moving the camera after setting the Follow Path constraint only applies when you’re actually viewing through the camera. You can otherwise still move it around as much as you want when it has the constraint on it. Sorry that I didn’t make that clear.

Richard Marklew and I have given you two different approaches to your problem, which has probably just confused you further. The Offset value for the Follow Path constraint allows you to delay path movement by a given number of frames. I find this method a little confusing, but it’s quite useful when you have multiple objects following the same path at different intervals.

I’ve looked at your blend file and I can see that you’ve missed doing a few things, so let me go through this from step one. We’ll use an animation length of 150 frames and we’ll start the camera motion at frame 100, which is what I think you were trying to do. This means that the camera will follow the path only for the last 50 frames.

  1. Set your total frame count to 150 on the Timeline menu bar.
  2. Create your path with a curve and edit it however you want.
  3. Go to the curve’s Data Properties panel > Path Animation, and set Frames to 50.
  4. Go to frame 101 in the timeline.
  5. Set the Path Animation Evaluation time to 1. Add a keyframe to that value.
  6. Go to frame 150 in the timeline.
  7. Set the Animation Path Evaluation time to 50. Add a keyframe to that value.
  8. Go to frame 1 in the timeline.
  9. Select the camera and add a Follow Path constraint. Set your curve as the Target value.
  10. At this point you can move the camera manually to place it at the start position of the curve and rotate it however you want. Pressing Alt-G at this point should also place it at the start. Do not try moving the camera while looking through it!
  11. If you want the camera to always face forward along the curve and turn with it, adjust the camera’s rotation to face the proper direction and then toggle the Follow Curve checkbox in the Follow Path constraint panel.
  12. If everything was done cleanly, you should be ready to run your animation. If you still have problems with the camera’s position, you probably just need to choose a different Forward orientation in the Follow Path constraint panel. The default is +y.

I hope this helps. Have fun!!!

thanks - still reading!

thanks - tried it - did not work.
“Pressing Alt-G at this point should also place it at the start” put ithe camera far away.
see attached.
camera was not at the end til i moved it there and then it just went everywhere but on the track.
thanks anyway for trying


slideshow2017–8.blend (1.5 MB)

I’ll look at the file and get back to you.