Eevee screen space reflections have black lines

so I’m using the latest build of blender 2.80 and working on a random fluid project but i kept having this issue with the screen space reflections having black lines

i tried playing around with screen space reflections settings, i tried using more samples and higher resolution and still black lines, can someone help please

Interesting. It’s especially visible at certain image scalings done by Chrome, for example:


I would use the Help->Report a Bug menu option (which nicely fills out your version and OS/graphics information now so it’s really easy) and submit your .blend file with textures packed (File->External Data->Pack all into .blend) and see what the devs say.

Or you can post the .blend here if you want more opinions.

P.S. Do you by any chance have two video cards? And what OS are you using?

Yeah i have 2 video cards, i tried using the cpu only and the lines are still there, the only way to get rid of the lines is to change the camera position to be more leveled with the horizon

Or is that not related to the bias setting for contact shadows? I thought I’ve seen someone writing about it here on blenderartists. Or is that another problem that looks like it?

it goes away when i turn off screen space reflections so it must be that right?

here’s a video with the issue

I only asked about the two video cards because Eevee only runs on GPUs so there’s no way to set it to CPU-only (unless you switched to Cycles and saw the same artifacts in which case it’s definitely your scene setup) is that I think it’s possible to have your OpenGL running on more than one card at once so there may be some chance that the two cards could calculate things differently.

It’s probably totally unrelated to this, but for fun if this is Windows, can you right-click on the Blender.exe program and see if you have a “Render OpenGL on…” menu option or similar? If you do, try asking it to render OpenGL on a single specific card.

Can’t i choose to render one a single card from the settings? I have 2 cards but never use the other card for rendering, i have it set up so it uses one card for display and one for rendering, never both

Seems another problem then. I thought you meant like this: Spot
I can’t see it in the video what stripes you have (compression probably), but if you have stripes like this here, I am able to get rid of them when giving a higher value for bias in the contact shadows of a light (spotlamp maybe most visible).

like this

you have less compression if you click on the video link instead of the embedded version, you can see a black box at the top

For Cycles it all works the way you describe, but for Eevee which is OpenGL based, none of those settings affect it at all. It depends on your system settings and hardware configuration as to whether the system uses more than one GPU for OpenGL stuff I believe.

Try going to:

x (without the ‘x’ on the front)

and then maximize it there.

Yes I’ve seen it. The stripes at the back as shown in the first picture. To me that looks like the issue with contact shadows for light. (self shadowing)
I thought like this in that case:

1 Like

Where is that setting?

Nvm, I’m using an hdri

Looks like it’s a Light setting:

You select a lamp (light, point, spot, area). In the properties panel, go to the tab for your light and there are settings for shadow. You will find there settings for contact shadow. One of them is bias.

I’m using an hdri unfortunately

Ahw, I gave up using HDRI’s in EEVEE. That was such a disaster. Since I use lights only I don’t have light leak (if they call it that way, reflections which are not supposed to be there). But that is another problem.

In that case I don’t know why you got those stripes.

1 Like