Eevee viewport and render result look very different

Final Render:

Screen grab of viewport:

This kind of thing happens a fair bit but this is one of the most extreme examples I’ve seen. It’s like there’s little to no bounced light or something. I googled around and saw a few people with similar issues but most of the time it was not a lighting issue and was because something was hidden from the render.

Hmmm… Do you have any hidden light ,or disabled lights in the collection outliner?? If not, maybe color management could have something to do with this… Not sure if Eevee in the viewport is color managed or not.

it’s hard to tell from here, I don’t think it’s a colormanagement issue , the lighting look too different.
I would have tried to get rid of all objects and bring them back one by one to narrow down the issue.
Small differences can hapend from time to time but here it looks too different.

Yes, it looks like a source of light is missing.
But in outliner, nothing seems to be different.

I see one possibility. We have ability to use LookDev HDRIs in rendered view, now.
If scene world is a uniform grey without sun in it but viewport uses an hdri with a sun ; that could explain why in one case , there are reflections and nothing in the other case.
Volumetrics and Bloom are emphasizing those reflections. That could explain why their absence is resulting in a lot darker scene.

I would suggest to verify that Scene World option is enabled in Viewport Shading popover.

Afraid it’s none of those, the issue is too severe. It’s like there’s no GI or reflections in the final render.

The only thing that may make this scene unusual is that it’s fairly large in scale, but I just applied the scale and that didn’t change anything. Just tried a few other settings like unchecking half res trace and checking high bit depth. Not even a slight change.

only other thought is that I’m using 4k textures and maybe it’s not using them for the final render coz it only wants to use 2k?

any more thoughts? I had to abandon Blender altogether and use Cinema 4D. Doesn’t bode well for my future relationship with Blender (for me Eevee = Blender coz cycles is just too darn slow) if I can’t render anything.

Applying the scale (using the apply scale operator) does nothing as far as the true scale of the scene is concerned. It only resets the scale used as a reference point for things like modifiers and editmode tools.

If you scaled the default cube from 2x2x2 Blender units to 100x100x100 Blender units, and you used the operator, it is still 100x100x100 Blender units in size from the perspective of the render engine. You need to actually scale down the objects to a more realistic size if you want to maximize the accuracy of your renders.

I scaled down the whole scene together and I think it affected the way the lights work, but still very different.

I think this problem is beyond us. Might have to report it as some kind of bug.

Care to share a minimalistic scene with that lighting that still shows the error? I’m not into Eevee myself, but others may be able to help if they had something.

For instance, post a blend-file …

Or if the file is locked by an NDA agreement, see if you can reproduce this in a simple scene and post a bug report.

well I think I figured it out. I was rendering the ‘view’ and not rendering the image. So view > viewport render image. Which is odd because up until now, that’s what I’ve been using to render! and why would it look so different to the F12 render?

Viewport render uses much fewer samples than a full F12 render (by default). If you had soft shadows enabled, that might explain the change. It still looks more different than it should, though…

Hello, although this is a cycles render, I have a problem where the rendered animation is different from the actual animation in the 3D view. The floor is invisible but should still act as a collision object. I can render single frames and they match, but not animations. Does anyone have any ideas? Spark explosion.blend (832.9 KB) I must be slow

I’m having the same problem.

Viewport looks great. dynamic paint slowly coats surface.

Animation render in eevee and cycles doesn’t show effects of dynamic paint: canvas is same color start to finish.

Individual frames render accurately sometimes.

Ok I got it , I was in a similar kind of situation where it was showing no light or almost nil in place of view port lighting. All I did was deleted all lights ( hdri has nothing to do with it) and relit it and boom , everything is perfect again!!

I just had a weird thing: Eevee render was looking totally wrong. Applied the modifiers. them it looks correct.

Eevee needs some work. The default Eevee render should look exactly the same as the viewport (presuming you have the same sample setting for viewport and render).

Normally we set up stuff in the viewport to look how we want it to look, so it should just render each frame exactly as it looks in the viewport.

i had the same bug, my solution was to render from viewport and then screenshot. but i guess it is not a proper answer for larger scenes. always happens when i make food in cycles… like a cake and a doughnut. thats weird.

Throughout this long-running thread, I have always wished: "post Blend-files!" (Along with the exact Blender version-number from the “About” screen.) Without that, everything that anyone’s saying is just hypothetical. (It’s also very beneficial if you can make a “minimal” file that clearly illustrates the problem and nothing else.)