Feather a cast shadow surface

Hello Blender Guru Artists,

I am facing a problem and need your expertise. I am using a plane right below my 3D model as a shadow catcher using the Cycles rendering engine.

The plane is casting the shadow perfectly but as you can see on the attached screenshot the plane edges while casting the shadow is too hard. Is there a way to soften the edges? I guess I can not really use transparency on the material since I enabled the Shadow Catcher for the plane under visibility> Object properties.

I have enabled transparency under films > Render Settings.

Thank you in advance.

I think a simple subdivision surface on the plane should do it :slightly_smiling_face:

Thanks a lot Kazrarr for your response, I am a newbie on blender and I am not sure how I could achieve it with Subdivision surface. Could you please explain the steps in detail or if it is too much send me a link to review it in detail?

Once again thanks.

I think I miss communicated the problem. I like the shadow end before reaching the edge of the plane like feather effect.

1 Like

hello again, first : I’m sorry for the misunderstanding, :sweat_smile: It was part me too, Now I get the problem : you want some kind of gradient/ramp between transparent shadow and hard shadow following your circle right ?

Second, I’m sorry to disappoint you, :sweat: but I’m not an expert in this subject, so I hope you’ll find someone to answer you :wink:

have a great day :slightly_smiling_face:

1 Like

What you need is a gradient transparent shader on the plane? But i am not sure if it works with the shadow catcher. I quickly test it and will come back with results.

1 Like

Seems not to be that easy. Dont know why the shadow catcher is not tasking the transparent mask into account. Maybe a bug?

My setup just limits the area but also not with a soft shadow…

I summon a node expert.

EDIT: i searched a bit and found the same node setup here.

but it works there so, still not sure if its a bug now…

1 Like

Thanks for your effort 3DArtGuy. I also posted the problem on blender.stackexchange.com and someone responded with a different node setup. Unfortunately I fail to find the “Distance” node and add it to the the setup. can you replicate the solution and perhaps explain why the “Distance” node is not showing up on my Blender but the other solution has it? Ia it because of my blender version 2.92 ?
I have the same issue for adding the “Power” node using the link you shared. When I search for “Power” or “Distance” node after hitting shit + A on the node setup nothing shows up. :((

Thanks for your patience and bearing with my newbie blender level.

How are you illuminating this. Can you not increase the radius of the lightsource?

Had a similar setup too but with the same problem…

When you cant find the node its an option of another node. The power node is a math node with a different option.

Distance is a mode of the vector math node.
So i learned something today too. Thats nice

not sure of what light source you use but if point or projector, i once notice that the size of the light emitter ( in the light tab of … well lemme do a thing… )

spot with a 0 radius

now spot with a 1m radius:

it’s the same for spots:

and sun…

Happy blending !

Thanks for your responses @pitibonom & @moony . The problem is something else. I like to have a defined plane as a shadow catcher (view the post image) and like to have the shadow ramped to transparent before reaching the edge of the plane. I like to achieve like what 3DArtGuy have shared in the post but unfortunately, it doesn’t work.

Maybe reviewing the problem here will give you an insight.

It finally worked :slight_smile: , solution by Gordon Brinkmann

2 Likes

oh okay, i didn’t catch the thing…

Yes this solution si simply the best :slight_smile:

Good luck for your renders and happy blending :slight_smile: