Flatten brush is really bad on Blender 2.83

The flatten brush is really bad, because it’s more like some sort of planar brush instead, even not doing real planar as it creates volume on sides of brushe radius.

As you can see on picture the original model, then trying to flatten does not do real flatten , and a working flatten brush on sculptris that flatten as you continue flattening and not trying to make some planar surface.
( try free Sculptris tool to understand what is a working flatten brush ).

Zbrush flatten brush

In the brush advanced panel, check Original Normal and Original plane. You can try that on the scrape/peak brush too.

I tried both, “original normal” is best but it has the same issue as “origial plane”, both create volume around brush radius instead of flattening volume directly.

This is “original normal” in Blender and sculptris

I guess most users of Zbrush or 3D coat never used Blender sculpting so much to not point such issue since there is a flatten brush.

The “scrap” brush with “original normal” seem to be the the one that is the nearest a “flatten” brush, but not as good as sculptris “flatten” brush as it can produce curvy down volumes.

Some adjustments to make Blender “flatten” brush a real “flatten” brush without those volume issues would be needed.

3 Likes

I guess no one is using Blender sculpting very deep or more extensively to not care with actual Blender flatten brushes issues and instead considering those as good.
One more reason to stay with Zbrush.

According to Pablo, Flatten brush in Blender is tweaked to behave similarly to Trim Dynamic in zbrush. I think the problem is you expect Blender tools to behave 1:1 to other apps, which probably won’t happen without quite some tweaking.

I think is better to try to reach Pablo on irc or in Blenderdev, and explain the problem. I think he’s aware of this, but it seems he considers this low priority, since it seems hard-surface sculpting never were considered in Blender sculpting base by any of the original sculpt devs, and implementing it to result in 1:1 compatibility with other softwares is not a goal of devs. Never was.

You got confused with the name of the brush? Its called flatten brush, but its misleading. It scales geometry towards sculpt plane.

If you use on smaller shapes it decreases (or increase) relief shapes contrast if you paint over. Acting like a contrast brush.

Tweaking plane offset, you get kind of push/pull brush. If you combine it with autosmooth, you can balance out mesh shrinking during smoothing.

Try “Scrape/Peaks” brush and check “Original Normal” and “Accumulate”.

And a advice to you: If you change your program, then you must change your habits.

And if you want totally flat surfaces, then check “Original Plane” and set “Normal Radius = 2.0”.

4 Likes

I guess it’s more “i must change brushes”.

I think Blender “scrape” brush could have been named “flatten” as it is what it is doing, but i just need to look how they work and not rely on the brush name only.

Scrape brush scrapes surfaces. Flatten brush flattens surfaces. In real world, if you want create effects like this, you must scrapes or cuts surface, not flatten.

You can create your own brushes.

The Flatten brush is pretty pointless overall. The Scrape brushes do pretty much everything you need from these types of brushes, which is why I never use the Flatten brush (it doesn’t even have the Invert to Fill option to make the alternate brush function work well). I have several settings that are close enough at replicating some of the standard ZBrush brushes in this area using only the Scrape brush.

Excatly, i don’t understand a lot this brush usage, as it’s not even making flat on center. It should be revisited or changed, i guess no one uses it.

The flatten brush before 2.80 is awesome, i used it so much, was my main brush, now i cant do anything inside blender im totally stuck cause they removed my brush :frowning:

Pablo added general settings to all brushes and changed defaults.
But Flatten brush was not removed. It is still there.

It behaves differently because settings are different.
But if you set normal radius to 1, enable Accumulate option and change FallOff from Smooth to Custom : you should obtain a similar behavior as in 2.79.