Frustrating Animation Problem. Help!

Hi, the problem I’m having is with animating a simple moving cube. I followed Andrew Price’s tutorial, this one: When I load my image sequence into Video Editing and I move the green bar over the sequence all there is, is a white screen showing no frames, it’s all white! I’ve looked at other tutorials and done this multiple times but I can’t figure out what the problem is.

This is what I’m doing:

  1. I insert a key frame, aka press the red button to record the movements. And put the file format to PNG.

  2. Move the object and it gets key framed.

  3. Make a file in which all the rendered frames go into.

  4. Press Animation, and then press stop render when it goes over the frames which are empty. When I check the folder it’s full of frames.

  5. Go into Video Editing, add the sequence and BAM! White screen! What the hell am I doing wrong??


Are the individual frames rendered correctly or is it a folder full of white images?

The frames in the folder are perfectly fine.

Are you rendering in the same file as you are animating?
Open a new blender file and change the layout to “Video Editing” and perform step 5 as you say

Yup it’s the same file. Another thing that happens when I play the white “image” stripe through Video Editing is a red sign saying, “Anim Player” comes up. What could this mean?

I’ve done everything ok I guess, could there be some problem with the software?

Nothing is wrong with the software – I just made a 15,000 frame animation the other day.

Which video encoder did you try-- sometimes the encoders are buggy depending on your system

Like I said open a new file and switch to Video Editing, then add the image strip and render to h.264

Ok, I went to Video Editing, loaded the image stripe which is still white, went back into default view, changed the Output to H.264, and rendered it, it made a video file of it but when I try to play it in Windows Media Player this comes up: “Windows Media Player cannot play the file. The Player might not support the file type or a required codec might not be installed on your computer.” I’ve tried different movie formats but still no luck.What do you mean by “video encoder?” Do you mean the “Codec” under the Encoding option?

The main thing I’m hung up about is when I load the image strip into the Video Editor why is it white? I think along the way I’ve forgotten to press one tiny, tiny button which makes a HUGE difference.

I’m new to Blender; just start a week ago.

With the image sequence I just move it to the left bar where it says, “1, 2, 3, 4,” vertically, is it supposed to “click” there to join? Because for me nothing happens I just move it there.

Has anyone got this problem before??

Post your blend file

Ok here is the blender file. Cube Animation.blend (404 KB)

OK, I changed the output folder to a temp file on my machine, then rendered 20 stills. No problem. I added them to the squence editor and they produced a nice purple strip. When I drag the green line across the strip, the cube starts dancing around the 3D viewport, as expected.

When you say: “BAM! White Screen!” what exactly are you talking about?

When I go into Video Editing and add the image strip and scroll over it with the green bar, it just shows white frames.

Look at this as if you were using two different programs to accomplish your goal. When you have “sequence” selected in the “post processing” properties of the “render” items, you are telling Blender to render from the “video sequence editor” window, not the camera in the 3d view. It is not telling Blender to create a “sequence” of files. Blender does that automatically when there is more then one frame in the render and a non movie file type is selected.

First make sure that “sequence” is disabled when you do the scene render, this will allow Blender to render from the camera view to your file(s).

After the render, enable “sequence”, import your image files ( “a” to select all in the file browser ) as an image strip, and do whatever in the video editor. When your done editing Blender will render the result from the Video editor.

I did this with your file and it worked as expected.

Hummm… interesting… still the same result. Here’s what I did, I started all over …

1)Went into Post Processing and unchecked “Sequencer”

2)Key framed movements

3)Rendered the movements

4)Turned Sequencer on after render

  1. go into Video Editing and load the images

  2. still they’re white

I might have misinterpreted one of your steps, let me know.


Also, many thanks to you guys helping me through this Blender crap!

can you post a screenshot of ‘still they’re white’? I am having a hard time understanding what the problem is. I don’t see any white things when i use your blend file

Here are some screenshots:

Your current path to the rendered image file is C:/Users/Raza/Desktop/Cube Animation// - (Note the // at the end.)

Try clicking the “change data/files” in the properties for the clip and re-load the image. It all works fine here.

BTW… this isn’t “Blender crap” - this is an issue that you alone seem to be having, getting your file path correct should solve it.
Now if Blender is creating a bad file path when loading the image sequence, and does so consistently… please report this as a bug. Currently this does not seem to be an issue for SVN builds on Linux, but I’m not currently able to test on other OS’s

I am not having any problems like this with Blender 2.68a on a Windows XP box.