Giant white block artifact in eevee render

I’m getting these giant white squares in my render for some reason. It shows up completely randomly and if I re render the frame there’s a 90 percent chance it’ll go away. Before the glare nodes it’s just plane white squares.

I’ve tried everything I can think of. Reducing and increasing the samples, raising the shadow light threshold, moving the camera and adjusting the lights. Nothing works.

I’m using blender 2.91 eevee and I have an rtx 2060.

maybe the same as this (if the same, seams like volumetric scatter)…

Interesting. There’s no volume inside the room but the clouds outside the windows are volumetric. Some people said it could be because of bloom too, maybe bloom interacting with the volumes? Also might be connected to rtx 20 graphics cards.

I updated my gpu drivers, changed the volume pixel size and disabled bloom. I’ll see if that works.

Humm… didnt think to try that, curious if it helps. Good luck.

It worked! Not sure if it was the volume pixel size or the bloom. I’ll turn the pixel size back down and see if it still works.

Edit: after some more experimenting, it’s definitely the volume tile size. I changed it back to two pixels and the artifacts came back, but if I set it to four pixels they go away.

Thanks for the update. Gonna have to give it a shot.