What are these "Light flashes" in Eevee .mov render

What / why are there these yellow, blue, pink and green “light flashs”, which are not in the scene.
The following video example was cut from the original video (which was longer).

Original was rendered with Eevee at a sample rate of 512 with a total of 1735 frames and 1080 resolution, Bloom is turned on and there is also a cube which the scene sits in and being used as a volumetric scatter shader.

Ive tried rendering with Blender 2.83 and 2.9 same results.
If i cut the timeline to 1-650 frames (which is was you seen in the example) they are not there.
If i render in Cycles (can’t remember if it was CUDA or OpitX, probably OpitX) (at a mush lower sample, think 64) they are not there.

Any direction would be great, thanks.

Specs on the computer.

  • Windows 10
  • i9-9900K
  • ZOTAC GAMING GeForce RTX 2070 (tried two drivers, both Studio, one from acouple months ago R450 something and just tried the latest from a week or two ago)
  • 64GB of ram
  • SSD drive

Although not solved there, this seems to be the same issue as encountered in this thread: Light Artifact In Eevee

There seems to be a trend of 20X0 RTX cards involved. That might be the common thread. Hope this helps!

1 Like

Thanks… any info is something :slight_smile:
When rendering the scene/animation for the full 1735 frames the issue is there, but then taking the timeline and chopping it to only 1-650 (or 400) and playing the same portion (this is happening right at the beginning of the animation) the issue does not appear. Noticed that the person in the other thread said the issue was happening at HD res but not 720 (which i didnt try, but edit main post to reflect im rendering at 1080) seams odd, same with my chopping my timeline.

I have these light artifacts with boom aktivated, eevee produces small pixel faults.
I don’t think it is gpu related

Next render (do them while sleeping and at work, take around 10-15 hours) will try with bloom off.

Yeah I am still experiancing the issue, here is another video I have been working on, just have not had the time to properly test and submit a ticket. But experiance the same problem, each render will result in different flash points. My work around for now is to render out frames and combine them in preimer pro, then just re-render the individual frames with issues.

I think the world volume node is causing the issue, but not 100% sure yet.

Turned off Bloom and to make up for it added a Glare node in the compositor, gonna start rendering in an hour or two, then it will take around 12 hours after that… will post back results.

1 Like

did some testing, in my case it could be depth of field related:
with different f-stop numbers i get different results, problem starts under f-stop 1.5

Can you get consistent results, with flash and with out ? Mine seams to be sporadic, but always somewhere.

i had a flash in an huge animationfile with maybe some strange settings, so i try to find out what i did wrong. For composting i need a mix shader with diffuse and Holdout, this produces a render flash in every frame (depending of the f-stop and bloom)

more tests, here is a very simple file that works in 2.83 but not in 2.90 and 2.91.
f-stop 2,0 produces a white spot, f-stop 2,1 works, bloom on.
It’s a special case because of the mix shader.
PixelFehler.blend (3.1 MB)

Win10, rtx 2070 super

I have raised a bug ticket here


1 Like

@MyVisualStory thanks for creating a ticket. See there was another which was only a few months old, but no activity. Once i find a consistency with this, ill try and slim down my scene and send it to them also.

Rendered with-out bloom but using the Glare node in the compositor, the “flashes” are now white artifacts (no color, just square white artifacts). There are less, but i also did other changes with the lamps and volumetric settings (for other reasons not related to the flashs) and also rendered this one at 384 samples.

Threw out the project ive never used any DOF for any cameras (two camers in scene)…

Maybe the next render will give a shot at disabling the volumetric cube.

Do have to say, glad for trying the Glare node in-place of Bloom, works much better for camera movement.

One “flash” right at beginning (just after hitting play) and a second around the 8 second marker.

Just an update…
Did another render last night, with-out bloom (but used Glare Node) and with-out volumetric scatter shader cube and no flashes. So for my case, it looks like (as some others said) its the volumetric scatter.

Thanks for the work around @MyVisualStory with editing later, plan on bring my animations into Davinci Resolve anyway so not too big a deal.

1 Like

No worries, yeah deffinatly the volume scatter causing the issue. Though I need to test using a cube with a volume shader to emulate a world volume shader and see if it is an issue with volume shaders or just the world volume shader

Gonna guess its volume shaders, i was using a cube and after dropping it from the render the flashes where gone.

for my special case, pixelartifacts in every frame, i created a bug report:

Some where along the lines someone brought up render resolution. Was just playing with the same scene ive posted here, but just bumped it up to 4k (was at 1080 previous) and these white artifacts really show up now.

Anyone aware of this issue being fixed in a more recent release or the cause?

I’m using 2.90.0 and getting the same issue with both World Volume and Volumetric Object shaders using Principled Volume nodes. I’m also utilizing Environmental Texture nodes in World and have camera movements and emission shaders.

Going to test turning off different shaders that might be impacting the volume shader to behave the way it is and possibly have a solution to avoid these. I appreciate the work around from MyStory - that will work but its a long detour that I will eventually loathe taking but will take if I can’t find another way around while still keeping the volume shader intact.

If you are using RTX card apparently this is not resolved yet:

According to developer comments:

Seems to be a Nvidia driver bug caused by the volume integration shader.