Glass Goblet

Am still working on this. Need to add a plane and change the “world” settings off of the basic blue. If someone could tell me everything that is wrong with it, I will try to fix it…:yes:


something is wonky with the base i see, no subsurf?
try to render this in cycles, it will look amazingly better
but if you dont want to, you need to make this look sell plastic-y, even though te reflections/refractions seem to be fine…its the color.
Get an HDRI image in the background so your reflections show up better.
Yeah and add that plane…

I am trying to fix the base, for some reason it refuses to change into a circular shape even though it is subsurfed.

I will do some Googling on how to render in cycles.

HDRI Image = what?

I am going to use the help forum to find out how to render in cycles…

Anyone know of Cycle’s nodes tutorials as I stink at nodes? I also started a separate thread in Rendering to try to figure this out…

Great one! I like your work! While the bottom of this glass seems weird! Seems blank!


hdri pack for download… there is 2 more below in the site
and even more in the web in general just google…

to download cycles go to and get your build and just start playing around and you will get the hang of it.

Have gotten the base corrected by jumping the subsurf render levels. I am now using 4 regular levels and 6 render levels. Thankfully, my computer seems to be handling it fairly well. I am working on adding a glass plane underneath it. A colored one seems to mess up my goblet by bleeding color up into it…

Well, just as a little test I decided to investigate for you!

Subsurf 2 worked fine for me. 6 seems kinda high…
Turn off spec. Trust me it improves the image tenfold. Gets rid of that plastic look that nearly all Blender renders carry on their shoulders.

Make a sun lamp and turn on “Sky” under the lamp settings. Makes a great backdrop for everything and can look awesome with some of the settings in there. (recently I saw a really nice setting for outer space. Really cool.)

Turn IOR on the glass to approx. 1.54. That is about what glass is in real life.

Make that plane! And give it a texture too. Just a basic wooden table texture off should do fine.

Glad to be of service.

Oh BTW this is what mine looked like after just changing those settings. Mind you I made the goblet itself in like 2 seconds. Really just to show the effects of good settings.

PS: Ignore the plane texture. I really love using magic…

Here is the glass with spec turned off… I am working on the lighting and sky background right now. As I uploaded it, I just noticed my base went wonky again, I will try to fix that as well.

Got the base fixed, working on the background, will post another image as soon as I have that done.

I am assuming from my efforts that you have used multiple sun lamps in the background?

No, didn’t need to!

Blender 2.5 (and I thought 2.49b, but it has been literally a year since I touched there…) has a great little feature called “Sky” under the settings on your average Sun lamp.

You can adjust these however you would like. Best used in conjunction with a hemi lamp to create the colour that the sky in the preview is making, and have it really soft over the scene. Makes it look more plausible.

Thanks, I am slowly getting their thanks to this page…

Edit: I am attempting to set the settings in 2.49b to almost exactly what yours were. I would do it in 2.57, but I killed my install when I installed the cycles build. Plus, I haven’t really played with it at all, as almost all tutorials are done in 2.4x.

Do I need to make my hemi lamp colored?

edit: Nevermind, coloring the hemi made it look interesting, so I will probably do it anyway…

If it weren’t for the weird background this would look better.

If where you I would redownload 2.57 and just put it somewhere else to Cycles. 2.49b is old as the hills and along with that is much mroe innefficient and slow (especially raytracing, that got an absolutely HUGE upgrade in 2.57) and it will put you in the same version as everyone else. Making it a lot easier to help you out.

The hemi lamp simply has to be coloured to a general light blue type colour, matched as best you can to the colour of the sky.

Am doing that right now…

Edit: 2.49 uninstalled, 2.57b installed, redoing settings for sun lamp

I switched to 2.57 and changed all the settings exactly, but am not getting a sky at all. I have attached both the settings and the rendered result. I have a hemi behind the goblet as well as the sun, just like you said…:confused::frowning: Sorry, the images came out rather small in this post, you’ll have to click and enlarge them to view.

Thanks wefyb for your help to conquer my stupidity!:yes::smiley:

I have blender 2.49 installed then i have 2.7 and cycles on my desctop lol i am prepared for any .blend any1 sends my way :stuck_out_tongue:

hey [email protected] plz change the background the blue is killing me lol.
Btw it should not be blue i belive with sky turned on…try to open 2.57 and import the goblet from the 2.49 file and go from there.

Does the first sentence mean you want the .blend? I don’t think it’s that great, but if you want it I can send it.

I will change the world settings and post a new image. I am still trying to figure out the sky.

No i dont need it, i was just describing how my versions of blender are set up. :slight_smile: