Google Maps Models Importer

I got now working checking …

Yep of course! That wasn’t my suggestion. It’s just that I remember have ripped games like Mafia or Call of Duty 2 once, to see how the level and assets were designed, just for curiosity. Anyhow, 3D from GPU buffer is not usable as it is so even for a thief I suppose it’s not a convenient tool.

I get this error message when I import the rdc file:

Traceback (most recent call last):
  File "/home/user/.config/blender/2.80/scripts/addons/MapsModelsImporter/operators.py", line 53, in execute
    importCapture(context, self.filepath, self.max_blocks, pref)
  File "/home/user/.config/blender/2.80/scripts/addons/MapsModelsImporter/google_maps.py", line 177, in importCapture
    captureToFiles(filepath, prefix)
  File "/home/user/.config/blender/2.80/scripts/addons/MapsModelsImporter/google_maps.py", line 41, in captureToFiles
    subprocess.run([python, SCRIPT_PATH, filepath, prefix])
  File "/media/@Blender 2.8/blender-2.80-b936d7b16c62-linux-glibc224-x86_64/2.80/python/lib/python3.7/subprocess.py", line 453, in run
    with Popen(*popenargs, **kwargs) as process:
  File "/media/@Blender 2.8/blender-2.80-b936d7b16c62-linux-glibc224-x86_64/2.80/python/lib/python3.7/subprocess.py", line 756, in __init__
    restore_signals, start_new_session)
  File "/media/@Blender 2.8/blender-2.80-b936d7b16c62-linux-glibc224-x86_64/2.80/python/lib/python3.7/subprocess.py", line 1499, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: '/media/@Blender 2.8/blender-2.80-b936d7b16c62-linux-glibc224-x86_64/2.80/python/bin/python': '/media/@Blender 2.8/blender-2.80-b936d7b16c62-linux-glibc224-x86_64/2.80/python/bin/python'

location: <unknown location>:-1

Mmh the plugin expects a python interpreter to be distributed with Blender in 2.80/python/bin. It seems that it is not the case of your build. Maybe it is somewhere else? It is surprising that they distribute it under windows and not under linux.

The RenderDoc module cannot run with an embbedded Python, so I need this standalone interpreter.

And now that I am thinking about it, you will bump into another issue. I had to build the python RenderDoc dll by myself because it is not provided in the official build: https://github.com/eliemichel/MapsModelsImporter/tree/master/blender/MapsModelsImporter/bin/linux64

There is only one file called: python3.7m
I am testing with official Blender tar.bz2 file.

Just downloaded and tested, works without issues on my win10 machine :slight_smile:
Got one question though…will it be possible in the future to grab several captures instead of just one, and have them automatically stitched together to cover larger areas? Well of course it is possible to take N captures in renderDoc, but it will deliver separate models from what i understand?..
And thanks for this great addon!

@irSindaco The addon tries to match the scales. There may be differences, but by an integer scale. I could not find for the location, though, so you’ll have to move it manually.

The way it matches the scales is by storing a transformation matrix visible in the scene properties tab the first time it loads a capture, so for the matching to operate, you must load the captures within the same blender scene.

@YAFU I’ll have a look at this but anyway since I did not build binaries for linux it is not going to work as is. Since the code was originally designed to be executed half in RenderDoc, half in Blender, you may try to execute stuff from google_maps_rd.py in RenderDoc Python interpreter, to generate the folder with textures and .bin files continaing geometry, then import this in Blender using the remaining of the addon. But I guess that this will require some editing of the code. Your best bet at the moment is to hand on some windows machine. :confused:

1 Like

Now having problem installing your addon in Blender. I can see it in the folder where all user installed addons are, but i cannot see it in Blender. I m using Blender latest version today’s builder.blender.org I tried other addons they worked fine.

I also had trouble installing it, but manual installation worked, ie. copy files from the zip to the blender addons directory. The addon is then normally visible in addons and can be enabled.

1 Like

The problem was the path to the folder, i did what @cdog suggested and i copied only MapsModelsImporter-master not the one before blender/MapsModelsImporter-master and it worked.

Hi, I’m on Mac and I installed RenderDoc for macOS and Chrome, how can I introduce the flags in Chrome for macOS?

hi @Mink,

works well, thanks for the addon, here you have some screenshots.

2 Likes

@erickBlender @cdog Did you download the zip through the Release page or using the green “Clone or Download” button? The former is supported, not the latter.

@Oxer you can run chrome from a terminal to add the flags. But you will have trouble using the addon then because I did not provide the extra RenderDoc binaries for MacOS. :confused:

@sanask Thanks for the feedback :slight_smile:

1 Like

“Clone or Download”

thanks for the video ! great add-on, thanks a lot ! i really hope this method will not be counter by google somehow

Hi, the addon seems like magic, I’ve watch the video and read the article, and I’m totally excited.
Yet I’m stuck because chrome gives me an error on startup saying that the sandbox flag is unavailable since is a security risk.
I’ve tried everything to bypass it, even installed chromiun and old versions of each, yet I can not pass it so I don’t get the overlay and can not capture the frame.
¿Any ideas on what I could do?
Thanks and great job

Hi @kubo, you’re not the only one to bump into this issue from what I’ve heard. How is the error displayed?
My Chrome shows a warning about the sandbox flag, but it does not prevent the process from working:

(I could not turn my Chrome to English, for some reason, but it says “You are using an unsupported flag: --disable-gpu-sandbox. Stability and security will be affected”)

@Mink
My warning goes beyond yours, it reads something like (freely translated)
The command line flag used is not allowed (–disable-gpu-sandbox) since it affects security and stability
I’m on Windows 10, and chrome 73.0.3683.86, also I’ve tried the latest chromium and the the 60 and 50 to no avail.
I’ve tried launching with and without the flag, and nothing seems to work

1 Like

Same version of Windows and Chrome here, so the difference must be related to some security settings and/or hardware.
Maybe try to add the flag --allow-no-sandbox-job
More generally, try to explore chrome://flags/ to see if something could help. Maybe site-isolation-trial-opt-out also.
Regarding hardware, you can have a look at chrome://gpu/ to check that webgl is hardware accelerated.

Ok, I’ve tried all your suggestions, I’ve added the allow-no-sandbox-job flag, I’ve check and enable a whole lot fo flags, one by one, in particular disabled the site-isolation one but no luck
I’ve tested in two other computer, a surface pro 3 and an A10 APU none of them share the same hardware, yet I got exactly the same error on all of them. My PC might have more custom settings, but the other two are as vanillas as you can get.
Just in case I’ve got a 780 and a 1070 Nvidias on the main PC, being the 780 de display one and I’ve tried updating the drivers, but no change there either.
So any other ideas?
Thanks a lot, btw
on the chrome/gpu I get webgl “Hardware accelerated but at reduced performance”