Hard Ops Thread

(2.8)BoxCutter 717_18g
Grid has now been resolved in 2.93 for releases post March 9th.

2 Likes

I’m on win 10 and 2.93.0

Amazing everything is working perfectly thanks for the great support!

How to turn off the Emission Material pulsing?
Hops Doc “Emission will add a pulsing material similar to tutorials on scripted expressions in the past.”
I’m interested in learning more about scripted expressions but only in the context of using it for Hard Ops, which tutorial would have that info?


remove whatever is connected to strength and its good to go.

3 Likes

thank you! I’m finishing the first video, guessing “Cycle” was changed to “Strength” but it is the pulsing function? Look forward to better understanding how these are setup.
In the material, “value” list, “Floor” is the default but after playing with different value types, It’s not in the list and want to change it back to the default pulse settings.

Can somebody please advise me on how to reactivate, or recall an inset cutter and make an edit to it? :pleading_face:

I did not press shift during the initial draw of the inset cutter, and for some reason, even though it has not been applied, I cannot get access to it in any fashion. :thinking: I have spent the last three hours reading this thread, and checking the docs. :thinking: I have found nothing which seems to solve this. :woozy_face: It’s highly possible I may be misunderstanding something.
At this point, I am beginning to wonder if I may not even be speaking the same language as ryuu, josh and masterxeon, as I haven’t understood how to recall / reactivate cutters after they have been drawn, even though I have seen josh and ryuu both do this in their tutorial vids. :woozy_face:

recalling cutters

about inset

I guess what I’m asking is how do I DO anything with the cutter once I find it. :worried: I have been trying all day, and getting nowhere. :woozy_face:
Right now, I’m trying again with a new file and completely different mesh.

Just hit tab and edit it. The cutter isn’t special, it’s just another mesh in Blender.

1 Like

That’s what I expected, and how I thought it was supposed to work. It has not been working that way. Instead, when I try to tab into edit mode, I get the original unmodified base mesh, as if there never had been a Boolean. This has happened with three booleans, and very simple geometry.

For some reason there was also an extra copy of one cutter (nothing associated with inset, interestingly.) left after smart apply.

That cutter copy was not applied when I smart applied everything, so I had to just delete it, and after that worked the mesh the old way. I am mystified by this technological terror you’ve created. :wink:

This is a really complex suite of tools, with a lot of options, many of them context driven. The tutorials are comprehensive and in depth, but also sometimes very confusing, :exploding_head: especially when even with screencast keys turned on, things go by so quickly it’s difficult to follow. :woozy_face:

I really do want to get good enough with this suite of tools to speed up my workflow, and I know that it takes time to get up to speed on something this complex, but I’m beginning to think I should take the advice I wished I could give to people in my tech support days, which was:

“Find the packing for your computer, unplug everything, put it back in the box and take that e-machine back to wal-mart, because you’re not smart enough to use a computer.” :crazy_face:

Mainly kidding with that, but the learning curve here is kicking my elderly ass, if you’ll pardon the unladylike speech. :wink: Thanks for the assistance so far, it IS greatly appreciated, no matter how dispirited I may be. :slightly_smiling_face:

Edited and reposted because I replied to the wrong post. bad day all around…

Hi,

it’s been several Blender versions since I reported this and it’s still not fixed. HardOps/BC are only two addons and literally also only tools in Blender that do not properly categorize their operators, resulting in pollution at the top of quick search list:

Every time I open quick search, the entire top is polluted by uncategorized Hops/BC stuff:

While this is how it actually should look:

Every other addon has them properly categorized, so that they don’t create this kitchen sink of random stuff at the top:
image

And also, the console errors whenever opening the quick search are still present:

unfortunately it is beyond our control. We’ll have to see how subsequent updates of blender address the issue until a solution is found.

4 Likes

I’m facing the same issue with a the Views pie in MACHIN3tools.

Curiously, the two props I’m exposing in the pie that are causing this, are both native Blender props.
How can native Blender props be unsupported RNA types?

3 Likes

Okay, the latter perhaps, but the former - categorizing the Hops/BC commands so they do not pollute the top of the search, that should be doable, as all other addons (that I use) already do it.

#hardops 987_8 out now.

#boxcutter 718_3 out now

The ultimate bundle is also 25% off until sunday!

7 Likes