Interactive Tools for Blender 2.8

@maxiv94 The Smart Extrude keymap setup guide is outdated. I still tried to follow it but the hotkey didn’t work. Currently, it’s doing a default behavior that’s actually weird as well. It’s just scaling the mesh or sometimes translating it when I press shift+left mouse drag. This is something I really miss in Blender spending 9 years with Max. Any tips on getting this hotkey setup properly?

Currently pressing the button in the tool works but only for duplicating the mesh in object mode. Try it with any edit mode selection and it’s just moving it.

1 Like

Can You add to “Transform Mode Cycle” option to hide gizmo after scale?
Translate, Rotate, Scale, Hide…

1 Like

Also, an option to hide/unhide any of the transform gizmos at any time would be nice as well. I was actually just trying to see if I could set this as a shortcut but you would actually have to set a separate shortcut for each. Most times I use the hotkeys but sometimes I turn on the gizmo in certain cases and this would be really helpful.

2 Likes

thanks for this addon.
But I do not understand how Smart Extrude works.
Can I activate the tool, press Shift and drag it gizmo? Or I need to press a Smart Extrude button every time?

Hi.

I just wanted to report a warning message that is displayed in the console each time I launch Blender 2.8.
I am currently using blender-2.81-10001d909905-win64

Warning: ‘MaxivzTools_PT_Panel’ doesn’t have upper case alpha-numeric prefix register

I don’t know if it’s normal or not to see this message.

Awesome update! The Stick Selection is great! That’s one thing I was missing from 3DS Max. Also the new Smart Create options are cool as well :).

1 Like

@genics: Thanks for the suggestion! I have added a new tool to cylce between transform orientation, it works globally.
@xmaiter: the Edge Flow addon can already be used with the smart modify script, you need to set it up in the preferences. I will see if I can update the documentation in the following days so its clearer on how to use it.
Automatically switching into the transform tool sounds like a good idea, I will add an option for it in one of the next updates!
Im not sure I completelly understand the last suggestion, but the tool works in a similar way. Right now you can activte the tool with a hotkey, move the pivot point to the position you want and then you can press the hotkey again to apply the pivot
@Ren-San@so3Datel: Right now the Smart Extrude tool only works as a hotkey, there will be a redesign of the tool in the future that will hopefully improove the way it works right now.
To set it up you need to make a new hotkey inside the 3D View Tool: Move context and assign the hotkey there as in the image. Theres also an example on how to set up the smart transform tool.


@Pinhead: I could add an option in the settings menu in a future update.
@xan2622: Now that you mentioned it I also get the message but everything seems to work fine, I will take a look at whats causing it and try to fix it in one of the next updates
@Kickflipkid687: Glad you find it usefull!

I just released a new update with a couple of fixes and two new tools.

Changelog:

Quick Align:
-Fixed bug where quick align kept the target mesh selected after running

Quick Lattice:
- Fixed bug with quick lattice not deleting old lattice vertex groups
- Fixed bug that didn't allow the lattice to align to the mesh when the tool was run in object mode

Wire/Shaded toggle:
-Now remembers what mode was used before switching to wireframe instead of always switching between Solid and wireframe shade mode

Transform Orientation Cycle:
-Cycles between the transform orientation modes

Quick Transform Orientation:
-If a face, vert or edge is selected it will create a custom transform called “Custom”.
-If Nothing is selected it will switch to the last used standard orientation.

Download link:

Time for another update! A new tool, new context menus and some more bug fixing :slight_smile:

Hilights:

Quick Hp Lp Namer

Finds the lowest poly mesh in the selection and adds the low poly suffix to it, then proceeds to name all the high poly meshes with the low poly name adding the high poly prefix.

The prefix for the low and high poly mesh can be changed in the plugin settings.

New Context Menus

Added entries for the context Menus for Edit Mesh Mode, Object Mode, Uv Mode and Lattice

Changelog:

Transform mode cycle:

-Fixed bug where the tool wouldn’t work if using the Move, Rotate of Scale active tools

Radial Symmetry

-Option to hide Radial Symmetry pivot

Quick Lattice:

-Add Presets to lattice right click menu

-Option to apply

Quick Hp Lp Namer:

-Implemented Tool

Misc:
-Added Seams From Islands to the UV Utilities menu for easier access

-Added entries for the context Menus for Edit Mesh Mode, Object Mode, Uv Mode and Lattice

-Fixed warnings when loading the plugin

Download link:

6 Likes

I upgraded to the new version and the radial array doesn’t work as it used to.

Hi @bloox64, could you elaborate a bit on what is the problem with the tool, or how does it work different than it used to? I have added options so you can hide the pivot, you can disable them from the plugin preferences and get it back to be as it was before.
Hope that helps!

Yeah, basically the origin point doesn’t act like before

This is where the origin point gets placed.

1 Like

Thanks Maxi, haven’t checked here in a while. some really great updates. Is there any way to turn off the transform gizmo? Once you use the cycler you can’t get rid of it, it always remains the active tool. Because of the way Blender works(as I’m sure you know) is that each of the transform tools are active until you either select another tool or exit the tool. With your cycler though the gizmo remains active no matter what even if you switch to another tool? So once you use it once there’s no way to get rid of it. Sorry if this has been addressed above already. Cheers.

1 Like

@bloox64: Thanks for the report! I will take a look into it and fix it with the next update!
@Musashidan Im not using active tools for the transform cycle, but changing the object gizmos. You can deactivate it in the gizmo properties . I will add an option to enable a fourth cycle mode which deactivates all gizmos in the next update to help with it.

Cheers mate, makes sense. Sorry, I don’t know where/what the gizmo properties are. Thanks again.

No problem! You can find them in the top/bottom bar in the viewport:

1 Like

@bloox64 I pushed a fix for the issue, give it a try and let me know if you run into any issues in the future!

Doesn’t seem to be solved, I downloaded from github (Clone/download buttom)

New update is great!

Big thank you for including the context toggle for wireframe/shaded - I use it as a quick toggle to be able to select through/select backfaces on the other side of a mesh, (using shaded mode to only select what is visible to the camera) so I’m glad to see this is still possible by leaving the toggle for the new behavior off.

I believe it has something to do with coupling Xray with wireframe, but at any rate, I’m glad it has been made into an option :slight_smile: