KIT OPS 2 Now Shipping

Thanks for your response and clearing that up. I can’t wait to use KitOps Pro and make my own inserts as well. So take my money already! Haha!

Thanks for the hard work you all put in to these amazing tools.

1 Like

Hey everyone!

KIT-OPS is officially released!

You can learn more about it at
and for the next 2 weeks we’re having an introductory special. Check it out!


Yaaay, just downloaded the free kit right now! amazing job guys !:ok_hand:

Hi thanks,
But how how to change material of an insert. Tried to apply as in documentation, but still not able to assign another material/shader to an insert. Tried making local, un-parent, make real, etc. Haha, I thought I knew enough about that stuff, but it’s a puzzle for me.

Make sure you turn auto select OFF. Then you can select object and change material!

Playing with the free ver and it looks good, but currently breaks when using Tabs Interface addon.

1 Like

oh, great that works. Still curious why I couldn’t figure it out, but it’s not really necessary for now.

Update: I tried the free version first, and since the pro-version comes with 300 inserts I decide to go for it. Looks very nice the addon. What it does and not does was what I expected the addon would do. But overal above expectations. Though one need still need tools to fix normals as far as I see.

Hey @chippwalters , thanks for the great plugin.
I noticed an issue (in Regular mode): in the manual it says after we delete an INSERT that is attached to a target object, next INSERT we add will automatically clean the modifier up but it doesn’t sometimes as seen below gif.
I realized that problem occurs always on some INSERTS.


Try deleting the INSERT with the Delete Globally option enabled:

Found in the 3D View Tool Shelf and the F6 Menu.

1 Like

I just purchased the pro version of Kit Ops. I am using Linux mint 19 and some of the items doesn’t work like “smart insert”, the mouse wheel for changing the scaling. To get the cutter or any operation to work you have to press the apply button. I’m sure it has something to do with Linux but could you help me…

Hi Foremancr,

Thanks for purchasing!

Can you provide a GIF for more clear explanation? Are you sure you’re following the correct workflow? Sorry, I don’t have a Linux configuration, but @proxe does. Hopefully after you post a GIF or sequence we can help you debug.

i’ve been playing with this for the past hour and i love it…

a minor suggestion (I’m sure i’ll have more soon enough) but shift+scrollwheel should allow you to scale in smaller increments like everywhere else in blender. not a huge deal since you can scale after the fact, but it’d be nice. somewhat related- i think i found a bug with scale display- it doesn’t seem to update when you change objects, and when you go to adjust the slider the object doesn’t move in small amounts, it has an initial “jump” where it snaps to whatever scale is in the UI. Not really sure what’s going on with that

also- how do I go about hiding the cutter wireframes for these objects? it’s getting pretty messy and I’m not seeing an obvious way to quickly hide or unhide them

unchecking autoscale should allow you to scale them freely with mousewheel.


I totally didn’t even see those display icons… thanks!

It’s also in the docs as well :slight_smile:
Might want to take a quick look through.

read docs, when i have this much power at my fingertips!? okay maybe you’re right :slight_smile:

Yeah, me too. I do the same thing all the time.
Here’s a link to that particular feature:

Definitely a powerful tool. A few workflow questions as I get used to the setup:

  • What is the role of the “Kit Ops Duplicate” objects created when adding inserts? Would it be possible to have these set to non-rendered and/or hidden by default?
  • What are best practices for using this addon in conjunction with Hardops? Often the booleans from KitOps create cuts that I would normally want to CSharpen but I think the modifier stack isn’t handled (hangs Blender)
  • Can inserts be parented to the object they apply to by default?
  • Is there any workflow for assigning textures based on inserts? For instance having the main object material and an internal material which inserts expose
  1. If you select an INSERT and press SHIFT+D while in SMART mode you immediately duplicate the INSERT. From there you press G (grab) then X,Y, or Z depending on where you want to move it.
  2. You’ll need the latest Hard Ops to work with KIT OPS. I’ll let @masterxeon1001 answer that as I’m not an expert Hard Ops user. I suspect he’ll be coming out with a video about some of this soon.
  3. No. INSERTS are not parented to the object by default. You have to manually do that.
  4. KIT OPS is smart in that it already knows when you add a new INSERT if the materials for that INSERT already exist and it doesn’t create a new material. If you want to edit the material of children of INSERTS: Step 1: Uncheck the *Auto select INSERT Step 2: Select the parent of the INSERT: Step 3: SHIFT+G select children AND then you can adjust materials for all children OR select them individually.

Hope I am not polluting the thread but exited here about my first INSERT. Is was a plug for Meshmachine, and fairly easy converted to an INSERT. Ofcourse a Plug or an INSERT is different, but for knobs and buttons, flat surfaces is not really a limitation. The ridge you see here is a difference Boolean and the knob a Union Bolean. Maybe not the best example for an control-INSERT, but it works.

I am planning to make INSERTS suitable for a workflow where you can Csharp (Hardops) your base-mesh and then place INSERTS in a way that all gets a nice bevel right away. (latest workflow in Hardops). It better that the inserts a simple than that they have a bevel already in such a worklow. (Is my idea).

1 Like