Loop select not working Blender 2.8

If I use left click, shift alt left click, to select a loop a messages comes up at the bottom of the UI which says Loop Select, but when I click on the edge, face or vertice nothing happens.
If I go to user preferences and change the Select With box to right select then shift alt right click will select the loop of edges, faces or vertices.
I’m not changing the keymap to 2.7, I’m keeping it on 2.8 but just changing the mouse click to right for select.

I haven’t been able to find much info on this problem so I am not sure how common it is or if it may be something to do with my OS, which is Linux Mint 19.1

It’s not a massive problem as I still use 2.79 for modelling, but I did want to get used to using the left click select in 2.8 as that’s the way things are going. But without the ability to select a loop, 2.8 is for me rather unusable for modelling at the moment.

If anyone has any info or advice on this problem it will be gratefully received.

1 Like

Odd, I use left click select, alt+left click & shift+alt+click works on edges for selecting loops ok, I’m running windows 8.1 btw.

Thanks for confirming left click works on you system, it made me fairly sure it must be something to do with my OS rather than Blender.

Just going to add this here in case anyone else running Linux Mint has the same problem.

Click on Menu, All Applications then Windows. In the Window Preferences click on Behaviour and then change the movement key from Alt to Super. After that’s done loop select works fine in Blender 2.8 :smiley:


Thanks for posting this.

That worked just fine on my Linux Mint.

I have the same issue with macOS - no GPU.

“emulate 3-button mouse” is not turned on - using a real 3 button mouse.

“Alt+Select MB” doesn’t work for loop select. Loop cuts with Ctrl+R works

Solved! - this was because I had issues with face normals facing the right direction, making blender think it wasn’t an actual loop, while I thought it was.

Maybe it’s too late, but I’ve solved this problem with disabling “emulate 3 button mouse” (MacOS)


Thanks for that buddy.

1 Like

Windows 10. After upgrading to version 1903 (build 18362.295), the loop select stopped working. I switched to the selection with the right mouse button (thank you, caz747). But I want to return the left button again for selection (I just started getting used to it).
P. S. Solved a problem. Removed Blender. Deleted his configuration folder (C: \ Users \ User_Name \ AppData \ Roaming). Installed again. Works!

1 Like

Thanks @Clandestin,
Removing C:\Users\UserName\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend worked for me on Windows10.
No need to remove and re-install Blender!

It helped me too, but it does the 2.80 unuseable for me. I need both - 3 mouse button simulation and the loop selecting, as it’s working in 2.79. I don’t use a mouse (don’t have one for a long time), only Wacom tablet, and modeling in 2.80 is a nightmare :frowning:

thanks man…its worked in my linux mint too. :wink:

OMG thank you so much it soled the problem I just disabled emulate 3button mouse.

1 Like

Many thanks for this solution. I’ve been puzzling over this for weeks (obviously I’m a Bliender noob).

Just want to add to this, here instead of making a new post. I made a post before about CTRL +R not working to make a edge loop but having trouble finding it. anyways in the past the only thing i could do was reinstall blender and that seemed to work, which i will try next if nothing comes of this. Anyways reading through this post, I do not have 3 mouse emulator selected, and i have select with left click. I can press F3 and search and find edge loop but pressing Ctrl + R and nothing happens.
here is a blank blender file, not sure if that will be useful though.
test.blend (552.6 KB)

Ctrl+R is a shortcut in the default ‘Blender’ keymap. If you’re using a different keymap, or if you’ve somehow changed that shortcut, then it won’t work. Also, this is off-topic: this thread is about loop selection. Ctrl+R is a shortcut for loop cut.

Solve partially for me. Alt+LeftClick, works. but Alt+Shift+LefClick not.

I’m using LinuxMint 19.3. and Blender 2.81a downloaded from Blender.

Anyone got the same behavior?

ok sorry i made a mistake i see it is different. Maybe i should make a new post then? Idk, but here the solution I just found
So first i took your suggestion and checked the keymap. it was set correctly to Ctrl + R. but it would not let me type Ctrl + R in as if it didn’t recognize the keys, but was ok with ctrl + some other key, or R by itself.
i did not have any other programs open. but in the left hand screen there was epic games and steam’s icons. so I closed them and then I could enter Ctrl + R in the keymap. Incidentally I reopened them and it still worked, so it seems like some issue with other programs running that use this command.

I’m running the same LinuxMint and Blender versions as you and Alt+left click and Shift+Alt+left click works for me.
I am using the Mate desktop, not sure if it would make any difference which desktop is being used though.

Brilliant, I was almost tearing my hair out trying to do this on Linux Mint but now problem solved :slight_smile: