Loop select not working Blender 2.8

If I use left click, shift alt left click, to select a loop a messages comes up at the bottom of the UI which says Loop Select, but when I click on the edge, face or vertice nothing happens.
If I go to user preferences and change the Select With box to right select then shift alt right click will select the loop of edges, faces or vertices.
I’m not changing the keymap to 2.7, I’m keeping it on 2.8 but just changing the mouse click to right for select.

I haven’t been able to find much info on this problem so I am not sure how common it is or if it may be something to do with my OS, which is Linux Mint 19.1

It’s not a massive problem as I still use 2.79 for modelling, but I did want to get used to using the left click select in 2.8 as that’s the way things are going. But without the ability to select a loop, 2.8 is for me rather unusable for modelling at the moment.

If anyone has any info or advice on this problem it will be gratefully received.
Cheers.

Odd, I use left click select, alt+left click & shift+alt+click works on edges for selecting loops ok, I’m running windows 8.1 btw.

Thanks for confirming left click works on you system, it made me fairly sure it must be something to do with my OS rather than Blender.

Just going to add this here in case anyone else running Linux Mint has the same problem.

Click on Menu, All Applications then Windows. In the Window Preferences click on Behaviour and then change the movement key from Alt to Super. After that’s done loop select works fine in Blender 2.8 :smiley:

4 Likes

Thanks for posting this.

That worked just fine on my Linux Mint.

I have the same issue with macOS - no GPU.

“emulate 3-button mouse” is not turned on - using a real 3 button mouse.

“Alt+Select MB” doesn’t work for loop select. Loop cuts with Ctrl+R works

Solved! - this was because I had issues with face normals facing the right direction, making blender think it wasn’t an actual loop, while I thought it was.

Maybe it’s too late, but I’ve solved this problem with disabling “emulate 3 button mouse” (MacOS)

1 Like

Thanks for that buddy.

Windows 10. After upgrading to version 1903 (build 18362.295), the loop select stopped working. I switched to the selection with the right mouse button (thank you, caz747). But I want to return the left button again for selection (I just started getting used to it).
P. S. Solved a problem. Removed Blender. Deleted his configuration folder (C: \ Users \ User_Name \ AppData \ Roaming). Installed again. Works!

1 Like

Thanks @Clandestin,
Removing C:\Users\UserName\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend worked for me on Windows10.
No need to remove and re-install Blender!

It helped me too, but it does the 2.80 unuseable for me. I need both - 3 mouse button simulation and the loop selecting, as it’s working in 2.79. I don’t use a mouse (don’t have one for a long time), only Wacom tablet, and modeling in 2.80 is a nightmare :frowning:

thanks man…its worked in my linux mint too. :wink: