MACHIN3tools

Maybe it could help (or not), how blender “Transform Orientation - Normal” is calculated.
Cube with random pivot angles and messing shape.


Select some polygon (with gizmo turned on for better look) and press shift+num7 and you’ll see that it perfect aligning in view

next poly without flat surface (2 pictures the same poly on both)


how it calculate this I can’t even imagine…
5

As a noob I’d like to use these generously provided tools, but the key re-mapping totally blindsided me and I had to revert many Preferences to get back to usability. Many of my most useful keys (“tab”) were changed.

For a clueless noob, is there a way to “ease into” MACHIN3tools, or should I just wait a few months until I can appreciate it properly?

Tab is arguably more useful in MACHIN3tools though.

MACHIN3tools is highly customizeble. you can just disable all but one tool or pie menu.


here everything is activated

A deactivated tool won’t be registered(Blender won’t know about it) and won’t set any keymap either.

Even if a tool sets a keymap, it won’t erase any pre-existing ones, the newly set keymap will simple take precedence. Nothing is re-mapped, nothing is lost.

You can change keymaps to different keys easily from the Keymaps panel, you can also disable just the keymaps by unchecking their boxes.

Unchecking keymap boxes really doesn’t make a lot of sense though, especially for the pie menus. You should just disable the entire pie, see above.

Disclaimer: The Customize tool is different, in that it actually modifies some keymaps, which I haven’t really documented so don’t recommend people do that unless they are adventurous, ha.

For details, see the videos where I go over all of this.

5 Likes

Hello,

The workspace Pie is not working. I’ve tried all of the workspace but only Scripting worked. I don’t know why?

There is not enough information on how to customize the workspace pie in UI/pie.py ? Can you provide some more information or provide some solution to fix the issue?

I also noticed when I used the Collection Pie, They are not exactly synchronized with the original Layout/Collection

For example, on the original Collection, I closed the “eye” and I also do same with Collection Pie by closing it and opening it. but nothing happened. I also had to open the eye from Original Collection and try do same with Collection Pie and it worked just fine.

you may want to improve on this part for synchronization.

Hope this would help you improve your addon. and it’s an excellent addon. keep up the work.

EDIT:
ignore the scratched lines, i figured it out. and I got it working. it’s just misspelling names for these workspace.

and where do i find the names for these icons so i can change the icons in workspace pie?

The way the eye icon hides in the outliner(hiding on the view layer) is not accessible to python, at least it wasn’t when I build the pie, so instead, I hide in the viewport(across all view layers).

Blender ships with an ‘Icon Viewer’ addon, which allows you to view/search icons from the scripting workspace.

ah I see, alright, thank you for answering my question.

have a great day!

1 Like

@MACHIN3 using most (all?) of these tools, I see that upon activation it toggles the display of sharp edges on the mesh to On. Perhaps it would be preferable to give the option to the user whether they want this or not as a checkbox in the plugin preferences?

In the meantime, would you happen to know which .py file(s) I could modify to turn off this behaviour? I don’t want my modeling tools to alter my edge displays :slight_smile:

It’s actually turned on by default in Blender. The ShadeSmooth tool however, ensures it is enabled, but only if you run it with ALT pressed, becauses that’s the purpose of ALT: setting sharps.

ui/operators/shade_smooth_flat_auto.py

1 Like

I’m sorry, I’m a dumbass - I meant to ask this in the MeshMachine tools. Sorry for the confusion!

Sorry if this has been asked already.
Is there a way to keep the pop-up visible after clicking on it?
For instance, when I use the shading menu and I switch to MatCap I’d also like to pick a material but the moment I click on MatCap the pop-up disappears.
I’ll look at the preferences again maybe there’s an option that I’ve overlooked.

There isn’t, pie menus close automatically once you click an item.

Continuing the discussion from MACHIN3tools:

hey!

I tried to use your tools addon with the latest Bledner version, but I get an error message after I used your custome settings

you know what happened here?

Yes, 2.82 doesn’t seem to have a preferences for multi sampling anymore, so trying to set it fails.

Hello,

I like your Tab pie menu, and I have a question:
Is there a way to assign 1 2 3 4 key on keyboard for vert/edge/poly/object without pressing Tab?

Doesn’t that defeat the purpose of the pie?

If you want number keys to set modes, just don’t use my modes pie, its default behaviour of Blender since 2.80. You will have to remap the smart tools to different keys of course, if you have them activated.

Your tools have one feature, I can immediately go into polygon mode from object mode, or edge from object. Blender default have only switching between Object and Edit mode and then switch to vert/edge/poly…

Nope switch to the industrial keymap and search for keymap 1, 2, 3 etc. It should be possible to copy the keymap from there to your keymap config by pasting the Code from there.

1 Like

Yes, that what I wanted, thanks!

@MACHIN3

I was using collection pie to move an object to Main folder but it came up with error:

Traceback (most recent call last):
File “C:\Users\PCMAC\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\MACHIN3tools\ui\operators\collections.py”, line 116, in execute
bpy.ops.object.move_to_collection(‘INVOKE_DEFAULT’)
File “I:\Programs\Blender 2.82\2.82\scripts\modules\bpy\ops.py”, line 199, in call
ret = op_call(self.idname_py(), C_dict, kw, C_exec, C_undo)
RuntimeError: Operator bpy.ops.object.move_to_collection.poll() failed, context is incorrect

location: :-1

I just clicked “Move to” and the error message showed up above.

what’s the cause of this?

Being in local view. I’ll see if I can make it work in the 0.4 release.